Completamento automatico dei moduli

Con Firefox è possibile memorizzare i dati inseriti nei moduli delle pagine web (detti anche caselle di testo). Dopo aver inserito un testo in un modulo di una pagina, come ad esempio in un campo di ricerca, alla successiva visita della pagina i dati immessi in precedenza potranno essere nuovamente utilizzati. Questo articolo spiega come utilizzare il completamento automatico dei moduli e come cancellare o impedire il salvataggio dei dati inseriti nei moduli.

Utilizzare la funzione di compilazione automatica dei moduli

Per richiamare un testo precedentemente inserito in un modulo:

  1. Digitare le prime lettere dell'elemento nel campo del modulo. Verrà visualizzato un menu a discesa con i termini inseriti in precedenza nel modulo.
    • Se si preme il tasto Freccia in basso quando il campo è vuoto, potrebbero comparire tutti i termini memorizzati per quel particolare modulo.
  2. Premere il tasto Freccia in basso per selezionare l'elemento da riutilizzare. Premere successivamente Invio quando l'elemento è selezionato. Il testo scelto comparirà nel campo del modulo. È anche possibile selezionare l'elemento desiderato con il clic del mouse.

Eliminare singoli elementi del menu a discesa

Se si desidera eliminare dalla cronologia di Firefox uno degli elementi inseriti in precedenza in un modulo:

  1. Fare clic sul campo del modulo e premere il tasto Freccia in basso per visualizzare tutti gli elementi memorizzati. Si può limitare il numero di elementi da visualizzare digitando le prime lettere dell'elemento da eliminare.
  2. Utilizzare il tasto Freccia in basso o il cursore del mouse per evidenziare l'elemento da eliminare.
  3. Premere Maiusc+Canc per eliminare l'elemento.

L'operazione può essere ripetuta per altri elementi dello stesso modulo.

Cancellare la cronologia dei moduli

Se si desidera cancellare tutti gli elementi memorizzati nella cronologia del completamento automatico dei moduli:

  1. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox, selezionare Cronologia e successivamente Cancella la cronologia recente....Sulla barra dei menu, fare clic sul menu Strumenti e successivamente Cancella la cronologia recente....Nella parte superiore della finestra di Firefox, fare clic sul menu Strumenti e selezionare Cancella la cronologia recente....
  2. Nel menu a discesa accanto alla voce Intervallo di tempo da cancellare: selezionare tutto.
  3. Fare clic sulla freccia accanto a Dettagli per visualizzare l'elenco delle voci che è possibile cancellare.
  4. Verificare che sia selezionata solo la voce Moduli e ricerche.
  5. Fare clic su Cancella adesso. La finestra di dialogo verrà chiusa e le informazioni relative al completamento automatico saranno cancellate.
  1. Nella parte superiore della finestra di Firefox, fare clic sul pulsante Firefox, selezionare Cronologia e successivamente Cancella la cronologia recente....Sulla barra dei menu, fare clic sul menu Cronologia e successivamente Cancella la cronologia recente....Nella parte superiore della finestra di Firefox, fare clic sul menu Cronologia e selezionare Cancella la cronologia recente....
  2. Nel menu a discesa accanto alla voce Intervallo di tempo da cancellare: selezionare tutto.
  3. Fare clic sulla freccia accanto a Dettagli per visualizzare l'elenco delle voci che è possibile cancellare.
  4. Verificare che sia selezionata solo la voce Moduli e ricerche.
  5. Fare clic su Cancella adesso. La finestra di dialogo verrà chiusa e le informazioni relative al completamento automatico saranno cancellate.

Impedire il salvataggio del contenuto dei moduli

Se si desidera evitare il salvataggio dei dati inseriti nei moduli, è possibile disattivare completamente questa funzione:

  1. Nella parte superiore della finestra di Firefox fare clic sul pulsante Firefox e selezionare Opzioni.Dal menu in alto nella finestra di Firefox fare clic sul menu Strumenti e selezionare Opzioni.Dalla barra dei menu fare clic sul menu Firefox e selezionare Preferenze....Dal menu in alto nella finestra di Firefox fare clic sul menu Modifica e selezionare Preferenze.

    Fare clic sul pulsante dei menu New Fx Menu e selezionare OpzioniPreferenze.

  2. Selezionare il pannello Privacy.
  3. Dal menu a discesa Impostazioni cronologia: selezionare utilizza impostazioni personalizzate.
  4. Deselezionare la casella alla voce Conserva la cronologia delle ricerche e dei moduli.
  5. Fare clic su OK per chiudere la finestra delle opzioniFare clic su Chiudi per chiudere la finestra delle preferenzeChiudere la finestra delle preferenze.

La disattivazione della funzione di completamento automatico dei moduli impedirà anche il salvataggio della cronologia delle ricerche quando si utilizza la Barra di ricerca.

Risoluzione dei problemi

Se si riscontra l'impossibilità di salvare e riutilizzare i moduli delle pagine web, leggere l'articolo I dati inseriti nei moduli non vengono salvati.



Questo articolo è basato sulle informazioni contenute in Deleting autocomplete entries (mozillaZine KB)



Condividi questo articolo: http://mzl.la/LRnhjb

È stato utile questo articolo? Attendere...

Utenti che hanno contribuito a scrivere questo articolo: underpass, michro. Tutti possono contribuire.