Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 125 URLs missing in suggestions dropdown

  • 5 respostas
  • 0 have this problem
  • 2 views
  • Last reply by Ken

more options

I've just updated to Firefox 125 and now, when I start to type in the URL bar and get my suggestion dropdown of previously visited pages, I no longer can see the actual url for each entry. All I see is the top level name for each entry.

This is not helpful, as I may have perviously visited a number of pages on that site and the information shown does not give me a way to differentiate sufficiently between those pages.

How can I get the exact url displayed on the suggestions dropdown.

How can I get those top level descriptions NOT displayed, so that only the urls are shown?

I've just updated to Firefox 125 and now, when I start to type in the URL bar and get my suggestion dropdown of previously visited pages, I no longer can see the actual url for each entry. All I see is the top level name for each entry. This is not helpful, as I may have perviously visited a number of pages on that site and the information shown does not give me a way to differentiate sufficiently between those pages. How can I get the exact url displayed on the suggestions dropdown. How can I get those top level descriptions NOT displayed, so that only the urls are shown?

Chosen solution

This can also be caused by CSS code in userChrome.css in case you use this file.

More info about userChrome.css/userContent.css in case you are not familiar:

Ler a resposta no contexto 👍 0

All Replies (5)

more options

Hi, which feature has the problem?

Shortcut List

When you first click in the address bar, before you type anything for Firefox to match off of, the drop-down shows the first 8-10 shortcuts from the built-in Firefox Home / new tab page.

  • If you don't want to see a list when you first click in the bar, you can turn this off on the Settings page. See: Address bar autocomplete suggestions in Firefox ("How can I control what results the address bar shows me?" section)
  • If you want the shortcut list but need to curate them to be more useful, see: Customize items on your Firefox New Tab page.
  • If you want to see your frequently visited sites like Firefox 77 and earlier, type a space in the bar.

Autofill

As you type, Firefox shows top level site address suggestions right within the bar. There is a hidden setting to show fuller URLs from your history within the bar if you want to try that out. There also is a hidden setting to stop in-URL-bar autofill suggestions.

Autocomplete Drop-down

As you type, Firefox shows matches from bookmarks, history, open tabs, your default search engine, your search history, and some reference sources. To control what is suggested, see the first article mentioned above.

Can you get it working the way you want?

Helpful?

more options

Full URLs should appear in the address bar suggestions dropdown, appended at the end of the title and visible in the hover tooltip.

Does it still happen in Troubleshoot Mode?

Helpful?

more options

Hmmm, Yes... In Troubleshooting mode the urls magically appear. So maybe an addon is causing this? I'll try that.

Helpful?

more options

Chosen Solution

This can also be caused by CSS code in userChrome.css in case you use this file.

More info about userChrome.css/userContent.css in case you are not familiar:

Helpful?

more options

Thank you cor-el!!!!!!

A *long* time ago, I had added and customized my profile /chrome folder using... https://github.com/Aris-t2/CustomCSSforFx. I had totally forgotten that!

Disabling my /chrome folder makes the suggestion dropdown show the exact URLs as it should.

Looking at the github, I can see that there is a new version as of last week. I'll be updating to the new version and tweaking it to the way I want. I'm 100% sure this will cure my problem (and who knows maybe even other problems I didn't even know I had!)

Two thumbs up!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.