Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Browser stopped warning that page has changed 97.0.1 (64) (now 99.0.1)

more options

My work consists mainly of capturing accounting data online. It is important that the browser warns me if I try to close or navigate away from a page if the data entered has not been saved or updated, but I no longer get these warnings.

Please help.

My work consists mainly of capturing accounting data online. It is important that the browser warns me if I try to close or navigate away from a page if the data entered has not been saved or updated, but I no longer get these warnings. Please help.

Modified by Joshua Jacobs

Chosen solution

Do you use any add-ons or user scripts that might affect whether pages can hook into the beforeunload event? If none seems like an obvious candidate, you can test in Firefox's Safe/Troubleshoot Mode. In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

Read this answer in context 👍 1

All Replies (8)

more options

By default I don't recall that being removed or changed. The user if I recall must do that action to uncheck that warning box.

How to configure Close Tab warnings in Firefox https://support.mozilla.org/en-US/kb/how-configure-close-tab-warnings-firefox#:~:text=and%20select%20Settings.,uncheck%20it%20to%20disable%20them.

Helpful?

more options

Dear Donthavecow,

The links you provided only explain about warning when one closes Firefox when multiple tabs are open.

That is not the problem.

I need a warning if I try to close or navigate away from a page UPON WHICH I HAVE ENTERED DATA THAT NEEDS TO BE SAVED OR UPDATED.

Thank you.

Helpful?

more options

You can choose to always allow websites to show alerts (even after you clicked the "Do not allow this website to prompt you again").

  1. Go to about:config and type dom.successive_dialog_time_limit in the search box.
  2. Choose number and click +. Set the value to "0" and choose the check button.
  3. Close and reopen Firefox.

Helpful?

more options

Joshua Jacobs said

I need a warning if I try to close or navigate away from a page UPON WHICH I HAVE ENTERED DATA THAT NEEDS TO BE SAVED OR UPDATED.

Sites can hook scripts into the beforeunload event to give you an opportunity to stay on the page instead of leaving.

If the site does it in other browsers, and it previously worked in Firefox, too, check whether the feature has been globally switched off:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we are restoring the default setting, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste beforeunload and pause while the list is filtered

Firefox should display four preferences.

(3) If the dom.disable_beforeunload preference is bolded and has a value of true, double-click it to restore the default value of false

I have a silly test page here to see whether it is working: https://www.jeffersonscher.com/res/beforeunload.html

Helpful?

more options

Zian said

You can choose to always allow websites to show alerts (even after you clicked the "Do not allow this website to prompt you again").
  1. Go to about:config and type dom.successive_dialog_time_limit in the search box.
  2. Choose number and click +. Set the value to "0" and choose the check button.
  3. Close and reopen Firefox.

Thanks, but I don't have a dom.successive_dialog_time_limit setting :(

Helpful?

more options

jscher2000 - Support Volunteer said

If the dom.disable_beforeunload preference is bolded and has a value of true, double-click it to restore the default value of false I have a silly test page here to see whether it is working: https://www.jeffersonscher.com/res/beforeunload.html

Thank you for the help, but no solution; my dom.disable_beforeunload is already false; when I click Go! on silly-test-page only the time changes at the top, whether my preference is true or false.

Helpful?

more options

Chosen Solution

Do you use any add-ons or user scripts that might affect whether pages can hook into the beforeunload event? If none seems like an obvious candidate, you can test in Firefox's Safe/Troubleshoot Mode. In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

Helpful?

more options

jscher2000 - Support Volunteer said

Do you use any add-ons or user scripts that might affect whether pages can hook into the beforeunload event? If none seems like an obvious candidate, you can test in Firefox's Safe/Troubleshoot Mode. In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. If Firefox is running: You can restart Firefox in Safe/Troubleshoot Mode using either:
  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button). If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button). Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings. Any improvement?

THANK YOU! The "Malwarebytes Browser Guard" extension prevents the attached message from being displayed.

I'm very grateful for the solution!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.