Sykje yn Support

Mij stipescams. Wy sille jo nea freegje in telefoannûmer te beljen, der in sms nei ta te stjoeren of persoanlike gegevens te dielen. Meld fertochte aktiviteit mei de opsje ‘Misbrûk melde’.

Learn More

Dizze konversaasje is argivearre. Stel in nije fraach as jo help nedich hawwe.

Use of Google Translator adds incredible amounts of links in the browser's history

  • 12 antwurd
  • 0 hawwe dit probleem
  • 36 werjeftes
  • Lêste antwurd fan pebredai

more options

When you use Google's Translator, this application automatically adds a link to Firefox's history each time you modify even a tiny bit of what you are translating.

This means that sometimes, you can add 1,000 links within a day when you incrementally translate a piece of text, what is the default way to do.

Today, two minutes of that work generated 40 links!

Example of a typical link:

https://translate.google.com/?hl=de&sl=de&tl=en&text=Manchmal%20ist%20es%20wichtiger%2C%20etwas%20zu%20schenken%2C%20als%20wie%20es%20beim%20Adressaten%20ankommt&op=translate

And that was only a small piece of text!

In my history, there are in between 50,000 of these, despite regularly deleting many of them.

Even on a relatively fast notebook, deleting 1,000 links in the history takes minutes.

I posted the problem to Google Translate as a feedback many times, but they never answered.

Is there a possibility within Firefox to selectively get rid of this permanent garbage?

That would be wonderful.

When you use Google's Translator, this application automatically adds a link to Firefox's history each time you modify even a tiny bit of what you are translating. This means that sometimes, you can add 1,000 links within a day when you incrementally translate a piece of text, what is the default way to do. Today, two minutes of that work generated 40 links! Example of a typical link: https://translate.google.com/?hl=de&sl=de&tl=en&text=Manchmal%20ist%20es%20wichtiger%2C%20etwas%20zu%20schenken%2C%20als%20wie%20es%20beim%20Adressaten%20ankommt&op=translate And that was only a small piece of text! In my history, there are in between 50,000 of these, despite regularly deleting many of them. Even on a relatively fast notebook, deleting 1,000 links in the history takes minutes. I posted the problem to Google Translate as a feedback many times, but they never answered. Is there a possibility within Firefox to selectively get rid of this permanent garbage? That would be wonderful.

Alle antwurden (12)

more options

You could use translate.yandex.com instead, it only adds history after a delay.

You can avoid history entirely by using a private window for translations.

more options

Dropa

1. " So did you try like Windows clear cache/history to see what happens as well? "

What does let you think I would work on Windows? I'm on a Linux OpenSUSE Leap system.

2. " I don't recall google translate doing this much history or cache holding? Are you sure this is coming from Google translate or Firefox browser and not something else? "

' ... and not from something else? ' You seem to suggest I'm a bit simple-minded, don't you?

3. " You should show a screenshot of the history to verify what is doing when using Google Translate if that is the case. "

It seems to me that you didn't take the time to accurately read my message above, did you?

Thus I repeat my text:

Example of a typical link:

https://translate.google.com/?hl=de&sl=de&tl=en&text=Manchmal%20ist%20es%20wichtiger%2C%20etwas%20zu%20schenken%2C%20als%20wie%20es%20beim%20Adressaten%20ankommt&op=translate

Are you sure to need more of them? There are currently 52,093 links of that kind in my Firefox's history. I recently deleted about 10,000...

And you are a 'Top 10 Contributor' ? Thanks a lot for trying to teach others than me: I was asking for intelligent thoughts.

more options

I nearly always paste into Google Translate, so I hadn't noticed this strange behavior of updating the URL every time you change a character.

I tested with bonjour mes amis and this was not sent to the cloud to translate until after I paused typing, but there is synthetic history for every character typed. (Screenshot attached.) I notice the same in Google Chrome (screenshot attached, different edit), so it's possible there is a web standard involved here.

The issue of sites adding entries to history through JavaScript more commonly surfaces in the context of news sites that add new URLs as you scroll down through a series of story headlines. This makes it difficult to go "Back" to exit the site. There is an experimental preference that users can test to address that issue, but it only seems to trim excess Back button history and not actually prevent the accumulation of entries in browsing history. (https://connect.mozilla.org/t5/discussions/firefox-needs-to-do-something-about-back-button-history-loading/td-p/4678 )

Because Google's scripting is notoriously complex, I'm reluctant to dive into how they are doing it to see whether that might suggest any way to circumvent it.

Until then, the most obvious workaround is to do your translations in a private window and switch back to a regular window for your other tabs. If there's an intermediate URL that you do want to keep, you can Ctrl+D bookmark it for future reference in a regular window since the URL seems to always be up-to-date with your input.

more options

jscher2000

Thank you very much for your helpful reply!

The screenshot you show exactly matches what disturbs me all the time.

" Until then, the most obvious workaround is to do your translations in a private window and switch back to a regular window for your other tabs. "

Good idea indeed, under the condition however that I keep it in mind all the time.

Firefox really owes us a more general solution for this problem.

more options

The following recently posted add-on is designed to clean up new history entries for a site as you brows. I'm not thrilled that it has a non-open license, and the author's attitude in response to reviews is... bad. But, sometimes you need what you need. Maybe it's worth a try.

https://addons.mozilla.org/firefox/addon/history-auto-delete/

more options

Thanks again jscher2000.

I installed the add-on but it doesn't work yet. I'll have a closer look at it tomorrow.

more options

You would expect that this is done via XHR and not by immediately modifying the URL. Modifying the URL could be done when you are finished typing (in idle time) or possibly click a Translate button, but currently the translate is done automatically on the fly (as you type) (not sure if you can still disable this).

more options

jscher2000

I installed last week the add-on you mentioned above:

https://addons.mozilla.org/firefox/addon/history-auto-delete/

and gave it the access rights it expects.

Unluckily, it doesn't work anywhere. Everywhere, on any active tab, it complains

" Can't read nor change anything on this page. "

No idea what happens :-(

more options

pebredai said

Unluckily, it doesn't work anywhere. Everywhere, on any active tab, it complains " Can't read nor change anything on this page. " No idea what happens :-(

You can ignore that small print. It means that the add-on doesn't have permission to view/edit the current pages. But when you installed it, you granted it permission to read/edit your history, which I think is all it needs.

If you click that button/row, or the gear button, it hopefully will take you to the panel where you can "Manage" the extension. Click Options while you're there and you should be able to add Google Translate to the sites to clean history for. The examples list shows that you should use this syntax:

^https://translate\.google\.com
more options

jscher2000

Thanks for the reply, but

^https://translate\.google\.com

is already on the add-on's list:

https://i.postimg.cc/rFJkBdkn/Screenshot-20230801-014120.png

I can't change anything there.

Maybe it's due to my Linux context (OpenSUSE LEAP 15.4) ?

more options

Hmm, I don't think it should matter what OS you are running. I guess if that one doesn't work, you may need to try a different one.

more options

jscher2000

I wrongly clicked on the 'Solved my problem' button attached to your last reply.

The problem of course remains unsolved.

But with the arrival of the newest Firefox revision (115.1.0esr) on my system, deleting 20,000 history entries created by Google Translate now takes only 3 minutes (10 times less than earlier).

The whole trash now is away.

Best greetings from Germoney pebredai