Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

why does the telegraph ask for subscription

  • 4 replies
  • 2 have this problem
  • Last reply by FredMcD

more options

i receive the Telegraph by email each day without a subscription,. when I used Internet explorer the email link would open the Telegraph page and let me read it. now I am using Firefox, much much better, when this links from my email it opens the window then a second window that askes me to subscribe to the Telegraph and will not let me read the page. Why is this and how can I make it work like it does on Internet Explorer?

Thanks for your help. so glad my daughter got me onto Firefox.


All Replies (4)

more options

Can you provide more info like are you able to close the window, if you close the window then are you able to view pages, the link which you are visiting etc..

If you able to view pages after closing the window then might be you might need to use pop-up blocker to block such pop-ups and then you will not get such pop-ups.

Modified by Manish Mishra

more options

You can try these steps in case of issues with web pages:

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

im really unclear about "telegraph" can you detail what type of system is sending these messages? is it a work related private pop server or something else? most message popups allow you to x out if it asks for registration or login, do you have an X or other "opt out" button?

more options

Is it a separate window, or a window within the window? If the latter, mouse over the window. Right click on it and select Inspect Element. There is now a small black bar on your screen. Press the box on its right side. Now move your mouse around until the offending box is chosen, then click. Now go to the black bar. On the right side is a down arrow. Click it. You now have a small menu. Select Delete Node. You may need to do this several times. If you make a mistake, just reload the page. This is how I get rid of those pesky things.