X
Tap here to go to the mobile version of the site.

Support Forum

How can I stop Firefox from redirecting me to a Yahoo search page when it gets a 404 - Page not found error?

Posted

I don't have a Yahoo toolbar (nor have I ever), and I can't find any add-ons that might be causing the problem. What should I do?

I don't have a Yahoo toolbar (nor have I ever), and I can't find any add-ons that might be causing the problem. What should I do?

Chosen solution

I assume that you already tried Safe Mode?

Check the connection settings.

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You can check for problems with preferences and possibly reset all prefs.


You may have an ISP that automatically redirects you to a search page if a DNS look up fails.
That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search.
In such cases you need to contact your ISP and ask for a DNS server to opt-out of that feature.
You can also check if there is a link on the search results page to go to your ISP and opt-out.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Version 4.9.1.16010
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • iPhoto6
  • WebEx64 General Plugin Container Version 202
  • D'Fusion Web Plug-In (3.20.20224.0)
  • D'Fusion Web Plug-In for Safari 64 bits (3.20.20224.0)

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17696 solutions 160119 answers

Chosen Solution

I assume that you already tried Safe Mode?

Check the connection settings.

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You can check for problems with preferences and possibly reset all prefs.


You may have an ISP that automatically redirects you to a search page if a DNS look up fails.
That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search.
In such cases you need to contact your ISP and ask for a DNS server to opt-out of that feature.
You can also check if there is a link on the search results page to go to your ISP and opt-out.

I assume that you already tried Safe Mode? *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Check the connection settings. *Firefox > Preferences > Advanced > Network : Connection > Settings *https://support.mozilla.org/kb/Options+window+-+Advanced+panel If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": *https://support.mozilla.org/kb/Firefox+cannot+load+websites+but+other+programs+can You can check for problems with preferences and possibly reset all prefs. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences ---- You may have an ISP that automatically redirects you to a search page if a DNS look up fails.<br /> That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search.<br /> In such cases you need to contact your ISP and ask for a DNS server to opt-out of that feature.<br /> You can also check if there is a link on the search results page to go to your ISP and opt-out. *http://en.wikipedia.org/wiki/DNS_hijacking

Question owner

I tried resetting my preferences and clearing the history (I'm not sure if the latter had anything to do with this, but I'm mentioning it just in case), and now it seems to have been solved! Thank you!

I tried resetting my preferences and clearing the history (I'm not sure if the latter had anything to do with this, but I'm mentioning it just in case), and now it seems to have been solved! Thank you!