Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

screen freezes unless I keep moving the mouse

  • 74 replies
  • 107 have this problem
  • Last reply by Andrew

more options

when I enter a website, I have to keep the mouse moving or the screen freezes

Chosen solution

The update to Firefox 25.0.1, which should fix the particular problem of pages not loading unless there is mouse movement, has just been released now.

  • If you have downgraded to Firefox 24 before to work around the issue, please go to Firefox > Options > Advanced > Update and turn automatic updates back on. Then go to Firefox > Help > About Firefox which should trigger the update to Firefox 25.0.1. In case you need to download the setup file for Firefox 25.0.1 separately you can do so from
  • If you were test-running Firefox 26 beta, you can either choose between switching back to the Firefox 25.0.1 release (use the link above to download the installer) or stay with the beta version - the latter option has the advantage of receiving new features weeks before they are landing in the regular Firefox versions and being able to sound an early alarm in case such serious regressions are occurring, so there is enough time fixing problems ahead of a general release and minimize the general impact.
  • If you were one of the people who helping out by checking the Nightly 28.0 developer try-build, please uninstall it from the windows control panel (but keep the option to remove your profile data unchecked!) and switch back to the general release version which can be obtained through the link provided above.

In case you continue experiencing the the same page freezing issue even after an update to Firefox 25.0.1 or have anything else you need help with, please open up a new question, because this thread is already pretty long and complex which will make it very difficult to keep track of or respond to individual issues.

Thanks for your patience and all the feedback you've provided which helped us getting a fix for the problem shipped as quickly as possible.

Read this answer in context 👍 3

All Replies (20)

more options


This seems to be an known issue with version 25. Please try disabling hardware acceleration.

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

Thanks for the ideas, all of which I have tried. There were some updates due for the graphics card which I have applied. The problem also occurrs in f/f Safe Mode. I am still wiggling my mouse! I have tried internet explorer (which I dislike!) and the problem disappears!

more options

After installing those graphics card updates did you disable video hardware acceleration?

more options

I also have this problem. On a guess that it might be connected to wireless mouse/keyboard function, I replaced them with wired devices. No difference. I have tried all the suggestions with no positive results. I am grudgingly returning to Explorer until this can be resolved - it's too disruptive and time cnmsuming. I will watch my mail for email notice that the issue has been solved.

more options

all the above applies to me too, my graphics card is updated, and i unchecked the option for hardware acceleration and waited a day it is still doing it. please advise

more options

hello, mozilla developers have made available a firefox build without the changes that are now suspected to have caused the bug in firefox 25. would you be willing to test-run this build and confirm that the rendering issue isn't present in there?

first a disclaimer, this is an experimental developer build, it will install beside your current firefox version but use the same profile (with all your bookmarks, passwords and user data) - so as a precaution please back-up your profile as it is described at before you proceed.

then you can go ahead and download & install the test-build from - you have to close all other instances of firefox before you can run it. please take a look around in it and see if the page loading issues are reproducible while using this build and please report back either here in the forum or directly in the corresponding bug report at

afterwards you can uninstall the nightly browser from the windows control panel, but make sure NOT to check the box to remove your personal data during the uninstalling process, as this would also affect your regular firefox.

thanks a bunch!

more options

sure i'll do it i don't save bookmarks or even know what profile is so settings don't have to be kept for me. Do I just click on the link above to download the test version. I hope it works because I started using IE again but would like to stay with Firefox, thanks

more options

Yes you can just click on the link and download and run the installer. as a comparison you can also run the regular nightly version from (which probably still contains the fault).

more options

I installed 28.0a1 (2013-11-07)

This got rid of the 'on mouse movement' issue.

Thank you. :-)

more options

i'm confused i downloaded the installer and now I have the browser nightly on my computer along with the firefox browser. The nightly browser works fine. But the firefox browser still has the mouse movement problem. What is nightly version?

more options

hello kb_lonski, thanks for the feedback - could you uninstall the test-build and also download and run the regular nightly version from to confirm that the scrolling issue is still present there for reasons of comparison?

@tangerine3 - this is what i've tried to explain above. the nightly version is an early developer version (or alpha version of firefox) where all bug fixes and changes are first tested before they ship in the normal firefox versions. as i've also described above, the nightly test-build also installed separate from your regular firefox browser (which is unaffected by that and still shows the rendering problem) - this was just for testing purposes, and since you've reported back that the scrolling issue isn't present in the nightly-testbuild everything turned out as expected. could you also try using the regular nightly version from like i've asked kb_lonski and confirm that opposite to the nightly test-build it still exhibits the problem...

thank you!

more options

I have loaded the Nighly program and it seems that the mouse issues have disappeared. However, it seems to be slower than the regular FireFox. It this because it is experimental, or just my imagination?

more options

Uninstalled 28.0a1 (2013-11-07) and Installed 28.0a1 (2013-11-08)

Mouse issue returns, along with slowness noted by previous user. The version 28.0a1 (2013-11-07) is faster on my older Dell.


more options

since kb_lonski has already stated that 28.0a1 11/8 returns the mouse problems I'm sticking with the nightly version from 11/7. Unless the download from mozilla will not replace the version from 11/7. Also don't know which one to download Windows express or windows standard.

more options

thanks for all your feedback - running the nightly test build was just meant for testing purposes and not as a permanent workaround though. you might also want to consider downgrading to firefox 24 at the moment until the issue gets resolved: Install an older version of Firefox

i'll report back here in this thread once there is a fix available - you can also follow along any progress in tackling this issue yourselves by keeping an eye on bug #933733.

more options

Hello, I'm the Firefox dev who broke this. Sorry about that. I'm looking into a proper fix now. It would be really useful to know what version of Windows you are using if you've had this problem. Thanks!

more options

I have been monitoring this thread since I have also been affected by this "bug". I am running the following windows version: 5.1 (build 2600.xpsp_sp3_qfe.130704-0421: service pack 3). Any estimate at this point regarding a resolution?

more options

I am using Windows XP, with all the latest updates (automatically updated).

more options

I have just reinstalled 24.0. The speed is back and the mouse problem is not there. Thanks for suggesting this option as an interim solution.

more options

I have this problem also, I have unchecked hardware acceleration which didn't solve the problem. I loaded version 24 instead of version 25 that seems to fix it but everytime my PC restarts or Firefox restarts I end up with version 25 again and have to go back and load the older version. What can I do to prevent that from happening?

  1. 1
  2. 2
  3. 3
  4. 4