X
Tap here to go to the mobile version of the site.

Support Forum

Firefox does not display correctly and I don't know why

Posted

I have just finished a complete re-installation of Windows 7 on my desktop, I downloaded and installed Mozilla Firefox at its most recent version (24.0). It has no additional add ons or features from a third party and it has not been customised other than its browsing behaviour and to show the menu bar.

I have noticed that for the last 24-48 hours when Mozilla starts up it is not displaying correctly, the menu bar is blacked out completely giving the impression there is no menu bar (File, Edit etc) and when a new tab opens up there are repeating characters like the x at the side and the letters that make up the word New Tab as well as an absence of the basic colour scheme. I am wondering if whatever is causing this has also cause my gadgets on the desktop to stop working as well.

Currently I am using a laptop to post this question so I can't add any troubleshooting information or use the automatically add as the menu is blacked out completely. There is no profile set up on the desktop machine, I will attempt to reinstall the program, however I am not hopeful that this will correct the error.

Any ideas?

I have just finished a complete re-installation of Windows 7 on my desktop, I downloaded and installed Mozilla Firefox at its most recent version (24.0). It has no additional add ons or features from a third party and it has not been customised other than its browsing behaviour and to show the menu bar. I have noticed that for the last 24-48 hours when Mozilla starts up it is not displaying correctly, the menu bar is blacked out completely giving the impression there is no menu bar (File, Edit etc) and when a new tab opens up there are repeating characters like the x at the side and the letters that make up the word New Tab as well as an absence of the basic colour scheme. I am wondering if whatever is causing this has also cause my gadgets on the desktop to stop working as well. Currently I am using a laptop to post this question so I can't add any troubleshooting information or use the automatically add as the menu is blacked out completely. There is no profile set up on the desktop machine, I will attempt to reinstall the program, however I am not hopeful that this will correct the error. Any ideas?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • iTunes Detector Plug-in
  • SiteAdvisor
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20513.0
  • McAfee MSC FF plugin DLL
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • McAfee MSS+ NPAPI Plugin
  • NPWLPG
  • Windows Activation Technologies Plugin for Mozilla
  • Office Live Update v1.5

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

ideato
  • Top 25 Contributor
739 solutions 5346 answers

Hello digital_jay, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

also try to disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

thank you

Hello digital_jay, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. also try to disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] thank you
cor-el
  • Top 10 Contributor
  • Moderator
12521 solutions 115452 answers

Helpful Reply

Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F).

If you are in full screen mode then hover the mouse to the top of the screen to make the Navigation Toolbar and Tab bar appear.
Click the Maximize button (top right corner of the Navigation Toolbar) to leave full screen mode or right-click empty space on a toolbar and choose "Exit Full Screen Mode" or press the F11 key.

Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible.

  • Firefox menu button > Options
  • View > Toolbars (press F10 to display the menu bar)
  • Right-click empty toolbar area

Use Toolbar Layout (Customize) to open the Customize window and set which toolbar items to display.

  • check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the toolbar palette into the Customize window to the Bookmarks Toolbar
Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F). *https://support.mozilla.org/kb/how-to-use-full-screen If you are in full screen mode then hover the mouse to the top of the screen to make the Navigation Toolbar and Tab bar appear.<br /> Click the Maximize button (top right corner of the Navigation Toolbar) to leave full screen mode or right-click empty space on a toolbar and choose "Exit Full Screen Mode" or press the F11 key. Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible. *Firefox menu button > Options *View > Toolbars (press F10 to display the menu bar) *Right-click empty toolbar area Use Toolbar Layout (Customize) to open the Customize window and set which toolbar items to display. *check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar *if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the toolbar palette into the Customize window to the Bookmarks Toolbar *if missing items are in the toolbar palette then drag them back from the Customize window on the toolbar *if you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar setup *https://support.mozilla.org/kb/How+to+customize+the+toolbar *https://support.mozilla.org/kb/Back+and+forward+or+other+toolbar+items+are+missing

Question owner

Hello there and thank you for the replies. I thought that I would let you know that I discovered the cause of the problem wasn't a fault with Mozilla but an actual catastrophic system failure within Windows 7 itself caused by a bad format and then what would appear to have been a forced installation/repair over it.

The replies that had been left will come in handy should I have any problems in the future with Mozilla itself. Thank you again for your quick replies and offers of help they are and were greatly appreciated.

Hello there and thank you for the replies. I thought that I would let you know that I discovered the cause of the problem wasn't a fault with Mozilla but an actual catastrophic system failure within Windows 7 itself caused by a bad format and then what would appear to have been a forced installation/repair over it. The replies that had been left will come in handy should I have any problems in the future with Mozilla itself. Thank you again for your quick replies and offers of help they are and were greatly appreciated.