X
Tap here to go to the mobile version of the site.

Support Forum

Options/Privacy/History/custom-is set to remember. Why then are there "no items" in the library???

Posted

I want to see my history! FF 24 is set to remember browsing, download, search and form! No items it library!

I want to see my history! FF 24 is set to remember browsing, download, search and form! No items it library!

Modified by Sportster

Chosen solution

You were right, cor-el, the places.sqlite was corrupted.

I add the Places Maintenance add-on. But all it did was tell me the file was corrupted.

After shutting down Firefox, I deleted all of the places.sqlite files. I restarted Firefox and all is good. I still have my Bookmarks and only lost the most visited tabs info, which I believe will fill back in as I continue to browse with Firefox.

Thanks to both of you for your feedback.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • Next Generation Java Plug-in 10.40.2 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.04

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Standard VGA Graphics Adapter
  • adapterDescription2:
  • adapterDeviceID: 0x2562
  • adapterDeviceID2:
  • adapterDrivers: vga framebuf vga256 vga64k
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 6-21-2006
  • driverDate2:
  • driverVersion: 6.1.7600.16385
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 11
  • webglRendererMessage: [u'']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.update: False
  • browser.startup.homepage: about:blank
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.loadInBackground: False
  • dom.ipc.plugins.reportCrashURL: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 24.0
  • font.internaluseonly.changed: False
  • network.cookie.cookieBehavior: 3
  • network.cookie.lifetimePolicy: 1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1380674630
  • places.history.expiration.transient_current_max_pages: 33335
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npconduitfirefoxplugin: 0
  • plugin.state.npdeployjava: 0
  • plugin.state.npdrmv: 0
  • plugin.state.npdsplay: 0
  • plugin.state.npwmsdrm: 0
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.history: False
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.sessions: False
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.history: False
  • privacy.cpd.offlineApps: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1378528528

Misc

  • User JS: No
  • Accessibility: No
iamjayakumars 475 solutions 5852 answers

Make sure you not running Firefox in (permanent) Private Browsing mode.

If you not using Private Browsing Mode

  • Tools > Options > Privacy > History>
  • Firefox will: "Use custom settings for history":
  • Select: [x] Accept Cookies from sites
    • Accept third party cookies: "From Visited"
  • Keep until "They Expire"
  • Deselect: [ ] "Clear history when Firefox closes"
  • https://support.mozilla.org/kb/Clear+Recent+History

If you use cleanup software like CCleaner then check the settings for the Firefox application.

Make sure you not running Firefox in (permanent) Private Browsing mode. *https://support.mozilla.org/kb/Private+Browsing *Tools > Options > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use private browsing mode" If you not using Private Browsing Mode *Tools > Options > Privacy > History> *Firefox will: "Use custom settings for history": *Select: [x] Accept Cookies from sites **Accept third party cookies: "From Visited" *Keep until "They Expire" *Deselect: [ ] "Clear history when Firefox closes" *https://support.mozilla.org/kb/Clear+Recent+History If you use cleanup software like CCleaner then check the settings for the Firefox application.

Question owner

Thanks for you reply,

As you can see in my post, I have the options set to Custom and to Remember.

I can see cookies in the Show Cookies window, that's not a problem.

Even if I was using a cleanup software there's nothing there to cleanup except cookies!

I've included a couple of screenshots.

I'm not sure but I think I might have to change something in about:config even thought I haven't changed anything since I updated to FF 24

Looking forward to your response.

Thanks for you reply, As you can see in my post, I have the options set to '''Custom''' and to '''Remember'''. I can see cookies in the '''Show Cookies''' window, that's not a problem. Even if I was using a cleanup software there's nothing there to cleanup except cookies! I've included a couple of screenshots. I'm not sure but I think I might have to change something in '''about:config''' even thought I haven't changed anything since I updated to FF 24 Looking forward to your response.
cor-el
  • Top 10 Contributor
  • Moderator
12750 solutions 117147 answers

Problems with bookmarks and history not working properly can be caused by a corrupted places.sqlite database file.

You can check for problems with the places.sqlite database file in the Firefox profile folder.

Problems with bookmarks and history not working properly can be caused by a corrupted places.sqlite database file. You can check for problems with the places.sqlite database file in the Firefox profile folder. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox *https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file

Chosen Solution

You were right, cor-el, the places.sqlite was corrupted.

I add the Places Maintenance add-on. But all it did was tell me the file was corrupted.

After shutting down Firefox, I deleted all of the places.sqlite files. I restarted Firefox and all is good. I still have my Bookmarks and only lost the most visited tabs info, which I believe will fill back in as I continue to browse with Firefox.

Thanks to both of you for your feedback.

You were right, '''cor-el''', the '''places.sqlite''' was corrupted. I add the '''Places Maintenance''' add-on. But all it did was tell me the file was corrupted. After shutting down Firefox, I deleted all of the '''places.sqlite''' files. I restarted Firefox and all is good. I still have my Bookmarks and only lost the most visited tabs info, which I believe will fill back in as I continue to browse with Firefox. Thanks to both of you for your feedback.

Modified by Sportster

cor-el
  • Top 10 Contributor
  • Moderator
12750 solutions 117147 answers

Helpful Reply

You're welcome

You're welcome