X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Why won't Firefox remember my password?

Posted

Firefox used to remember my bank password, but it does not any longer. After downloading the update to version 23.0.1 today, the remember password feature appeared broken.

I tried many things and eventually got passwords working on other sites, but not my bank. I deleted the saved password from the password manager in an attempt to try and get the Remember Password prompt to show up again, but it didn't work. I checked in Exceptions and it's completely empty, so that's not it. I also tried using the bookmarklet for fixing autocomplete on sites that it's disabled and my bank doesn't appear to disable it.

I've spent an hour and a half researching this and trying everything I could but I am at a loss. This computers main user is an elderly man so having the bank remember the password is a MUST.

Additional System Details

Installed Plug-ins

  • GEPlugin
  • Google Update
  • Shockwave Flash 11.7 r700
  • 5.1.20513.0
  • MindSpark Toolbar Platform Plugin Stub for 32-bit Windows
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Foxit Reader Plug-In For Firefox and Netscape
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • avast! Online Security 8.0.1489 (wrc@avast.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Updated Ad Blocker for Firefox 11+ 0.7.7 ({4DC70064-89E2-4a55-8FC6-E8CDEAE3618C})
  • Webmail Ad Blocker 3.9.1 (gmailnoads@mywebber.com)
  • Marine Aquarium Lite 2.50.0.52860 (57ffxtbr@MarineAquarium3Free_57.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 6150SE nForce 430
  • adapterDescription2:
  • adapterDeviceID: 0x03d0
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvd3dum
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-31-2013
  • driverDate2:
  • driverVersion: 9.18.13.783
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 6150SE nForce 430 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130815180504
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.0
  • gfx.direct3d.checkDX10: False
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1376944119
  • places.history.expiration.transient_current_max_pages: 46937
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 0
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1376939273

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Websites remembering you and automatically log you in is stored in a cookie.

  • Create a cookie Allow exception to keep such cookies, especially for secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > Cookies: Exceptions

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.


In case you are using "Clear history when Firefox closes":

  • do not clear the Cookies
  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception.

Question owner

I tried what you posted but it didn't appear to have any effect. I downloaded some password manager extension and solved the headache.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Websites may be using autocomplete=off to prevent Firefox from saving and filling name and password.

You can remove autocomplete=off with a bookmarklet to make Firefox save names and passwords and other form data.

LLLActive 0 solutions 3 answers

It could be same problem I have on Mac OSX 10.7.5 - I asked the Question

"After every update on Mac the Saved Passwords list is deleted, how can it be recovered?" just before this question.

The Saved Passwords List is empty after an Update of Firefox. Check if your Saved Passwords List is empty after the update.

I don't know how to get there in the Setup for Windows. I have only Mac. In Mac it is in the Menu under:

"Firefox -> Preferences -> Security -> 'Saved Passwords' Button"

HTH

Edit: I see you looked at Firefoxe's internal password manager and deleted the passwords there to see if it recovers. My answer is only if the Saved Passwords List is empty after an update by Firefox.

Modified by LLLActive

LLLActive 0 solutions 3 answers

@cor-el:

I am alarmed to think that passwords are saved in cookies or in cookies.sqlite by Firefox. Is this really true? If passwords are saved by banks or any other website in cookies or cookies.sqlite - then I'l delete all cookies and never use them - what if some Trojans get hold of the passwords stored in a cookie or cookies.sqlite? - they are readable by the whole world ...

Question owner

Thanks for the help, I do appreciate it. Just wanted to let you know that the bookmarklet thing did not work for me, I already tried it multiple times and it just kept coming up saying 0 sites were using autocomplete=off.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Is your issue with Firefox not saving the password in the Profile Manager or do you want the website to remember you, so you do not need to login when visiting the next time?

If the latter is the case then you have a problem with cookies that aren't kept or are corrupted.

Question owner

The issue is with Firefox not saving the password or asking me to save the password. It used to know it, but it stopped working on it's own, so I deleted the password from the list to try and get Firefox to ask me if I wanted it to remember it again - it didn't do it though.

Right now I'm content to leave well enough alone, the add-on I downloaded gets the job done.

CraigStallone 0 solutions 29 answers

@bkgarris: Where do I go to get a password manager extension like you downloaded? I've had a problem with Firefox remembering passwords since I bought my current computer - in March.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never Remember History).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

It is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox.
Rename the key3.db and signons.sqlite files in the Firefox profile folder.
You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action.
You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost.
If that has worked then you can remove the renamed files that are no longer needed.

See also:

CraigStallone 0 solutions 29 answers

@cor-el: under privacy, I have Firefox set to remember history. I also have it telling sites that I don't want to be tracked, could that make a difference?

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Hi CraigStallone

No. The do-not-track setting only makes Firefox send a special header to the server. It doesn't have any local effects on your computer.

What did you try so far?

Do you mean names and passwords in the Password Manager or do you mean that you are no longer logged on to (remembered by) websites after closing and restarting Firefox?

CraigStallone 0 solutions 29 answers

I tried deleting and reinstaling Firefox, as was suggested to me in (https://support.mozilla.org/en-US/questions/959336?page=2#answer-473707) this thread. I was also told to try creating a new profile, but the instructions I saw for how to do that seemed like they were designed for WinXP. I held off on using them, because I'm using Windows 7, and I don't know whether they'd work there. So will they?

CraigStallone 0 solutions 29 answers

Still trying to find out whether I'll be able to create a profile with the instructions I was referred to. Anybody?

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Instruction to create a new profile using the Profile Manager are the same for all Windows versions and require to start Firefox with the -P switch appended to the command line (be sure to leave a space before the -P)

  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" -P
CraigStallone 0 solutions 29 answers

okay thanks.

tryingtofigureitout 0 solutions 1 answers

This worked for me:

Firefox>Options>Security and check "Remember password for sites"

Explained here:

https://support.mozilla.org/en-US/kb/usernames-and-passwords-are-not-saved