Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have upgraded my mac to 10.6.8 yet firefox tells me I don't have the needed requirements which is 10.6. Help!

  • 2 replies
  • 4 have this problem
  • 603 views
  • Last reply by kobe

more options

My operating system is 10.6.8 recently upgraded. However Firefox won;t let me install an update that only requires os 10.6. Any suggestions? Thanks

All Replies (2)

more options

Your Firefox is reporting that you run Firefox 3.0.11 on MacOS X 10.5. This article has the steps for how to fix that: Websites say that Firefox is outdated or incompatible even though it's the latest version. Does that help?

And then, of course, you'll want to get on to the current version. I suggest making a backup of your personal settings folder first, in case something goes wrong with all the automated conversions that will be needed (if you are really still running Firefox 3). This article has tips on that: Back up and restore information in Firefox profiles.

Any luck?

more options

Hi please refer to

The latest version is 16 i belive on this OS.