Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

read the artricles, tried the solutions; my 3.6 does not show the choices shown on your solutions and i cant seem to update but am told by fb etc I should.

  • 4 replies
  • 1 has this problem
  • 40 views
  • Last reply by John99

more options

dont know what else to say - want to update from 3.6 but so far cant do it

All Replies (4)

more options

You really really really really really need to update to Firefox 22. Please read Install Firefox on Linux and Update Firefox to the latest release to learn how to do that

more options

I'm starting to do implement your reply and saw this on my preferences, extensions, "Ubuntu Firefox Modifications 0.9rc2 - Ubuntu Firefox Pack" - dont know whether to disable it or not or how to install the other.

more options

You can just uninstall that honestly, it's pretty much useless.

more options

Some early linux distros may lock Firefox to a specific version current with that distro.

That should not prevent you installing a Mozilla Firefox as an additional browser. You appear to be using Ubutnu 8.04 LTS

You should update your supported edit UN-supported OS. That presumably will require a re-install, which will be easier if you have a separate partition for your user directory.

A workaround to update Firefox would be to install Mozilla Firefox

Modified by John99