X
Tap here to go to the mobile version of the site.

Support Forum

Version 21.0 unresponsive after sleep mode

Posted

I'm on Windows 7. The browser won't accept any commands after my computer is woken from sleep mode. This only happens on the latest version. I had to revert back to 20.0.1.

I'm on Windows 7. The browser won't accept any commands after my computer is woken from sleep mode. This only happens on the latest version. I had to revert back to 20.0.1.

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Foxit Reader Plug-In For Firefox and Netscape
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • DictionarySearch 10.0.0 ({a0faa0a4-f1a7-4098-9a74-21efc3a92372})
  • Download Statusbar 0.9.10 ({D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389})
  • DownThemAll! 2.0.16 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Greasemonkey 1.9 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • HistoryBlock 1.4.0.5 (historyblock@kain)
  • LastPass 2.0.20 (support@lastpass.com)
  • Menu Editor 1.2.7 ({EDA7B1D7-F793-4e03-B074-E6F303317FB0})
  • NoScript 2.6.6.2 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • NoSquint 2.1.9 (nosquint@urandom.ca)
  • Pocket 3.0.1 (isreaditlater@ideashower.com)
  • Reddit Enhancement Suite 4.2.0.2 (jid1-xUfzOsOFlzSOXg@jetpack)
  • SkipScreen 0.7.0 (SkipScreen@SkipScreen)
  • Tab Mix Plus 0.4.1.0 ({dc572301-7619-498c-a57d-39143191b318})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) G33/G31 Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x29c2
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igdumdx32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 100
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 9-23-2009
  • driverDate2:
  • driverVersion: 8.15.10.1930
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) G33/G31 Express Chipset Family)
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.link.open_newwindow: 1
  • browser.link.open_newwindow.override.external: 2
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.google.com/ig
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.tabs.closeWindowWithLastTab: False
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • browser.zoom.siteSpecific: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • font.internaluseonly.changed: True
  • general.autoScroll: False
  • gfx.direct3d.prefer_10_1: True
  • mousewheel.withcontrolkey.action: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1369619182
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.extensions-tabmix: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158016 answers

Does it help if you close and restart Firefox?

Does it help to toggle offline mode off/on (Firefox > Web Developer > Work Offline)?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
Does it help if you close and restart Firefox? Does it help to toggle offline mode off/on (Firefox > Web Developer > Work Offline)? Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

Yes, it works again if I restart Firefox.

Yes, it works again if I restart Firefox.
jscher2000
  • Top 10 Contributor
8705 solutions 71136 answers

Likely related forum threads (unsolved):

Two bugs have been filed recently relating to sleep on Windows 7 (64-bit). Neither seems to have progressed toward a solution as of yet:

(It was also posted on a closed bug: https://bugzilla.mozilla.org/show_bug.cgi?id=765215#c91.)

If forum members can contribute to the development, please feel free to pitch in. Otherwise, it's generally not helpful to add comments to bugs (unless there is a call for test cases), but you can register on the Bugzilla site and "vote" for them to be fixed. See:

Likely related forum threads (unsolved): * [https://support.mozilla.org/en-US/questions/961206 FF 21.0 Unresponsive after Sleep - Windows 7.0] * [https://support.mozilla.org/en-US/questions/961898 browser freezes after resuming from sleep] Two bugs have been filed recently relating to sleep on Windows 7 (64-bit). Neither seems to have progressed toward a solution as of yet: * [https://bugzilla.mozilla.org/show_bug.cgi?id=859038 859038 – UI stops painting after resuming from sleep] * [https://bugzilla.mozilla.org/show_bug.cgi?id=873110 873110 – When OS Windows 7 wakes up after sleep Firefox doesn't respond to actions] (It was also posted on a closed bug: [https://bugzilla.mozilla.org/show_bug.cgi?id=765215#c91].) If forum members can contribute to the development, please feel free to pitch in. Otherwise, it's generally not helpful to add ''comments'' to bugs (unless there is a call for test cases), but you can register on the Bugzilla site and "vote" for them to be fixed. See: * [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette] * [https://bugzilla.mozilla.org/page.cgi?id=voting.html Voting]
bayouboogie 0 solutions 12 answers

July 19, 2013

I finally fixed the Firefox freeze problem today. Had FF 22, Windows 7. So damn tired of the damn Firefox freeze because if I had tabs open I'd have to X out and lose them. The checkbox for hardware acceleration makes no difference.

The fix was very simple. Uninstall Java. Uninstall FF. Restart computer. Find and download Firefox 20 Beta 4. Go to java dot com and re-install Java and the problem is fixed.

Done. Tired of screwing around with this and having to set my computer never to sleep, because I'm a busy guy and glad I fixed it.

July 19, 2013 I finally fixed the Firefox freeze problem today. Had FF 22, Windows 7. So damn tired of the damn Firefox freeze because if I had tabs open I'd have to X out and lose them. The checkbox for hardware acceleration makes no difference. The fix was very simple. Uninstall Java. Uninstall FF. Restart computer. Find and download Firefox 20 Beta 4. Go to java dot com and re-install Java and the problem is fixed. Done. Tired of screwing around with this and having to set my computer never to sleep, because I'm a busy guy and glad I fixed it.
bayouboogie 0 solutions 12 answers

P.S. - When you uninstall Firefox, make sure you don't check the box that erases your personal data. It'll be obvious during the wizard so it's foolproof.

P.S. - When you uninstall Firefox, make sure you don't check the box that erases your personal data. It'll be obvious during the wizard so it's foolproof.
jscher2000
  • Top 10 Contributor
8705 solutions 71136 answers

Hi bayouboogie, why do you recommend an early beta version of Firefox 20 instead of the last released version? Why do you think there is the connection with the Java plugin??

Before going back to a vulnerable version of Firefox, it would make sense to try the beta of Firefox 23, which others have confirmed to work for them in another thread.

http://www.mozilla.org/en-US/firefox/all-beta.html

Hi bayouboogie, why do you recommend an early beta version of Firefox 20 instead of the last released version? Why do you think there is the connection with the Java plugin?? Before going back to a [https://www.mozilla.org/security/known-vulnerabilities/firefox.html vulnerable] version of Firefox, it would make sense to try the beta of Firefox 23, which others have confirmed to work for them in another thread. http://www.mozilla.org/en-US/firefox/all-beta.html
bayouboogie 0 solutions 12 answers

Helpful Reply

I advocated the FF 20 Beta 4 because it worked perfectly the first time I invented the fix and tried it. I remembered specifically that the problem started with FF21 and so I decided at last to go back to the last version that I KNEW worked. I was 100% on the mark, in my case at least.

I tried everything, and I am quite methodical about what I do. The FF 20 Beta 4 fix works perfectly for me. The hardware acceleration checkbox does nothing for the problem.

I put up with this major pain in the butt for too long and finally solved it for myself. I am a happy camper now with my fix.

That said, are you telling me that FF 23 has fixed the bug? That would be great!

I am very busy right now, but when I get a chance, I will try it and post back my results.

Anyone else trying the beta 23, please report back.

As to your Java question, I'm not sure there is a connection at all. I just decided that if I was going to do a clean FF 20 b4 install, I wanted Java stripped out and reinstalled too. Let me say that I stripped out Java several times in the last couple months to address the freeze, but it didn't help.

IMO, Firefox itself was the problem

FF20b4 - no problem, and I'm happy as a clam now.

I advocated the FF 20 Beta 4 because it worked perfectly the first time I invented the fix and tried it. I remembered specifically that the problem started with FF21 and so I decided at last to go back to the last version that I KNEW worked. I was 100% on the mark, in my case at least. I tried everything, and I am quite methodical about what I do. The FF 20 Beta 4 fix works perfectly for me. The hardware acceleration checkbox does nothing for the problem. I put up with this major pain in the butt for too long and finally solved it for myself. I am a happy camper now with my fix. That said, are you telling me that FF 23 has fixed the bug? That would be great! I am very busy right now, but when I get a chance, I will try it and post back my results. Anyone else trying the beta 23, please report back. As to your Java question, I'm not sure there is a connection at all. I just decided that if I was going to do a clean FF 20 b4 install, I wanted Java stripped out and reinstalled too. Let me say that I stripped out Java several times in the last couple months to address the freeze, but it didn't help. IMO, Firefox itself was the problem FF20b4 - no problem, and I'm happy as a clam now.
TheMightyZeus 0 solutions 1 answers

I have same problem in FF23.0.1, Windows Vista. As so often, the actual cause is the Adobe Flash plugin.

Temporary workaround: when FF is in this frozen state, open Windows Task Manager (right-click on Windows Task Bar), switch to processes tab, and kill the process called FlashPlayerPlugin.exe or similar.

Presumably getting rid of the plugin would make the problem go away altogether. I haven't tried that, as it is occasionally a useful plugin, not just a delivery mechanism for advertising trash and bugs.

I have same problem in FF23.0.1, Windows Vista. As so often, the actual cause is the Adobe Flash plugin. Temporary workaround: when FF is in this frozen state, open Windows Task Manager (right-click on Windows Task Bar), switch to processes tab, and kill the process called FlashPlayerPlugin.exe or similar. Presumably getting rid of the plugin would make the problem go away altogether. I haven't tried that, as it is occasionally a useful plugin, not just a delivery mechanism for advertising trash and bugs.