X
Tap here to go to the mobile version of the site.

Support Forum

Search button does not work on start page

Posted

When I enter the item I want to search for i.e. Griffin Vulture in the search bar in the center of the home page and then click on the search button to the right of the bar nothing happens

When I enter the item I want to search for i.e. Griffin Vulture in the search bar in the center of the home page and then click on the search button to the right of the bar nothing happens

Chosen solution

Try to use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

You can also check if you still have the XML files of the default search engines including Google in the searchplugins folder in Firefox program folder.

If not then you need to reinstall Firefox.

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.4"
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Plug-in for detecting Nero Kwik Media.
  • BlackBerry WebSL Browser Plug-In
  • AppWorld NPAPI plugin
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • Citrix ICA Client Plugin (Win32)
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • British English Dictionary 1.19.1 (en-GB@dictionaries.addons.mozilla.org)
  • Java Console 6.0.33 ({CAFEEFAC-0016-0000-0033-ABCDEFFEDCBA})
  • Java Console 6.0.37 ({CAFEEFAC-0016-0000-0037-ABCDEFFEDCBA})
  • Norton Vulnerability Protection 11.3.0.9 - 4 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Add to Amazon Wish List Button 1.10 (amznUWL2@amazon.com) (Inactive)
  • Java Console 6.0.35 ({CAFEEFAC-0016-0000-0035-ABCDEFFEDCBA}) (Inactive)
  • Norton Toolbar 2013.3.4.3 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Mobility Radeon HD 4330
  • adapterDescription2:
  • adapterDeviceID: 0x9552
  • adapterDeviceID2:
  • adapterDrivers: atiumdag atidxx32 atidxx64 atiumdva atiumd64 atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 8-4-2009
  • driverDate2:
  • driverVersion: 8.632.1.1000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (ATI Mobility Radeon HD 4330)
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • gfx.blacklist.suggested-driver-version: 10.6
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1365446274
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 79594
  • places.history.expiration.transient_optimal_database_size: 127350210
  • plugin.disable_full_page_plugin_for_types: application/pdf,application/x-ica
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.passwords: True
  • privacy.clearOnShutdown.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.promptOnSanitize: False
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159012 answers

Chosen Solution

Try to use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

You can also check if you still have the XML files of the default search engines including Google in the searchplugins folder in Firefox program folder.

If not then you need to reinstall Firefox.

Try to use the SearchReset extension to reset some preferences to the default values. *https://addons.mozilla.org/firefox/addon/searchreset/ Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons). You can also check if you still have the XML files of the default search engines including Google in the searchplugins folder in Firefox program folder. If not then you need to reinstall Firefox. *http://kb.mozillazine.org/Unable_to_search_or_add_new_engines

Question owner

Thank you for your response. If the Search Bar no longer works or you can't add new search engines, the problem may be a corrupt "search.sqlite" file. [1]. Try the following solution:

   Exit Firefox and go to your Firefox profile folder.
   Delete (or rename) the file "search.sqlite".
   Re-start Firefox to see if it solves your problem. 

If the problem is not resolved, exit Firefox again, go back to your Firefox profile folder and delete (or rename) the file "formhistory.sqlite" (also delete "formhistory.sqlite-journal", "formhistory.sqlite.corrupt" and "formhistory.dat", if they exist). This may resolve the issue but will remove all Saved Form data from Firefox.

This fixed the problem, thank you

Thank you for your response. If the Search Bar no longer works or you can't add new search engines, the problem may be a corrupt "search.sqlite" file. [1]. Try the following solution: Exit Firefox and go to your Firefox profile folder. Delete (or rename) the file "search.sqlite". Re-start Firefox to see if it solves your problem. If the problem is not resolved, exit Firefox again, go back to your Firefox profile folder and delete (or rename) the file "formhistory.sqlite" (also delete "formhistory.sqlite-journal", "formhistory.sqlite.corrupt" and "formhistory.dat", if they exist). This may resolve the issue but will remove all Saved Form data from Firefox. This fixed the problem, thank you
Nisa51 0 solutions 4 answers

Helpful Reply

I got this problem today on Firefox 21.0 all of the above did not work

I got this problem today on Firefox 21.0 all of the above did not work
Yawrood 0 solutions 3 answers

Cor-el: Could you PLEASE tell me what you are talking about when you respond with this help:

You can also check if you still have the XML files of the default search engines including Google in the search plugins folder in Firefox program folder.

What are XML files? How do I know what default search engines are? How might one know where the search plugins folder are? How might one know where the Firefox program folder is?

Cor-el: Could you PLEASE tell me what you are talking about when you respond with this help: You can also check if you still have the XML files of the default search engines including Google in the search plugins folder in Firefox program folder. What are XML files? How do I know what default search engines are? How might one know where the search plugins folder are? How might one know where the Firefox program folder is?
FirefoxGoogleFix 0 solutions 12 answers

Had this problem this morning and it is now fixed.

1. Open Firefox Browser

2. Type about:config in location bar and press ENTER

A message will come up "This might void your warranty" Select, I'll be careful, I promise.

3. Search for configuration key, keyword.URL and highlight it

4. Right Click on the configuration key, keyword.URL and choose RESET from the shortcut menu.

Firefox automatically resets the value to:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

5. If the RESET option is greyed out in the shortcut options, select NEW and type in the google search location

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

and press OK.

If you are not comfortable with having changed the default URL, you can now go back to the shortcut option and select RESET, which will do exactly the same thing.

Your Firefox Google Search function will now work again, and you are back in business searching using Firefox Google.

..... Easy Fix.

.... Enjoy.

Cheryl

Had this problem this morning and it is now fixed. 1. Open Firefox Browser 2. Type about:config in location bar and press ENTER A message will come up "This might void your warranty" Select, I'll be careful, I promise. 3. Search for configuration key, keyword.URL and highlight it 4. Right Click on the configuration key, keyword.URL and choose RESET from the shortcut menu. Firefox automatically resets the value to: http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= 5. If the RESET option is greyed out in the shortcut options, select NEW and type in the google search location http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= and press OK. If you are not comfortable with having changed the default URL, you can now go back to the shortcut option and select RESET, which will do exactly the same thing. Your Firefox Google Search function will now work again, and you are back in business searching using Firefox Google. ..... Easy Fix. .... Enjoy. Cheryl
FirefoxGoogleFix 0 solutions 12 answers

If I was a conspiracy theorist, I would swear somebody at Mozilla doesn't want this problem fixed.

Been using the Firefox Google Search function for the last 3 hours, with no problems. As soon as I made the post above, 2 minutes later it no longer worked.

Mozilla had loaded some Add-On sites into my browser which now stopped it working.

Select from the Firefox Menu, Options (Underneath Add-Ons), sub menu Options.

The page should show the following options ticked:

Warn me when sites try to install add-ons Block Reported attack sites Block Reported Web Forgeries

Select the Exceptions TAB, and DELETE the default options Firefox have loaded in the browser.

Firefox Google Search should now work again, until the next time it is sabotaged.

Cheryl

If I was a conspiracy theorist, I would swear somebody at Mozilla doesn't want this problem fixed. Been using the Firefox Google Search function for the last 3 hours, with no problems. As soon as I made the post above, 2 minutes later it no longer worked. Mozilla had loaded some Add-On sites into my browser which now stopped it working. Select from the Firefox Menu, Options (Underneath Add-Ons), sub menu Options. The page should show the following options ticked: Warn me when sites try to install add-ons Block Reported attack sites Block Reported Web Forgeries Select the Exceptions TAB, and DELETE the default options Firefox have loaded in the browser. Firefox Google Search should now work again, until the next time it is sabotaged. Cheryl
jscher2000
  • Top 10 Contributor
8792 solutions 71920 answers

Helpful Reply

Hi FirefoxGoogleFix, you were searching from the address bar (using the keyword service) and it suddenly stopped working?

Please disable ALL nonessential or unrecognized add-ons on these two tabs:

orange Firefox button (or Tools menu) > Add-ons > Plugins category
orange Firefox button (or Tools menu) > Add-ons > Extensions category

Then restart Firefox using one of the links provided for that purpose above a disabled extension.

This won't reset keyword.URL, but hopefully will stop whatever is changing it from doing it again.

Hi FirefoxGoogleFix, you were searching from the address bar (using the keyword service) and it suddenly stopped working? Please disable ALL nonessential or unrecognized add-ons on these two tabs: orange Firefox button (or Tools menu) > Add-ons > Plugins category<br> orange Firefox button (or Tools menu) > Add-ons > Extensions category Then restart Firefox using one of the links provided for that purpose above a disabled extension. This won't reset keyword.URL, but hopefully will stop whatever is changing it from doing it again.
FirefoxGoogleFix 0 solutions 12 answers

Sorry,

Wasn't clear initially

Select from the Firefox Menu, Options (Underneath Add-Ons), sub menu Options, Security TAB.

Then Exceptions TAB.

Clear whatever default Add-On files are loaded under the Exceptions TAB and your Firefox Google Search Function will work again, if you have already done the keyword.URL fix

Thanks

Sorry, Wasn't clear initially Select from the Firefox Menu, Options (Underneath Add-Ons), sub menu Options, Security TAB. Then Exceptions TAB. Clear whatever default Add-On files are loaded under the Exceptions TAB and your Firefox Google Search Function will work again, if you have already done the keyword.URL fix Thanks
jscher2000
  • Top 10 Contributor
8792 solutions 71920 answers

Hi FirefoxGoogleFix, the list of sites allowed to install add-ons without asking permission should not affect whether you can use Google. I think there must be something else going on with your Firefox.

Hi FirefoxGoogleFix, the list of sites allowed to install add-ons without asking permission should not affect whether you can use Google. I think there must be something else going on with your Firefox.
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159012 answers

Note that the next Firefox 23 release will no longer use the keyword.URL pref, but will use the default search engine engine selected in the search bar.

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Note that the next Firefox 23 release will no longer use the keyword.URL pref, but will use the default search engine engine selected in the search bar. If you do not keep changes after a restart or otherwise have problems with preferences, see: *http://kb.mozillazine.org/Preferences_not_saved