X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to fix Shockwave Flash version 11.6 r602 Causing Firefox to Crash?

Posted

I just loaded windows 8 onto my system and placed Firefox version 19. as my web browser and went to Youtube and updated flash to the Version it was looking for which in this case is 11.6 r602 and now everywhere that I go on the web the plug in pops up says it fails and locks up my firefox. I have done what the suggestions have said

1. Made sure system was up to date 2. Lowered hardware and flash acceleration 3. changed firefox settings 4. have done numerous re-installs of firefox and flash

I had to start using google chrome Please help I like fire fox better

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.5 r502
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Version 3.13.2.11592
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Pando Web Plugin
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.10411.0
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

alco 18 solutions 141 answers

Hi cactusjeff,
have a look at this article:
Flash Plugin - Keep it up to date and troubleshoot problems
Notes on how to install flash plugin here:
Install the Flash plugin to view videos, animations and games
Hope that will help you. Please report back!

Question owner

Thank you very much but I already troubleshot everything in that article and it was failing before it was submitted. reducing the flash acceleration does not cause the flash plugin to not fail I have installed 10.3 but the plug in still hangs and fails (even though it does not have the same error it fails and causes firefox to hang) the current versions of firefox and the plug ins are up to date so I rolled each back 5 versions trying to get it all straight but still will not work. I have installed and reinstalled all components numerous times and it continues to hang. :(

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8893 answers

hello, have you already tired updating all the other plugins? especially make sure that realplayer is updated to version 16 since prior versions might interfere with the flash plugin and are known to cause crashes. also your java plugin is vulnerable (though it has probably nothing to to with the issues you're seeing):

https://www.mozilla.org/plugincheck/

Question owner

This is a fresh install so there are very little plugins to check I did a fresh install and only used the flash plug in and as soon as 11.6.r602 is installed it kills the browser. I did go back and add stuff back after the fact and it still fails but all the tests tell me that for whatever reason the new firefox 19.0 and other older versions of firefox hate 11.6.r602 flash.

Helpful Reply

After a week of Headaches and troubleshooting I have found the answer it Pains me to say that a build in feature of Adobe causing my problem and has apparently been causing the Problem for users since 11.3.300.257 and also IE causing the browsers to freeze or crash.Adobe did integrated Protected Mode for Firefox update and continues to use this causing the crash issue I am having . The Problem is that this should have been fixed and it has not in the many versions of adobe :(

Fix:

Disabling Protected Mode until a fix comes out that is resolving the issue. The company highlights that it highly recommends to enable Protected Mode again once the troubleshooting is complete.

To disable Protected Mode you need to edit the mms.cfg file located in one of the two directories:

   Windows 32bit: C:\windows\system32\macromed\flash
   Windows 64bit: C:\windows\syswow64\macromed\flash

Just open the file with a text editor and add the following line to the mms.cfg file:

   ProtectedMode = 0

If the file does not exist, create it first. You can alternatively download a version from the blog post linked above. To enable Protected Mode again simply delete the line that you have added to the config file.

Question owner

I was watching videos for an hour in least before I posted above and if the issue comes back I will throw it in here

ackurxs 0 solutions 3 answers

I was also experiencing the same bug. After disabling flash everything worked fine. I did my own searching and found that it is indeed a problem with protected mode. Another way to fix this is to downgrade to flash player 10 but it causes other problems. I hope the Mozilla team will look into this.

kleck 0 solutions 1 answers

I was also experiencing this issue. After uninstalling, reinstalling and following other forum suggestions, nothing worked. Then I updated all Firefox plugins (including RealPlayer and Java) and that solved the problem.

T-daddy 0 solutions 1 answers

I tried to circumvent as described, however I don't have authority to update the mms.cfg file. How can I get the authority?

ackurxs 0 solutions 3 answers

Try creating a new blank .txt file and insert

   AutoUpdateDisable=0
   SilentAutoUpdateEnable=0
   ProtectedMode = 0

Then rename it to .cfg and replace the original in the folder.

Modified by ackurxs

rblancrt 0 solutions 1 answers

Just wanted to say thank you. I have been dealing with this for months. Usually just installed an older version of flash (10. ??) and it would work. Then recently Firefox would complain that the old version of Flash was unsafe.

I think you have finally given a solution that is satisfactory.

Thanks for taking the time.

P.S. For others who are having trouble modifying the .cfg file. It is a problem with the security settings/ownership of your user name or of the file. If you get the security settings changed properly you can edit and re-save it.

dlmills 0 solutions 1 answers

Not computer savy, it did not help me. how do you use text editor to find the lines shown above?

pprewett 0 solutions 5 answers

Helpful Reply

I had no problems with version 20.0.1 on a windows 7 64 bit computer until upgraded shockwave flash to version 11.7.700.169 now the browser crashes have to disable the plugin.

It appears that this is a common problem and needs a solution not a work around, as most people are not computer literate, and what happens if a fix occurs does one have to go back and undo the work around.

Messing about with the operating system or SW is certainly not the answer.

Peter

Ninko85 0 solutions 1 answers

Hi there,

I have exactly the same problem as pprewett.

My Windows XP and Vista computers are fine, it only seems to be affecting my Windows 7 64bit computer.

Is Mozilla aware of this problem?

Thanks


Ninko85

pprewett 0 solutions 5 answers

It does not seem that Mozilla is answering or even listening, so not much point in posting anything.

Peter

BillyBob58 0 solutions 2 answers

ACG, I have made a new file for mms.cfg and copied it as you suggested, so far all seems OK. But is this safe, is my computer at risk with out this auto safety feature?

Also, some "updated all Firefox plugins (including RealPlayer and Java)" and had success. Is there one step to Update all plugins? How is that done? Bill

marigonda 0 solutions 1 answers

THIS WORKED FOR ME!

THANKS!

angleofdarkness 0 solutions 1 answers

Fix did not work for me.

I had to boot in safe mode to alter the mms.cfg file due to "File in use" messages when attempting to save edits, even though no browser or flash was in use. Not sure if this is part of the problem? Either way, after updating the mms.cfg file in safe-mode to add ProtectMode toggle I still get continual freezing then crashing of Shockwave flash on any website that uses flash ads or video content. I've switched to Chrome out of necessity.

FF20.0.1, Flash 11.7.700.169, 64-bit Lenovo T420 Win7

Modified by angleofdarkness

BillyBob58 0 solutions 2 answers

Angelofdarkness, I also was using Chrome and Safari because of the problems until I altered that file about 6 days ago. But have used nothing but Firefox since then without a single freeze up so far ( knock on wood ). In fact, it all seems to be working better than it ever has for this one week. So I am disappointed to hear you had no luck. BTW, I was also unable to edit that file, and I even had to download a free program to even view it. But, I made a new file in notepad containing the suggested changes, then saved it to my desktop with the file name mms.cfg, then copied it to the C:\windows\syswow64\macromed\flash folder, which replaced the original file. (got a warning/message telling me that file name already existed and asking did I want to replace it) I kept a copy of the original just in case. Fingers crossed, so far so good for 6 days with lots of video watching.

But, I am still worried if this somehow effects my system security? Any opinions? Will this interfere with auto-updates, and do I need to update on my own periodically? Or any other added risk? I run a Norton 360 anti-virus/firewall, would that hopefully keep things safe when altering this file?

extent 0 solutions 2 answers

I had a theme in windows 7 which gave a slideshow (wallpaper changed to a new image every few minutes). turning this off solved the browser flash hanging for me