X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My search-engine takes my homeland, but i shop in a bordercountry. how i can change this ?

Posted

I live near the border. My internetaccount is from a provider in my homecountry. My searchengine, google takes my homeland, but i want to search dominantly in the bordercountry. how i can change this preferency ?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • GEPlugin
  • 4.1.10329.0
  • e.dentifier2 Plug-in for Mozilla
  • A component of your photo software powered by RocketLife
  • CANON iMAGE GATEWAY Mycamera Plugin
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
415 solutions 4920 answers

In order to change the default search engine or the order of search engines in the top right search box in Firefox, please perform the following steps:

  1. Move the mouse cursor inside the search box at the top right of the Firefox window and click the down arrow next to the provider's logo.
  2. If you would like to select another search engine, simply pick the engine from the dropdown list.

In order to change the order of the search engines, do this:

  1. From the dropdown list, select Manage Search Engines....
  2. In the upcoming window, you have all your search engines listed. To change the order, simply click one search engine and then select Move up or Move down from the buttons on the right side in order to change the order of the search engines.
iamjayakumars
  • Top 10 Contributor
415 solutions 4920 answers

When you enter a search term in the Firefox location bar and press Enter, Firefox will per default do a "I'm feeling lucky" Google search and redirect you to the first result that matches your search term. This behaviour can be changed by a number of add-ons. If you'd like to restore the previous default behaviour, please follow these steps:

  1. Enter about:config in the Firefox location bar and press Enter.
  2. You should see a warning that making changes to the Firefox configuration can be potentially harmful to Firefox's integrity. Click the I'll be careful, I promise button to continue.
  3. In the Search box at the top, enter keyword as the search term. You should see a few remaining items, one of these is keyword.URL. It should be bold.
  4. Right-click on the keyword.URL setting and select Reset from the dropdown menu.

Now you're done. Please report back if this fixes your problem. Thanks in advance!

You can find more information about the Location bar search feature in the Search the web from the Address Bar article.