X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I've successfully updated latest Java plug-in to latest version but Mozilla plugin page shows it's still outdated

Posted

Mozilla Plug-in page showed Java was outdated and needed updating. I did do that but the plug-in page still shows Java Deployment Toolkit 7.0.90.5 10.9.2.5 & Java (TM) Platform SE 7U9 10.9.25 as being outdated. But when I go to my add-on page and check my plug-ins, those are both showing up as being installed and enabled and the date I updated them on which was today 12/12/12. Also I went to www.java.com to check what the latest version was and when you click on downloads it automatically checks to see if you are running the current version and it says I am running the latest version. I even went and uninstalled some old java updates that I forgot to remove in my programs. Should I just ignore the *outdated* plug-in reminders for those two on Mozilla's plug-in page since everything else is telling me I did it correctly? Thing is, how do I know when there is a new update if those two never update and consistently show they are outdated? Thanks to anyone that may be able to answer this question.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24404 answers

Helpful Reply

Try testing it here:
http://java.com/en/download/testjava.jsp

Another thread here - https://support.mozilla.org/en-US/questions/944191

Question owner

Thanks but I did go to www.java.com and it tested to see if I had the latest Java and it said I did. But Mozilla Plugin page indicates that both Java Toolkit & Java Platform have not been updated. Just wanted to make sure that it truly had been. But will worry how I'll know the next update when the current plugin page indicates that it hasn't been done.

Axis 2 solutions 46 answers

Helpful Reply

Thanks much to whomever deleted my reply to DFelice. Apparently someone who moderates the support forums doesn't like inconvenient truth...that is...the plugin page is seriously broken and my link in this thread to the same issue in another thread was removed along with the whole post. ( https://support.mozilla.org/en-US/questions/944115 )

Is this a support forum? Or is there some unwritten protocol that we must walk on egg-shells. That is just plain wrong. It is the same issue affecting two different plugins, Flash and now Java.

At least is was here long enough for DFelice to hop over and reply in the above linked thread.

I don't write these things because I "hate" Firefox, but because I love it and want to see it not slip away into Opera land. So here is positive feedback as well. Firefox has the best "View Source" of any browser, it will actually point out coding errors and sometime suggest where the problem is which is extremely useful to webmasters. The latest Firefox has fixed a font rendering problem which is something I addressed in a post a few months(?) ago in the support forums here and now it is fixed and is on the "same page" with all the other browsers in terms of font rendering. So that is cool.

Modified by Axis

papasmurfcba 0 solutions 2 answers

Same here. It is mainly a concern for me because I do a lot of java programming for school and work. 7.0.90 is the latest version as of today, err this morning. That's what I am using on everything. Firefox just isn't reporting it correctly. It is looking for some switch that Oracle didn't tell the Firefox dev team about. On windows 7 you can look at your version in 'programs and features' in the control panel OR type 'java -showversion' at the command prompt. The later will only work if you navigate to your java folder or if you have added the java directory to your %path% variable.

BeeKay1 0 solutions 2 answers

Same issue here. Making me crazy. I have installed deleted and reinstalled. C'mon Mozilla please fix this issue. It all works fine in IE and Chrome but I truly prefer Firefox. It is something going on with Firefox if it all works fine in the others.

Alice_85 2 solutions 39 answers

@Beekay1, and papasmurfcba,

I ran into this problem a few days ago too. For some reason I think it's just taking a while for Firefox to get a proper read on the latest Java update.  Make sure to have the latest version installed and disable Java until it corrects itself.
  • I installed both 7u9 and 7u10 on my computer and then disabled Java in Firefox (Safari and IE were fine).
  • After about 48 hours, the Java add-on corrected itself. {It changed from 7u9 to 7u10 on it's own}. The toolkit was already up to speed.

I hope that helps. If you need Java, just use another browser until the update catches up on Firefox. {Note: Once everything is working again in Firefox, be sure to uninstall the 7u9 from your computer.}

Modified by Alice_85

Question owner

Yes, I've checked my plug-ins for the computer in my add-ons section and went to Java directly and everything tells me I have the correct version installed. I too love Mozilla and wish they fixed the plug-in update page to reflect the changes one makes when updating, instead of making us think we're crazy or our computers aren't working properly. I personally am sill using only Firefox 8.0, because the last time I updated to the latest version, for some reason I lost my entire browser and if it weren't for the fact I still had an old version saved in my folder to re-install I don't know what I would have done. I am only 'techy' up to a point and after that point I'm usually sunk. Thanks much to all who have responded to my problem. Debbie

Question owner

In my above reply I said I wasn't all that 'techy'. So here's a stupid question... again. Everything on my computer shows I have the current Java, so why would I have to disable Java until Firefox plugins catches up. So far everything seems to be working. Debbie

Alice_85 2 solutions 39 answers

Hi, DFelice

     Sorry for the confusion, I was addressing Beekay1 and papasmurfcba's comments.  :)

Most of this is lost on me... I'm just sharing what worked. If everything looks like it's working fine, then you're probably good to go.  :)

Modified by Alice_85

BeeKay1 0 solutions 2 answers

Yes, mine is not functioning. I knew what Alice meant. Everyone is just trying to help. No worries. I just wish it would be fixed.

Question owner

Okay. Thanks anyway! Who knows? I'm not all certain what Java takes care of except games and things. I usually do games with friends on Yahoo Messenger but of late the one friend I play it with hasn't internet for the moment and so I'm hoping that it will work when we do get back to doing it. But like I said earlier, everything seems to check out that I have the latest version. Just Mozilla plugin page doesn't agree. Debbie

Axis 2 solutions 46 answers

OK, FF...now I am really mad. You have disabled Java from my browser without my consent. I have installed the latest version and it all shows up fine in every other browser. I can tolerated the brain dead plugin page telling me that everything needs to be upgraded when it doesn't...as in Flash a few days ago and then Java, but I will not tolerate a browser that disables plugins without my consent...especially when they are wrong.

What gives your stupid plugin page and your browser the right to disable anything against my will!

I was about to throw in my lot with the whole Mozilla Project, being a longtime FF user but you have no right to disable anything against my will. You are actually blocking the web from me and how many other users. I want my Java back regardless of your brain dead plugin page. So...how do I find what you have disabled and enable it again? I am not a child and you are not my baby sitter! If I don't get a solution today it is bye-bye FF.

tds777 0 solutions 4 answers

I don't know whats really going on but after doing a Google search and found the solution on google groups.google.com/forum/?fromgroups=#!topic/mozilla.support.firefox/mHtGVvdB6CY

Now the current version is Java SE Runtime Environment 7u10, not the 7u9 version we are getting from java.com. You have to download from the Oracle site to get version 10, I did this and everything is OK now. Make sure you get the right version either 32bit or 64 bit. How this is occurring is beyond me the 7u9 version is really outdated, you need the 7u10 version. It is a java. com error.

http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html

Axis 2 solutions 46 answers

Hi tds777 and all--

I did manage to get it all sorted with Java 10. My final "personal" solution is at the bottom of this page: http://support.mozilla.org/en-US/questions/944191?esab=a&as=s&r=2&page=4

Good luck all!

tds777 0 solutions 4 answers

I didn't really have to do nothing but download the right version from the Oracle site and install.