X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Google search just produces a blank page. (Windows8) . Google is working okay in IE. Any known issues

Posted

I use the Google Page to search. It is working okay with I.E. But the page is going blank in (Just updated) Firefox, using Windows 8.

Never had a problem before.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Plexus Streaming Web Plugin
  • McAfee MSC FF plugin DLL
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Adobe Acrobat Plug-In Version 6.00 for Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Gryllida 76 solutions 892 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.



Once done, please let us know whether the issue persists in safe mode. Thanks!

Question owner

Hi Gryllida

Tried your suggestion but no luck.

Thanks anyway.

rezzel 0 solutions 5 answers

Helpful Reply

Ok so i figured something out about this problem. Uninstalled and reinstalled firefox, but still did not fix the issue. However, if you do the search and right click on the page after you tried the search and click reload it will appear. Still trying to figure out how to fix it, but i do not think it is on our end.

Modified by rezzel

Pervis 0 solutions 6 answers

The same problem just started on Mac OS 10.6.8, Firefox 17.0.1. Tried Safe Mode, no joy. Looks to me like it is not responding to the "Enter" key after you enter your search term.

Safari works fine.

Modified by Pervis

rezzel 0 solutions 5 answers

Right now it is only happening in firefox and clearing the cache and browsing history did not work either.

Question owner

Your suggestion worked.

Right click and reload page.

But this is something I wouldn't want to do all the time.

Appreciate your efforts.

GrumpySteve 0 solutions 9 answers

I have this too - reported in another thread, so we are dividing our efforts! Win XP, doesn't work in safe mode, does work if you switch javascript off. And I can reload. Reinstalled latest version - didn't fix it!

rezzel 0 solutions 5 answers

I found out how to fix the issue. Close firefox. Use the run command to open firefox in safe mode. Use fire -safe-mode in the run-as box. Reset firefox from the popup that appears and this should fix the issue. For users that do not have the run box like in windows 7 and 8. right click on the start button and click properties. Then click on customize. You will find the run command if you scroll down. I also made a tutorial for anyone.

Modified by rezzel

Pervis 0 solutions 6 answers

Unfortunately, this is the nuclear option. It wipes out all your data unless I am mistaken.

Question owner

Well...I had a slight difficulty in following your instructions in windows 8, which is more my fault than yours.

But I tried another route which has solved the problem. Holding down the Shift key I clicked on the Firefox icon (on desktop), then a box appears with 2 options.

Start Firefox in Safe Mode

Reset Firefox to its original state.

Choosing to Reset still saved my browser settings, although I had to set my Firefox preferences again (which is not a hardship).

This has worked for me so I hope it helps others.

Thanks for the help.

Gryllida 76 solutions 892 answers

As said before: This is a nuclear option. It resets all user's custom preferences. If you are still having this problem, please check for it in safe mode without resetting anything, and let us know whether this works. Thanks.

rezzel 0 solutions 5 answers

I only use firefox for browsing the web. I rarely place any bookmarks and passwords, well I do not like to save them at all. Any other settings, well i can change the home page, but if you use firefox for more than this by all means do not do this. I found safe mode to have the same problem.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Helpful Reply

hello, some other users have reported that the search problem only appeared when they had firefox set to specifically block cookies from google.com or one of its local domains. can you check if this is the case for you when you go into firefox/tools > options > privacy > accept cookies - exceptions...?

alternatively you might use the firefox search bar to do a google search or use https://www.google.com/webhp?complete=0 until this is somehow addressed by google (provided that this was not an intentional change).

GrumpySteve 0 solutions 9 answers

I'm not blocking cookies, so for me it's not that. But I can certainly live with the modified search URL you give. Thanks!

Modified by GrumpySteve

kezme 0 solutions 2 answers

I have had the same problem since upgrading to 17.0.1.

I am not blocking cookies, and Safe Mode does not fix the problem.

rezzel 0 solutions 5 answers

I know when i turned off enable java script, Google searches started working again. That is another work around. When i turned off one of the advanced options it would pop up a message asking what program to open a js script. I turned it back on and still had the same problem. Not sure how to fix the problem, but it has something to do with java scripts.

Gryllida 76 solutions 892 answers

When you're getting a blank page, go to tools > web developer -> page source, and paste it in a reply here. Thanks.

GrumpySteve 0 solutions 9 answers

I can't post the page source I get - the forum won't handle it - "Please keep the length of your content to 10,000 characters or less. It is currently 96,580 characters."

Gryllida 76 solutions 892 answers

Sorry. Please Use http://pastebin.mozilla.org