X
Tap here to go to the mobile version of the site.

Support Forum

FF 15.0.1 is very slow on my Laptop but good on my Desktop?

Posted

I have an ASUS dual core 4GB RAM W7 64bit laptop where FF 15.0.1 runs very slowly & many times hangs up.

When I try SPEEDTEST.net (ST) using FF, my d/l speed is ~2MBS & u/l is ~1.5MBS. And I can tell that ST is running very slowly. The ST page alone loads very slowly. Ping takes a long time.

But when I run ST on Chrome, all other things being equal, I can get 20MBS d/l & 3 MBS u/l speeds. A dramatic difference.

I have reset FF & that helped a little but it is still running about 1/10th the d/l speed as does Chrome. I prefer FF & wondering what else I can do. I also run Charter Security Suite.

Thanx in advance - Bob

I have an ASUS dual core 4GB RAM W7 64bit laptop where FF 15.0.1 runs very slowly & many times hangs up. When I try SPEEDTEST.net (ST) using FF, my d/l speed is ~2MBS & u/l is ~1.5MBS. And I can tell that ST is running very slowly. The ST page alone loads very slowly. Ping takes a long time. But when I run ST on Chrome, all other things being equal, I can get 20MBS d/l & 3 MBS u/l speeds. A dramatic difference. I have reset FF & that helped a little but it is still running about 1/10th the d/l speed as does Chrome. I prefer FF & wondering what else I can do. I also run Charter Security Suite. Thanx in advance - Bob

Additional System Details

This happened

Every time Firefox opened

This started when...

Not sure, but it also happened before FF15

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • DivX Plus Web Player version 2.2.1.2
  • DivX VOD Helper Plug-in
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Garmin Communicator Plug-in Version 4.0.2.6
  • Picasa plugin.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

Reset FF
Cleaned disc, optimized & defragged HD
Ran Windows MEM test
Ran Ckdsc

Question owner

ps- I posted this issue while using my Mac Mini which seems to run much better than my ASUS laptop. So the additional "Info" can be misleading. While submitting the issue, the Mac data was sucked in by FF help, I did not document it.

ps- I posted this issue while using my Mac Mini which seems to run much better than my ASUS laptop. So the additional "Info" can be misleading. While submitting the issue, the Mac data was sucked in by FF help, I did not document it.

Modified by Homer1952