X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

significant regression in scrolling performance in firefox 15

Posted

I immediately noticed a significant performance regression after upgrading from 14.0.1 to 15. I've seen various comments on input.mozilla.org but it's now a week after release and the latest firefox planning meeting made no mention of it (https://wiki.mozilla.org/Firefox/Planning/2012-09-05) so I thought I would try here.

The first thing I noticed was slow and jerky scrolling of a web page (the same one I was looking at immediately before the upgrade). I tried restarting in safe mode, and while this improved things somewhat, it was still noticeably worse. I also tried with a clean profile with similar results. It was bad enough that I reinstalled 14.0.1 and everything went back to normal.

Now I'm back in 15 to submit this report and I've noticed that the performance is bad in other places too.

  • scrolling in all web pages, even simple ones
  • scrolling the tab bar is also slow and jerky
  • selecting text is so slow that the highlight lags half a second behind the cursor
  • key repeat is now half the speed of other applications
  • youtube videos drop frames all over the place, and WindowServer is the top CPU user when playing

I'm going to revert to 14 again for the time being but if you want me to try anything in 15 I can do that. I'm a developer but don't have any experience with ff so don't know what to try next.

Chosen solution

I have some more information to report as I've made a discovery. The above mentioned regression in 15.0.1 is almost eliminated by changing the transparency effects on the iTerm.app I also have installed. To be precise, with a "large radius blur" on an open iTerm window (even if completely hidden by FF) the performance of scrolling etc in FF is terrible. If I minimize the iTerm window, or turn off the "blur" effect, or quit iTerm, performance is restored to acceptable levels.

Now I didn't change any of the iTerm stuff when I upgraded from FF 14 to 15. In other words, FF 14 was happy to run along side iTerm with the transparency effects enabled.

So clearly something has changed in FF 15, maybe to do with graphics compositing, that really throws the Macbook Air's graphics hardware/drivers/compositors/etc. for a loop. While the problem of course could lie in other apps or the OS itself, I need to reiterate that FF 14 worked fine, then without changing anything else on the system, FF 15 did not. Perhaps it's time to open a bugzilla issue and get a dev to chime in?

Read this answer in context 0

Additional System Details

This happened

Every time Firefox opened

This started when...

upgrade to 15

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

Application Basics
Name
Firefox
Version
15.0
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:15.0) Gecko/20100101 Firefox/15.0
Profile Folder
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Better Gmail 2
1.2
true
bettergmail2@ginatrapani.org
British English Dictionary
1.19.1
true
en-GB@dictionaries.addons.mozilla.org
Greasemonkey
1.0
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
Modify Headers
0.7.1.1
true
{b749fc7c-e949-447f-926c-3f4eed6accfe}
Net Usage Item
1.2.337.1
true
{DA1B0AB5-7DD3-4066-BC2A-64AABBDD0A8B}
Reddit Enhancement Suite
4.1.2
true
jid1-xUfzOsOFlzSOXg@jetpack
YTshowRating
1.0.7
true
jid1-m7xzZLMj29zzjA@jetpack
Firebug
1.10.3
false
firebug@software.joehewitt.com
Flashblock
1.5.15.1
false
{3d7eb24f-2740-49df-8937-200b1cc08f8a}
FoxyProxy Standard
3.6.2
false
foxyproxy@eric.h.jung
iViewFox
1.4.0
false
iViewFox@forboden.com
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
686080
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20120824154833
browser.startup.homepage_override.mstone
15.0
extensions.lastAppVersion
15.0
general.autoScroll
false
network.cookie.prefsMigrated
true
network.protocol-handler.expose.mango
false
places.database.lastMaintenance
1346925364
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
plugin.expose_full_path
true
print.macosx.pagesetup-2
PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO…
print.print_bgcolor
false
print.print_bgimages
false
print.print_command
print.print_downloadfonts
false
print.print_evenpages
true
print.print_in_color
true
print.print_margin_bottom
0.5
print.print_margin_left
0.5
print.print_margin_right
0.5
print.print_margin_top
0.5
print.print_oddpages
true
print.print_orientation
0
print.print_page_delay
50
print.print_paper_data
0
print.print_paper_height
11.00
print.print_paper_size_type
1
print.print_paper_size_unit
0
print.print_paper_width
8.50
print.print_printer
print.print_reversed
false
print.print_scaling
1.00
print.print_shrink_to_fit
true
print.print_to_file
false
print.print_unwriteable_margin_bottom
57
print.print_unwriteable_margin_left
25
print.print_unwriteable_margin_right
25
print.print_unwriteable_margin_top
25
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Vendor ID
0x8086
Device ID
0x 116
WebGL Renderer
Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine -- 2.1 APPLE-7.18.18
GPU Accelerated Windows
1/1 OpenGL
AzureBackend
quartz
JavaScript
Incremental GC
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.1
4.9.1
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

Question owner

hello? mozilla?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Try to disable hardware acceleration in Firefox.


If there is a problem with scrolling on web pages then try to disable smooth scrolling.

  • Firefox > Preferences > Advanced > General: Browsing: "Use smooth scrolling"

(edit: changed menu paths to Mac)

Modified by cor-el

Noah_SUMO
  • Moderator
50 solutions 303 answers

Hey qwerty, sorry about the delay. The first thing you should know about these forums is that they are volunteer driven. So while Mozilla hosts this site, there isn't anyone paid to specifically answer questions. There's a couple of us though who do know Firefox intimately enough after having fiddled with the settings and files of Firefox over 7 years. One of them being me. So I'll try my best to help you.

The easiest fix might be to turn off hardware acceleration:
Firefox button > Options > Options > Advanced > General > Use hardware acceleration when available
(or Tools > Options)

Hardware acceleration tries to use your graphics card to make web pages render/display faster. Personally, I find this feature causes more headaches than smiles. It must not like your graphics card b/c is too old or your graphics card drivers are outdated.

If that didn't help, my gut is telling me one or more of your addons was silently broken by a change in Fx 15 that the addon developer did not know about. Addon developers aren't always aware of changes to the Firefox code that might break their addon in odd ways or cause side effects but keep working.

I would start off by disabling the addon Greasemonkey (I suspect 1 of the scripts could be to blame) then restarting Firefox and trying to see if you can reproduce your problem. If it doesn't help, try disabling a few Greasemonkey scripts at a time. Then see if you can reproduce the problem. If you still can, try disabling a few more or all of them. Then try to reproduce the scrolling issue again.

If that doesn't work, try disabling all your addons:
Firefox button > Help > Restart with Add-ons Disabled

Modified by Noah_SUMO

Question owner

hey Noah, thanks for the reply. I will test the hardware acceleration option when I get a chance, but I wanted to highlight what I mentioned in the original post: I get the same regression both in safe mode, and in a new empty profile, so I don't think it is addon related.

Noah_SUMO
  • Moderator
50 solutions 303 answers

D'oh! Sorry about that. I always try to make sure I don't tell someone to try something they already said they did. I forgot Firefox Safe mode automatically disables Hardware acceleration. Plus, it's super early in the morning here so I can blame that too. :D

Great job on trying a new profile yourself. To be sure though, how did you create the new profile? With Profile Manager? Also I agree it's definitely not addon related if you can reproduce in a new profile. The only thing left (after a new profile) are your plugins which look normal to me: iPhoto6 (for iPhone), latest Flash, Google Earth, Java, and Quicktime.

Plugins are stored outside the profile folder for the record.

So seeing as how nothing obvious is striking me as left, I think you've done all you can do.

Unless there's a 3rd party application conflicting with Firefox 15. My only guesses would be AV software and perhaps firewall software. But that's grasping at straws essentially. Short of that, I believe there's something inherently wrong with Firefox 15 because it didn't receive enough testing and pushed a patch thru that it wasn't supposed to, one that was too experimental but not flagged as such.

Btw what are your Mac's specs? Maybe that will help someone at QA narrow down the problem.

If I think of anything I'll be sure to let you know. Thanks for your efforts in trying to debug this.


Edit:
I was also thinking about possible Firefox debug builds. But from what I hear those may be better served to track down crashes and not performance issues. And they may be a bit complicated to setup/work with. So I wouldn't send you down that path.

It'd be great if a Fx dev could whip up some sort of performance measuring build that could run on your system and log its internal metrics, dump that output into a file and send it to the devs. I'll ask around and see if something can be done. I think a debug build can do this & can dump data to a log but it doesn't sound easy. Anyway I'll get back to you on that.

Modified by Noah_SUMO

Question owner

Yep, created a new profile with the profile manager. I don't run any 3rd party firewall or AV software.

Since there is relatively little "chatter" on the web about poor performance with 15, and presuming that the devs themselves aren't having the same problems, it must be relatively unique to my setup.

My specs are:

MacBook Air 13-inch, Mid 2011 Processor 1.8 GHz Intel Core i7 Memory 4 GB 1333 MHz DDR3 Graphics Intel HD Graphics 3000 384 MB Software Mac OS X Lion 10.7.4 (11E53) fully patched

I'd be happy to try out any instrumented builds available.

I've been a happy ff user since 1.0 and never really had any problems, so this was a bit of a surprise for me.

Chosen Solution

I have some more information to report as I've made a discovery. The above mentioned regression in 15.0.1 is almost eliminated by changing the transparency effects on the iTerm.app I also have installed. To be precise, with a "large radius blur" on an open iTerm window (even if completely hidden by FF) the performance of scrolling etc in FF is terrible. If I minimize the iTerm window, or turn off the "blur" effect, or quit iTerm, performance is restored to acceptable levels.

Now I didn't change any of the iTerm stuff when I upgraded from FF 14 to 15. In other words, FF 14 was happy to run along side iTerm with the transparency effects enabled.

So clearly something has changed in FF 15, maybe to do with graphics compositing, that really throws the Macbook Air's graphics hardware/drivers/compositors/etc. for a loop. While the problem of course could lie in other apps or the OS itself, I need to reiterate that FF 14 worked fine, then without changing anything else on the system, FF 15 did not. Perhaps it's time to open a bugzilla issue and get a dev to chime in?

wavlet 0 solutions 6 answers

I've tried disabling skins, add-ons and hardware acceleration to no-avail. I get delays in scrolling and sometimes typing. I'm not having these issues with IE9 and I'm afraid after many years as a Firefox user I'm forced to go back to IE9 which seems to be equivalent in functionality to Firefox and now performs much better. I'm running a quad-core 8 Gig machine with the latest drivers. Sorry Firefox....  :-(