X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 15 asks for the master password on startup

Posted

Variants of this problem are found in closed threads, but this problem is new for me and I've used FF since Netscape folded. After updating to FF15 I get this on 3 different machines. When I open FF I am, before opening a page, asked to enter the master password. If I click on a password-protected page too quickly, the "enter master password" box comes up twice, and half the password goes in one box and half in the other. I find this very irritating. The only workaround is, after opening FF, to wait anything from 10 seconds to a minute for the box to appear.

Chosen solution

Acting on a suggestion from a poster on "The Netscape FAQ" site, I went to create a new Firefox profile. There I was advised first to reset Firefox. I did this, and the problem appears to be solved. I did not know of this command, which is clearly a useful one to be able to fall back on.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • QVP Netscape Plug-in Stub
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • VLC media player Web Plugin 2.0.2
  • 5.1.10411.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

Firefox 15, using Windowns 7 or Windows XP

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Try this extension as a workaround:

Question owner

This half solves the problem, inasmuch as I now only get the master password box to fill in once, when I open FF. But I would rather I had the previous default, which was that I was only asked for the MPW when I wanted to open a page for which a PW is stored. After all, sometimes I open FF and never open a page that needs a PW . . .

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

If you aren't opening pages that have a log in form and you've saved a name and passwords for that domain then other things can cause the MP pop-up to appear.

Are you using Firefox Sync?

Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Question owner

I started FF in safe mode without hitting reset and it still asked for the master password before I opened a page. I have used sync in the past but disabled it because I couldn't work out how to prevent duplicate bookmarks.

Chosen Solution

Acting on a suggestion from a poster on "The Netscape FAQ" site, I went to create a new Firefox profile. There I was advised first to reset Firefox. I did this, and the problem appears to be solved. I did not know of this command, which is clearly a useful one to be able to fall back on.