X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox 14 crashes when home page is google.com

Posted

Firefox 14 crashes when home page is set to google.com I have always had google.com as the home pages. everything was ok till this morning. as soon as i start the fire fox with Google as home page it crashes. On my other computer it has no problems at all. I can change the default settings to what I have always used but as soon as I change the home page it crashes and forces me to change all my settings to the default before I can use it again. i dont get any crash ID either.

Chosen solution

For anyone experiencing crashes on the Google Homepage, for now it is best to set your home page to something else (like about:home, which also provides a Google Search Box), until these doodle's are gone, or a Firefox fix is released (whichever comes first). We will fix this issue so it doesn't happen again in the future, but the current set of doodles may be gone before then.

How to set the home page

Read this answer in context 9

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • Google Talk Plugin Video Accelerator version:0.1.44.16
  • Version 3.3.3.8675
  • Next Generation Java Plug-in 1.6.0_33 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • npsitesafety
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

it just says the problem has been reported.

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Do a malware check with some malware scanning programs on the Windows computer.
You need to scan with all programs because each program detects different malware.
Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:


See also:

Blazde 0 solutions 2 answers

Helpful Reply

Possibly it's related to the hurdles game ( http://www.google.com/doodles/hurdles-2012 ) which appeared on Google's homepage today. I get the problem only when FF first starts up and the startpage is set to google.co.uk (https and http both fail) or when starting it up on a blank page and immediately hitting home to go to Google. A few seconds after startup it can be accessed without any problems and the hurdles game appears to work fine

Setting start page to http://www.google.com/doodles/hurdles-2012 also causes the crash

Starting in safe-mode avoids the crash and the page loads fine

rockabilly 0 solutions 1 answers

I was having the same problem today and could only log in in Safe Mode. My home page was set to google.com.au. In Safe Mode I changed my home page (to my ISP's), closed down Firefox and restarted it - and it worked. So it appears that the problem has been with something Google has on its home page. Try changing your start-up home page, and hopefully it will work for you as an easy solution.

Shyonenz 0 solutions 6 answers

I wondered if it was the hurdles game too. If i am really really quick and select one of my quick links as the page flashes I can get in. Also if I right click and choose private browsing it is OK. It is so frustrating though. I am linked to the nz google so I don't think it matters which country you use. Seems to be a compatibility issue with Mozilla and the Google Home Page re the game

Shyonenz 0 solutions 6 answers

Thanks

aytacaksel 0 solutions 1 answers

same problem. if home page www.google.com/co.uk whatever its crashing.

urma 0 solutions 1 answers

I think it crash if home page is Google and there is settings ”Do not save any history”. Please try that

Ambugaton 0 solutions 1 answers

I have a dozin of plugins/tweaks and whatnot and (after numerous crashes and Mozilla wanted me to go safe mode) I activated them all again and refitted Mozilla to my own settings, EXCEPT to make Google.com my home page/start-up page. I have no more crashes in normal mode.

All personal settings in security, secrecy and such does not crash Mozilla for me, anyway. Only Google.com as home page.

MattMoz 1 solutions 10 answers

Helpful Reply

What worked for me (requires Adblock Plus plug-in):

  • Start firefox in safe mode.
  • Change homepage to default or some other page.
  • Restart firefox to re-enable plug-ins etc.
  • Navigate to google homepage (no crash when firefox already up and running).
  • Right click google doodle and click Adblock Plus: Block image.
  • Reset homepage to google and resart firefox to test.
  • Firefox starts ok and google doodle is gone.

While confirming the block rule you have a number of options. You could block all google doodles and logos with the custom setting to block http or https://www.google.co.uk/logos/*

Workaround complete. Sanity resumes.

ljswales 0 solutions 3 answers

It started today, Firefox crashing just after loading. It is the Google homepage showing the animation hurdles. Start up firefox in Safemode and just change the homepage to anything other than google.co.uk or google.com, Firefox will load correctly then. Once Firefox has loaded you can switch to google, the problem for me only happened when starting Firefox with google as the start page. No Gold medal for google on this one.

EvilAshe 0 solutions 3 answers

Google released a glitchy, poorly tested game on their front-page. Just hit ESC key quickly when opening the browser and it will stop it from loading and crashing Firefox. Another reason Google should stick with the "KISS" principle.

Modified by EvilAshe

EvilAshe 0 solutions 3 answers

It's a problem with the Hurdles game, cor-el. Nice stock response tho.

Modified by EvilAshe

Question owner

Thanks for all the replies I got. shows firefox being used by a lot.

I have no games on that computer, nothing at all. it is a work machine. I have scanned and rescanned it, cleaned all the system and temp files, disabled all securities, so on and so fort. nothing has worked.

I can set the Google as home page and it works fine but as soon as I customize the optional settings like "ask me where to save" or any other options, Firefox crashes.

And now it does not let me uninstall it either, it simply wont uninstall. System restore makes no difference either.

Any ideas out there?

Blazde 0 solutions 2 answers

There are no problems for me today now the game has changed to the basketball one. Maybe you had a different problem to begin with, or you've messed something else up while trying to fix it

Have you done Help Menu->Troubleshooting Information->Reset Firefox

gardengal444 1 solutions 17 answers

fascinating array of workarounds being reported, but where is Firefox responsbility here? It sounds like FF wants to blame Google webpage for their crashes!! huh? A quality browser should not crash on any site - period!!!!!!!!!

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

I've seen that there is now a different (baseball) doodle used on the Google search page, so the crashes might be over now.

There are a few bug reports related with the previously used hurdle doodle.

  • Bug 773097 - crash in gfxContext::~gfxContext()
  • Bug 734921 - Startup Crash @ _moz_cairo_destroy
templates 0 solutions 3 answers

it does not matter what page i set as the home page....msn, or cnn will just freeze the page and i can't move left or right....always have to resort to task manager to close it.... what gives suddenly this headache?

ljswales 0 solutions 3 answers

The google home page with hurdles crashed firefox and the new basket ball one today also crashes firefox. I reported the hurdle homepage yesterday and agree with the comments, google has caused a problem but firefox should have dealt with it. The user who suggested holding down the esc key, good suggestion and will stop firefox from crashing. Like other users I have a number of AddOns loaded which may be part of the problem. For the time being I will keep google as my home page and hold down the esc and wait for a firefox patch.

ljswales 0 solutions 3 answers

try holding down the esc key as firefox displays your home page.

skitomwoage 0 solutions 2 answers

I've got exactly the same problem. It also started yesterday. I tried to disable everything. Even though it flashed in my mind that the animation on google might be the problem, but I thought it was doubtful that google would cause it. I downgraded firefox too 13.0.1 and it worked fine.