X
Tap here to go to the mobile version of the site.

Support Forum

How to disable fonts antialiasing on Linux

Posted

I have Firefox 11 on Ubuntu 12.04. I have disabled antialiasing of fonts in the system, but Firefox seems to ignore this setting. Fonts are still blurred, which is very annoying and makes eyes tired. Is there any way to make fonts in Firefox sharp, as they are on Windows?

I have Firefox 11 on Ubuntu 12.04. I have disabled antialiasing of fonts in the system, but Firefox seems to ignore this setting. Fonts are still blurred, which is very annoying and makes eyes tired. Is there any way to make fonts in Firefox sharp, as they are on Windows?

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • The Totem 3.0.1 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

Hasan 469 solutions 5600 answers

See this article -> Fonts look blurry

Your User Agent shows that you are using Firefox 11. Would you like to upgrade to Firefox 12 ??

Check and tell if its working.

See this article -> [[Fonts look blurry]] Your User Agent shows that you are using Firefox 11. Would you like to upgrade to Firefox 12 ?? * [[Installing Firefox on Linux]] Check and tell if its working.

Question owner

The article is about Clear Type in Windows, so it's irrelevant. Upgrading to version 12 didn't help.

The article is about Clear Type in Windows, so it's irrelevant. Upgrading to version 12 didn't help.
Hasan 469 solutions 5600 answers

Try Disabling "Hardware Acceleration" to see if that makes any difference

  • Edit -> Preferences -> Advanced panel -> General tab -> Remove Checkmark from Use Hardware Acceleration when available
  • click OK -> Restart Firefox

Check and tell if its working.

Try Disabling "Hardware Acceleration" to see if that makes any difference * '''Edit''' -> '''Preferences''' -> Advanced panel -> General tab -> Remove Checkmark from '''Use Hardware Acceleration when available''' * click OK -> Restart Firefox Check and tell if its working.

Modified by Hasan

cor-el
  • Top 10 Contributor
  • Moderator
17687 solutions 160003 answers

What kind of monitor do you have (CRT or LCD) and with which resolution?

Does it help if you zoom the page?

If you select the proper anti-aliasing setting then it shouldn't look so bad that it isn't usable.

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB).

What kind of monitor do you have (CRT or LCD) and with which resolution? Does it help if you zoom the page? If you select the proper anti-aliasing setting then it shouldn't look so bad that it isn't usable. Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB).

Question owner

@mha007: Thanks for the suggestion. I've disabled hardware acceleration, but it didn't help.

@cor-el: I use an LCD monitor. Zooming page means that the fonts are bigger, but not sharp.

I'm attaching a screenshot. For comparison, there is a normal window with disabled antialiasing on the right of the picture. As you can see, the fonts are sharp in the system window and blurred in the Firefox window.

What is more - I remember that a few versions ago it was possible to display sharp fonts in Firefox but now I cannot do it.

@mha007: Thanks for the suggestion. I've disabled hardware acceleration, but it didn't help. @cor-el: I use an LCD monitor. Zooming page means that the fonts are bigger, but not sharp. I'm attaching a screenshot. For comparison, there is a normal window with disabled antialiasing on the right of the picture. As you can see, the fonts are sharp in the system window and blurred in the Firefox window. What is more - I remember that a few versions ago it was possible to display sharp fonts in Firefox but now I cannot do it.

Modified by pkalinow

kcpoole 0 solutions 1 answers

I also have the same problem. I can disable aliasing on the Gui and apps except Firefox and thunderbird.

I disable Antialiasing on a windows 7 machine and these 2 apps no longer do it, so why not on Linux?

Ken

I also have the same problem. I can disable aliasing on the Gui and apps except Firefox and thunderbird. I disable Antialiasing on a windows 7 machine and these 2 apps no longer do it, so why not on Linux? Ken
Tomek 0 solutions 3 answers

I have the same problem on FreeBSD, about one month ago I have updated gnome with all related ports and since then firefox and thunderbird show antialiased fonts. Screenshots:

Before upgrading they just worked fine (it was version 12 of firefox too)

Now I have updated xorg/gnome and firefox/thunderbird, current my versions are:

  • xorg-7.5.2
  • gnome2-2.32.1_4
  • firefox-12.0_1,1
  • thunderbird-12.0.1_1

everything installed from ports collection.

All other applications respect my fonts.conf but only firefox/thunderbird use antialiased fonts.

In firefox:

  • option 'use hardware acceleration' is off
  • zooming a page didn't help, in fonts.conf I have set fonts greater than 18px should be rendered with antialiasing -- and before upgrading gnome it worked under firefox fine (small fonts were rendered without antialiasing and large fonts were smooth)
I have the same problem on FreeBSD, about one month ago I have updated gnome with all related ports and since then firefox and thunderbird show antialiased fonts. Screenshots: * http://tmp.slimaczek.pl/tmp/firefoxaliasedfonts/firefox.png * http://tmp.slimaczek.pl/tmp/firefoxaliasedfonts/opera.png Before upgrading they just worked fine (it was version 12 of firefox too) Now I have updated xorg/gnome and firefox/thunderbird, current my versions are: * xorg-7.5.2 * gnome2-2.32.1_4 * firefox-12.0_1,1 * thunderbird-12.0.1_1 everything installed from ports collection. All other applications respect my fonts.conf but only firefox/thunderbird use antialiased fonts. In firefox: * option 'use hardware acceleration' is off * zooming a page didn't help, in fonts.conf I have set fonts greater than 18px should be rendered with antialiasing -- and before upgrading gnome it worked under firefox fine (small fonts were rendered without antialiasing and large fonts were smooth)
Hasan 469 solutions 5600 answers

Perform the suggestions mentioned in the following articles:

Check and tell if its working.

Perform the suggestions mentioned in the following articles: * [https://support.mozilla.com/en-US/kb/Template:clearCookiesCache Clear Cookies & Cache] * [[How to clear the cache#w_clear-the-cache|Clear the Network Cache]] Check and tell if its working.
Tomek 0 solutions 3 answers

It din't help, I even deleted all my profile (.mozilla) and firefox still displays antialiased fonts. The fonts are antialiased not only on a web page, all menus, dialog windows have such fonts.

It din't help, I even deleted all my profile (.mozilla) and firefox still displays antialiased fonts. The fonts are antialiased not only on a web page, all menus, dialog windows have such fonts.
cor-el
  • Top 10 Contributor
  • Moderator
17687 solutions 160003 answers

In your screenshot the menu shows like it is using a persona (text-shadow).

Are there any extensions installed globally?

Does disabling Boolean gfx prefs on the about:config page help?

In your screenshot the menu shows like it is using a persona (text-shadow). Are there any extensions installed globally? Does disabling Boolean gfx prefs on the about:config page help? *http://kb.mozillazine.org/about:config
Hasan 469 solutions 5600 answers

-> Start Firefox in -> Troubleshoot Firefox issues using Safe Mode to check if your add-ons/extensions are causing the problems.

Check and tell if its working normally while using Firefox in Troubleshoot Firefox issues using Safe Mode.

-> Start Firefox in -> [[Safe Mode]] to check if your add-ons/extensions are causing the problems. * Also see this article -> [[Troubleshooting extensions and themes]] Check and tell if its working normally while using Firefox in [[Safe Mode]].
Tomek 0 solutions 3 answers

I have deleted my .mozila profile in home directory, screenshots:

so it behaves like a clean install, nothing help.

I changed those gfx options:

  • gfx.color_management.enablev4
  • gfx.font_rendering.graphite.enabled
  • gfx.use_text_smoothing_setting

but it didn't help too.

I have deleted my .mozila profile in home directory, screenshots: * http://tmp.slimaczek.pl/tmp/firefoxaliasedfonts/firefox2.png * http://tmp.slimaczek.pl/tmp/firefoxaliasedfonts/firefox3.png * http://tmp.slimaczek.pl/tmp/firefoxaliasedfonts/firefox4.png so it behaves like a clean install, nothing help. I changed those gfx options: * gfx.color_management.enablev4 * gfx.font_rendering.graphite.enabled * gfx.use_text_smoothing_setting but it didn't help too.
khaled131 0 solutions 1 answers
I guess this could help [[http://new-balls.blogspot.com/2012/06/font-rendering-problem-in-firefox-on.html]]