Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox unilaterraly changes to an unreadable font - why? (it's now a real pain in the ***)

more options

On more and more pages (this one included) firefox unlalterally changes to an impossible to read (square) font. Ocassionally, a page can start in the usual arial font and then return in the unreadable format. It's becoming far too frequent resulting in me copying the URL to dreaded Windows Explorer - but at least this works. It has to be a simple recification issue else I may as well abandon Firefox after many years. There is also the issue of frequent crashes and getting more frequent - luckily Firefox can restore sessions easily.

All Replies (14)

more options

maybe related since the newer versions of firefox use hardware acceleration (your graphic card) to render web content - you might want to update the graphic driverson your system to the latest version provided by nvidia.

more options

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB).

more options

On any Windows system, yours may be missing a critical, needed system font, usually a font that's commonly seen or shared with web browsers as well as with the system.

If so, you will usually get the same exact symptoms that you have stated.

Joe

more options

I have now downloaded the latest nvidia driver BUT is hasn't solved the problem. Today, the first "support" screen was normal, then the problem started again - screenshot attached. It's a nromal screen with MS IE!

more options

The pages work perfectly in MS IE, so a mssing font is probably not the answer!

more options

it might be a combination of a corrupted font and hardware acceleration in firefox. you can try turning off hardware acceleration in tools > options > advanced > general

also refer to this help article: https://support.mozilla.org/en-US/kb/Some%20text%20shows%20up%20bold%20af.... you could also try deleting and reinstalling the arial font.

more options

Did you try to disable hardware acceleration?

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

You can use this extension to see which fonts are used for selected text.

more options

1. hardware acceleration disabled - no effect 2. font test - all prefect ! (this page is however, corrupt and hardly readable) working on choosing own fonts and fonts used. The pages that are corrupted in Firefox can be read perfectly in IE, so patience is radiply dwindling. Firefox patently doen't work properly and I should not have to go through this arduous effort to make it work. I'll try one more time, then goodbye Firefox (it's a shame because I'm not a fan of MS)

more options

Now installed the font test add-on - Firefox was restarted and this page is now perfect! 3 fonts used identified from @font-face - never heard of them and one has a weird long name. pppldiumwabbtxckgjqgijlwam - looks dodgy!

more options

Posted the reply and now back to corrupted screen!

more options

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

You can also try to use Clear Recent History to clear the cache.

more options

removed everything - all cookies, all cache, all temp files, all history. Problem still remains

more options

Can you improve things with this extension?

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

You can use this extension to see which fonts are used for selected text.

Modified by cor-el

more options

I downloaded all fonts again, set the default, and it worked. Might help.