X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I have downloaded Java but it does not show up in plug ins nor does it run. Any idea why? Using Win 8 consumerpreview. Tried re installing FF, still doesn't work - does work in IE

Posted

the question is pretty much complete.

Chosen solution

Did you download and install the 64 bit version of Java, or the 32 bit? Firefox is a 32 bit browser, which means it needs to 32 bit Java. http://javadl.sun.com/webapps/download/AutoDL?BundleId=61043 for Java 6, http://download.oracle.com/otn-pub/java/jdk/7u3-b05/jre-7u3-windows-i586.exe for Java 7

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • 4.1.10111.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • CANON iMAGE GATEWAY Mycamera Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

Chosen Solution

Did you download and install the 64 bit version of Java, or the 32 bit? Firefox is a 32 bit browser, which means it needs to 32 bit Java. http://javadl.sun.com/webapps/download/AutoDL?BundleId=61043 for Java 6, http://download.oracle.com/otn-pub/java/jdk/7u3-b05/jre-7u3-windows-i586.exe for Java 7

Question owner

I downloaded your link to Java 7 and it worked! Since my system is 32 bit - I think I downloaded 32 bit version before - regardless- works now- Thanks!