X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

vimeo video won't show

Posted

Firefox 11, embedded vimeo video, doesn't show up on the screen, doesn't play.

Additional System Details

This happened

Not sure how often

This started when...

I tried to view an embedded vimeo video.

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.1 r102
  • GEPlugin
  • Sony Reader Application Detector Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • 5.0.61118.0
  • iTunes Detector Plug-in
  • Unity Player 3.4.2f3
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • Picasa plugin
  • Provides additional functionality on Facebook. See our web site for details.
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • np-mswmp
  • Office Plugin for Netscape Navigator
  • Allows browsing on RealArcade sites with Mozilla browsers.

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

Opened Chrome to the same website; vimeo video worked fine. So I know it's not my internet security software blocking it.
Checked for FF plugins that might be required. Flash, Shockwave both installed and up to date.
Checked my privacy & security settings. Nothing in there seems to be preventing vimeo.
Searched online for solutions. Tried one from FF4, using about:config, resetting some video setting (can't remember which) to true. Didn't help either.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Helpful Reply

Does that happen with all videos on the Vimeo site?

It is possible that the video is encoded as H.264 and may not work if that is the case.

Question owner

I can watch videos at the Vimeo site. Thanks for suggesting that; I hadn't checked.

So are you saying that FF cannot play videos with certain encodings (I'm not technical, don't know the difference), while other browsers can? Is there a plugin or add-on I can install to fix that incompatibility?

Strange, though. I just went back to the 2 websites I was having vimeo problems with yesterday. Those videos ARE now showing & working in FF. Hmm. Any guesswork explanation for this?

Thanks for your help.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Was that a problem with embedding a Vimeo video on another web page (domain) or with viewing a video on the Vimeo site?

It may have been a problem with the Vimeo site or with the link on the page if it happened on another website and may have been corrected or there may have been a problem with the cache or cookies.

If it happens again then try to reload the web page and bypass the cache and possibly delete cookies from domains that are involved.

To bypass the cache:

  • Press and hold Shift and left-click the Reload button .
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Question owner

It was a viewing problem. It wasn't a problem with the site or link or video, because I was able to view it in Chrome on this same computer. I did try reloading the page, as well as closing the browser and reloading. No help. I didn't think to delete the cache or cookies though.

Thanks for the bypass-cache methods. Those will prove useful from time to time, I'm sure. And thanks again for your help.

JJ333 0 solutions 13 answers

Above (cache/cookies) methods don't work for me. Can't play embedded videos on Vimeo and RT.com anymore. With the earlier FF version I had to switch Plugin container off in order to play Real files. What will it be this time?  :-(

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Which Flash player do you have installed?

JJ333 0 solutions 13 answers

Thanks Cor-el Have 11.1.102.63 installed. Btw, there's no problem with playing the RT files (Mp4 and Flv) as they appear in the source. A discrepancy between Rt's (and Vimeo's) config and FF11, I suppose.

JJ333 0 solutions 13 answers

Downgrading to FF10 solved the problem with RT.

JJ333 0 solutions 13 answers

Helpful Reply

My config in FF 10/11:

dom.ipc.plugins.enabled.nptest.dll;false
dom.ipc.plugins.enabled.npswf32.dll;false
dom.ipc.plugins.enabled.npqtplugin.dll;false
dom.ipc.plugins.enabled.npctrl.dll;false
dom.ipc.plugins.enabled.i386.nppl3260.dll;false
dom.ipc.plugins.enabled;false

If 'dom.ipc.plugins.enabled;true' Vimeo works fine, but RealPlay does not.
No probs using MSIE.
Has anybody any suggestions, please?

Problem solved
120411 added: dom.ipc.plugins.enabled.nppl3260.dll;false
changed: dom.ipc.plugins.enabled;true
and now Vimeo and RT videos are both working.

Modified by cor-el

chrishough 0 solutions 1 answers

@JJ333

Where do we find that file in OSX so I can make the adjustment to fix this bug?

JJ333 0 solutions 13 answers

Chris - Mine is a PC (Vista) and the lines I mentioned are (or should be) in FF's configuration ('about:config').