X
Tap here to go to the mobile version of the site.

Support Forum

How can I copy absolute URL to clipboard from address bar?

Posted

I'm using FireFox10.0.2 on Windows7 Pro 64 bit. I need to copy an absolute URL to clipboard from address bar. How can I do that? I cannot find any Option to set this.

TIA.

I'm using FireFox10.0.2 on Windows7 Pro 64 bit. I need to copy an absolute URL to clipboard from address bar. How can I do that? I cannot find any Option to set this. TIA.

Chosen solution

If you mean that the http:// protocol is missing, you can change a setting to display that; the https:// is always displayed on a secure site.

The protocol (http://) has been removed from the URL in the location bar for http:// pages only. https:// pages will still have the protocol. This may be confusing to some users. There's also a known bug where if you copy the URL after selecting it from the awesome bar dropdown (but before loading the page) it won't include the http:// part.

Users can revert to the old behavior by setting browser.urlbar.trimURLs to false in about:config

  1. type about:config in the Location/URL/Address bar and press the Enter key
  2. if you see a warning, accept it (promise to be careful)
  3. Filter = browser.urlbar.trimURLs
  4. double-click on the pref in the lower panel to toggle it to "false" OR right-click on the pref in the lower panel and choose "Toggle" to toggle it to "false"
  5. close the about:config tab


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



You should consider upgrading to Firefox 11 as it was released last week. Firefox versions 4.0-10.0.2 are considered abandoned and are no longer supported.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • 4.0.60831.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

More Information

SafeBrowser 543 solutions 2390 answers

Chosen Solution

If you mean that the http:// protocol is missing, you can change a setting to display that; the https:// is always displayed on a secure site.

The protocol (http://) has been removed from the URL in the location bar for http:// pages only. https:// pages will still have the protocol. This may be confusing to some users. There's also a known bug where if you copy the URL after selecting it from the awesome bar dropdown (but before loading the page) it won't include the http:// part.

Users can revert to the old behavior by setting browser.urlbar.trimURLs to false in about:config

  1. type about:config in the Location/URL/Address bar and press the Enter key
  2. if you see a warning, accept it (promise to be careful)
  3. Filter = browser.urlbar.trimURLs
  4. double-click on the pref in the lower panel to toggle it to "false" OR right-click on the pref in the lower panel and choose "Toggle" to toggle it to "false"
  5. close the about:config tab


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



You should consider upgrading to Firefox 11 as it was released last week. Firefox versions 4.0-10.0.2 are considered abandoned and are no longer supported.

If you mean that the '''''http://''''' protocol is missing, you can change a setting to display that; the '''''https://''''' is always displayed on a secure site. The protocol (http://) has been removed from the URL in the location bar <u>for http:// pages only</u>. '''https:// pages will still have the protocol'''. This may be confusing to some users. There's also a known bug where if you copy the URL after selecting it from the awesome bar dropdown (but before loading the page) it won't include the http:// part. Users can revert to the old behavior by setting browser.urlbar.trimURLs to false in about:config #type '''''about:config''''' in the Location/URL/Address bar and press the Enter key #if you see a warning, accept it (promise to be careful) #Filter = '''browser.urlbar.trimURLs''' #double-click on the pref in the lower panel to toggle it to "false" '''''OR''''' right-click on the pref in the lower panel and choose "Toggle" to toggle it to "false" #close the about:config tab '''If this reply solves your problem, please click "Solved It" next to this reply when <u>signed-in</u> to the forum.''' --------------------- You should consider upgrading to Firefox 11 as it was released last week. Firefox versions 4.0-10.0.2 are considered abandoned and are no longer supported. *See --> https://support.mozilla.org/en-US/kb/Updating%20Firefox

Question owner

Thank you very much for your quick & right answer! It worked!! It was easy to follow the steps you explained.

Thank you very much for your quick & right answer! It worked!! It was easy to follow the steps you explained.