Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

In Firefox 10, tooltips/hoverover text no longer displays unless I use Safe Mode. Disabling all extensions, add-ons, and even doing a profile wipe and fresh install changed nothing. This issue did not occur with earlier verisons of Firefox.

more options

As described in the question, I can no longer view hoverover text/tooltips on webpages where I know they exist (and they continue to work in other browsers, including prior versions of Firefox.) Safe Mode displays them, but a regular instance of the browser does not, even when I boot with add-ons and extensions disabled. I removed my profile and wiped the install before reinstalling fresh, but this also did nothing to change the situation. Is there any way of fixing this short of going into about:config and toggling gfx.direct2d.disabled to "true"? It seems a weird way to fix this sort of thing, and I question why it suddenly stopped working in the first place.

Modified by LordHuffnPuff

All Replies (4)

more options

In Firefox 4 and later Safe mode disables extensions and disables hardware acceleration.

Try to disable hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

If disabling hardware acceleration works then check if there is an update available for your graphics display driver.

more options

I have two separate graphics cards. One is an integrated intel that uses a custom manufacturer's driver and can't be updated, and the other is an NVIDIA that is up to date. As I said, this issue did not occur in prior versions of Firefox [including ones installed on this machine], and I've been using the browser consistently since Firefox 2. I am boggled about why hardware acceleration would cause this issue now. I suspect that something else may be at work, as the changes to my computer between using Firefox 9 and upgrading to Firefox 10 were exactly zero.

more options

This has been driving me nuts for months on my Lenovo T420 laptop. I also have an NVIDIA card (with up-to-date driver) and built-in manufacturer card. Turning off hardware acceleration does seem to solve the problem for me. What's bizarre is that I only get this problem when I dock at my office, not when I dock at home. My home setup uses two older Hitachi monitors (one of which is plugged in via VGA cable), while my work setup uses two newer ASUS monitors (both of which are plugged in via HDMI cables). I also have no issues just using my laptop's built-in monitor.

Modified by danthman

more options

Same problem here. Lenovo W520, Windows 7, display driver version 8.17.12.7658.

I did find a workaround though:

  1. Go to Tools > Options > Advanced.
  2. Uncheck "Use hardware acceleration when available". Now the tooltips will work.
  3. Go back into the options and re-enable hardware acceleration. The tooltips will continue to work.

The trigger for this bug seems to be launching Firefox with hardware acceleration enabled, so you'll have to repeat these steps every time you launch.

See bug: https://bugzilla.mozilla.org/show_bug.cgi?id=712242

Modified by cheesechoker