X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to set the tab options to open new tabs always as a blank page?

Posted

Hello everyone. I installed a translation program (Babylon), and meanwhile I have already uninstalled it. But since then, everytime a create a new tab, it opens with the Babylon search engine. How do I remove this? I already checked the options regarding this subject, but none is suitable for this, I'm afraid.

Thank you.

Chosen solution

There appears to be several parts to Babylon

  • An application installed on system -- uninstall via add programs
  • A firefox extension -- tools > add-ons > find Babylon and uninstall
  • Entries in about:config that can be found by filtering on babylon, and right-click on each and reset.
  • Stuff in C drive -- very unclear
  • Registry entries -- uninstalling should fix, but there are tools

Try these pages

Read this answer in context 7

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Shockwave Flash 10.3 r183
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; pt-PT; rv:1.9.2.21) Gecko/20110830 BTRS31753 Firefox/3.6.21

More Information

David McRitchie 321 solutions 3089 answers

Chosen Solution

There appears to be several parts to Babylon

  • An application installed on system -- uninstall via add programs
  • A firefox extension -- tools > add-ons > find Babylon and uninstall
  • Entries in about:config that can be found by filtering on babylon, and right-click on each and reset.
  • Stuff in C drive -- very unclear
  • Registry entries -- uninstalling should fix, but there are tools

Try these pages

Question owner

Thank you very much Dmcritchie. Very clear and complete answer! By the way, it was an add on ;)

David McRitchie 321 solutions 3089 answers

Thanks. An add-on is what I thought as that is what Firefox would see, but so many people say they uninstalled Babylon and then there are very extensive back and forth answers only to find out that it was the add-on itself and the others with "same" problem were inconclusive and not the questions owner.

But you may also have some problems with search bar, and with external searching (Google is the default) from the location bar. Of course those problems that others have might be related to something else installed at the same time, and I didn't want to confuse the issue with these convoluted previously "solved" Babylon questions.

But you might want to look through just in case you recognize something else.

GreatnessJ 0 solutions 1 answers

I actually just found the simplest way to remove this stupid Add-On! Tools > Add-Ons >Extentions > Disable and REMOVE!!

I removed the Babylon application or whatever from Control Panel/Programs and it didn't do a thing. And then I had removed the .XML file from the Mozilla program folder and THAT didn't do anything. After I had poked around and removed the stupid extention, it's gone!

Spread the word!

JonLedbury 0 solutions 1 answers

So your solution is to vaguely 'poke around' a bit is it? I never downloaded Babylon nor gave permission for it. They've twice given me instructions for removing it, both of which led to non existent pages. what sort of a scam are they?

jetxtreme 0 solutions 1 answers

Hi I am experiencing the same problem. Everytime I open a new tab in firefox, the babylon search engine opens by default. I tried to open the add-ons window then on the extensions manager tab but I was not able to see the babylon toolbar. Is there any other place that babylon might be hiding?

slim-sadie 0 solutions 1 answers

Thank you GreatnessJ! This is JUST what I needed to do. Not only was the Babylon extension forcing the search engine problem, but it had actually disabled my ability to activate "login / logout" hyperlinks. BIG problem fixed. Again, thank you!