X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I keep getting this message The proxy server is refusing connections Firefox is configured to use a proxy server that is refusing connections.

Posted

message continued... Check the proxy settings to make sure that they are correct. Contact your network administrator to make sure the proxy server is working..

When I go to Tools, Options, Advanced Configure how Firefox Connects to the Internet the settings are Manual with theHTTP proxy set to 127.0.0.1 Port 50687.  Then it says No Proxy for localhost 127.0.01.  In order to do anything I change the setting to Autodetect, but it keeps switching back.  Please tell me what to do.  

The only other thing I did today was to run a Malwarebytes scan that found some bad files and they were quarantined/deleted. I'm not sure if this has anything to do with it.

Additional System Details

This happened

Not sure how often

This started when...

Today

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Shockwave Flash 10.3 r181
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.60531.0
  • NPWLPG
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

foxyshadis 2 solutions 15 answers

Set it to no proxy, maybe it's misdetecting. If it switches back, download ComboFix from bleepingcomputer, reboot into safe mode, and run it. Check the guides on combofix if you need help, but it's a dirt simple tool.

Question owner

I'm confused as to how this got set to the manual mode with that Http proxy to begin with . I guess I don't understand the impact of changing the setting to No proxy. And how will that help me get it to stop selecting manual mode. UGH!

foxyshadis 2 solutions 15 answers

Helpful Reply

If you've ever tried something like Privoxy, the installer can change your proxy settings because it does install a local proxy. If not, you probably have a virus that was redirecting traffic to itself, and Malwarebytes only fixed part of the problem (the proxy part, not the FF part).

No proxy is the normal way people browse. Proxies are normally only used in commercial and sometimes university environments, aside from the rare person who installs a local proxy to filter ads.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

See also:

Question owner

Thanks for the info, but I'm getting weary on this one. I do not think the extensions are the problem. It seems to me that my preferences are not being saved and when I went to the preferences not saved link you provided I could not find the files listed. I don't seem to have a prefs file at all anywhere. This morning, after running a virus scan and another Malwarebytes scan, I uninstalled and reinstalled Firefox hoping that would solved the problem, but it didn't. I have installed Firefox 4 because I really like the McAfee Site Advisor and an hesitant to do 5 in fear of losing it. The problem seems to be that when I exit Firefox, the Internet Option keep resetting to Manual and it directs the access to my network card. Any ideas on my prefs files and where they may be would be great or how to get them back or resolve this short of using Internet Explorer!

Question owner

Tried one last thing and removed the Personas add-on (which I love) and it seems that is what was causing the problem. Let's hope this lasts. Thanks for all your help.

saforaRM 1 solutions 8 answers

I'm also getting this problem. It seems every time I shut down FF, it defaults back to manual proxy setting. When I set it to No Proxy, or Automatic or whatever, it only keeps for that one session. I'm running FF 4 because 5 won't let me use some of my add-ons that I like. I've been using the same add-0ns forever and it's not been a problem until just this past couple days. Any other ideas? Thanks in advance.

Question owner

The problem for me was the use of Personas. I like them, but when I disabled them the problem went away. Turned them on again and the problem came back. I think if you disable Personas it will make the problem go away, but to me that's not the resolution. But it's better than having to reset the internet connection preferences every time you logon and refreshing every tab. If you find out another answer, please post because I really do like using the Personas.

slammed02chevy 0 solutions 1 answers

I have discovered the way to fix this issue. I was having the same error message "Firefox is configured to use a proxy server that is refusing connections." I went into the Tools-> Options-> Advanced-> Network-> Settings and my Proxy Server settings kept shedding to Manual at http proxy 127.0.0.1 and the port was 53636. I tried selecting to Automatically Detect Proxy Server AND No Proxy Server. Both options worked and allowed me online, but as soon as I closed Firefox and got back in, it would give me the same error, and I had to start all over again. Pain in the butt. I even tried disabling Personas as jmusser969 suggested, but this did NOTHING for me. I then uninstalled Firefox (at which point I noticed it was no longer listed in my Programs on my start menu... strange). I didn't fully uninstall everything because I didn't want to lose all of my bookmarks etc. When I reinstalled it was still having the issue.

Finally I went through my quarantine log on McAfee. I found two files in the Quarantine log titled "Proxy-OSS" and "Proxy-OSS.dll". I selected those files in McAfee and chose to delete them completely.

Once I deleted them, I opened firefox and VWALA! No more proxy server issues.

Hope this helps everyone!

iSenne 0 solutions 1 answers

Helpful Reply

I had the same problem. But my virus scanner did not found any "Proxy-OSS" stuff on my computer. Weird thing is that my proxy server was set to ip "127.0.0.1" and port "8888". When I googled that, I found it was the same settings as Fiddler.

When I turned off the Fiddler addon, my FireFox worked perfectly!

cynthiageiger 0 solutions 1 answers

I had this problem with the proxy server message. Go to Tools then click on options, click the network tab, go to settings and click use systems proxy settings click OK This corrected the problem for me. I missed my Firefox. I'm very happy to have it working again. Hope this works for you too.

Question owner

Thanks for the info, but setting my system to system proxy setting didn't do a thing. Seems the only way to get around this problem for me is to not have Personas installed.

SUBZER0 0 solutions 2 answers

Man...this has really become a problem hasn't it? I've been fighting with it for a couple months now. BUT (insert dramatic music) I think I may have found the answer!!! Not 5 minutes ago I tried this and it worked. Here's what I did:

1) Go to the connection settings as described in many of the posts above. 2) Right at the bottom is an option that reads "Automatic proxy configuration URL" 3) Simply type in your desired homepage! For example "http://www.google.com"

Hope this helps!!!

pizza132 0 solutions 1 answers

I have this same problem on a Mac OS X with Firefox. I disable my proxy add-ons the problem goes away, so this will probably work on Windows too. Hope this helps.

Paul 0 solutions 3 answers

It's cool and everything to share war stories, but when is MOZILLA going to actually FIX this problem? This condition has persisted for several revisions of Firefox, and I have just one question (which I'd like answered by a Firefox developer, rather than another user). Why aren't the changes to my network settings being saved after I have confirmed them and exited the TOOLS menu? This is procedure in every application I know of! Modify settings/save changes/exit, and the new settings are recorded and maintained until the next time you choose to modify them.

Paul 0 solutions 3 answers

No data

Modified by Paul