X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox opens all links in a new window

Posted

I am using Firefox 4.0.1. I have checked the settings on my browser under Tools / Options / Tabs and "open new windows in tabs" is set. However, whenever I click on a link on a website, Firefox opens the link in a new window. This occurs even if I right click on the link and choose the option to open the link in a new tab instead of a new window.

This behavior began just recently. To the best of my knowledge, none of the add-ons have updated recently.

Additional System Details

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.43.7
  • Version 2.0.7.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.4"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 10.2 r159
  • Next Generation Java Plug-in 1.6.0_25 for Mozilla browsers
  • 4.0.60310.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Application Basics
Name
Firefox
Version
4.0.1
User Agent
Mozilla/5.0 (Windows NT 5.2; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Microsoft .NET Framework Assistant
1.2.1
false
{20a82645-c095-46ed-80e3-08825760534b}
Java Quick Starter
1.0
true
jqs@sun.com
BetterPrivacy
1.49
true
{d40f5e7b-d2cf-4856-b441-cc613eeffbe3}
Webmail Ad Blocker
3.3.2
true
gmailnoads@mywebber.com
Morning Coffee
1.35
true
morningCoffee@shaneliesegang
New Tab Homepage
0.4.3
true
{66E978CD-981F-47DF-AC42-E3CF417C1467}
Java Console
6.0.22
true
{CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA}
Java Console
6.0.24
true
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
Java Console
6.0.25
true
{CAFEEFAC-0016-0000-0025-ABCDEFFEDCBA}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://
browser.startup.homepage_override.buildID
20110413222027
browser.startup.homepage_override.mstone
rv:2.0.1
browser.tabs.warnOnClose
false
extensions.lastAppVersion
4.0.1
font.size.variable.x-western
17
general.useragent.extra.microsoftdotnet
(.NET CLR 3.5.30729)
network.cookie.lifetimePolicy
2
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1307570881
places.history.expiration.transient_current_max_pages
255547
places.last_vacuum
1295825339
privacy.cpd.siteSettings
true
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce 9500 GT
Vendor ID
10de
Device ID
0640
Adapter RAM
Unknown
Adapter Drivers
nv4_disp
Driver Version
6.14.12.7533
Driver Date
5-20-2011
Direct2D Enabled
false
DirectWrite Enabled
false (0.0.0.0, font cache n/a)
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
GPU Accelerated Windows
2/2 Direct3D 9

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

In Firefox 4 you can use one of these to start in Troubleshoot Firefox issues using Safe Mode:

  • Help > Restart with Add-ons Disabled
  • Hold down the Shift key while double clicking the Firefox desktop shortcut (Windows)