Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I go to JoyceMeyer.org to watch a vido I get this as a mesage "Firefox doesn't know how to open this address, because the protocol (rtmp) isn't associated with any program." What's the matter?

  • 4 replies
  • 8 have this problem
  • 89 views
  • Last reply by bankim

more options

I went to JoyceMeyer.org to watch her broadcast, but I got the following message:

Firefox doesn't know how to open this address, because the protocol (rtmp) isn't associated with any program.

How can this be fixed?

All Replies (4)

more options

I have the problem too. Running in Safe Mode doesn't make any difference.

It appears to be an MP4 file, but I don't see that format in the Applications list (Firefox button, then Options | Options | Applications). I changed it in Win XP to open with Quicktime, but it doesn't seem to make any difference.

I will try to find a way to add the MIME type to the menu and will update this thread later today.

more options

Thanks for the info, but so far I don't know how it's helpful.

more options

OK, here's what you have to do to get this to work.

  1. Open Windows Explorer and at the top, click Tools and choose Folder Options from the menu.

  2. Click the File Types tab and scroll down to MP4.

  3. Click the button called Change and in the next menu, choose Quicktime Player (see screenshot).

  4. Click Apply/OK.

  5. Next, open Firefox and in the location bar at the top, type: about:config and hit Enter.

  6. In the filter at the top, copy/paste the following: network.protocol-handler.expose.mp4 This will result in a blank page appearing but this is intentional.

  7. Right click anywhere in the blank area and choose, New then Boolean.

  8. Copy/paste: network.protocol-handler.expose.mp4 into the dialog box and click OK.

  9. In the next menu, choose False.

  10. Close the tab and go to the site. The video should now play correctly.

Modified by Xircal

more options

In my window explore in folder option I could not find m4 file option. I have other mp4 p, v but not extansion what you had mention

So how can I add the same.