X
Tap here to go to the mobile version of the site.

Support Forum

When I download a program, It appears as downloaded in the download box, but when I click it, It says it's a Binary File & won't open it, When I try to search for the program, nothing appears, How do I get Firefox to allow me to run other programs?

Posted
  • This problem fails for EVERY Program I try to download.
  • In the download, it shows it has been downloaded. It gives the size, the website where I got it from.
  • When I right click, it just gives me options to delete it off the list
  • When I first try to download it, it will cancel automatically, I have to go back and click refresh on the download.
* This problem fails for EVERY Program I try to download. * In the download, it shows it has been downloaded. It gives the size, the website where I got it from. * When I right click, it just gives me options to delete it off the list * When I first try to download it, it will cancel automatically, I have to go back and click refresh on the download.

Additional System Details

This happened

Every time Firefox opened

This started when...

I downloaded Firefox from Internet Explorer and started using Firefox Permanately.

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.1 r85
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • ScorchPlugin
  • Musicnotes Viewer plugin 1.17.3 For more information visit Musicnotes.com
  • Rhapsody Player Engine Plugin
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Xircal 334 solutions 3835 answers

Try running Firefox in Troubleshoot Firefox issues using Safe Mode. If it functions properly in that configuration, then one of your add-ons is the culprit.

Also, update Flash a.s.a.p. The version you have installed at the moment is vulnerable to attack. See Exploit on Amnesty pages tricks AV software

You can update it from here: http://get.adobe.com/flashplayer/

Also, update Java via Windows Control Panel | Java | Update.

Try running Firefox in [[Safe Mode]]. If it functions properly in that configuration, then one of your add-ons is the culprit. Also, update Flash a.s.a.p. The version you have installed at the moment is vulnerable to attack. See [http://www.h-online.com/security/news/item/Exploit-on-Amnesty-pages-tricks-AV-software-1230724.html Exploit on Amnesty pages tricks AV software] You can update it from here: http://get.adobe.com/flashplayer/ Also, update Java via Windows Control Panel | Java | Update.

Question owner

I tried to update the Java, both ways and they both said that something was wrong with my internet connection, when clearly, I have the Internet..I went and redid the Internet settings again, but it still said that something was wrong and Java couldn't be updated. Aaahh!

I tried to update the Java, both ways and they both said that something was wrong with my internet connection, when clearly, I have the Internet..I went and redid the Internet settings again, but it still said that something was wrong and Java couldn't be updated. Aaahh!

Modified by samwaida

Xircal 334 solutions 3835 answers

You can check your version @ http://www.java.com/en/download/installed.jsp and update it from there if necessary as well.

You can check your version @ http://www.java.com/en/download/installed.jsp and update it from there if necessary as well.

Question owner

It says I have the wrong version downloaded, I tried to download the right version, but it comes up binary file, like jxpiinstall.exe ... I've noticed that ".exe" is common when downloading a program, if that means something or not. I am going to try running in Safe mode to see where the problem is coming from

It says I have the wrong version downloaded, I tried to download the right version, but it comes up binary file, like jxpiinstall.exe ... I've noticed that ".exe" is common when downloading a program, if that means something or not. I am going to try running in Safe mode to see where the problem is coming from

Question owner

I ran it in safe mode and it still did the exact same thing. I can't download the Java I'm supposed to have

I ran it in safe mode and it still did the exact same thing. I can't download the Java I'm supposed to have
Xircal 334 solutions 3835 answers

Hit CTRL+SHIFT+DEL, change the dropdown menu to Everything, checkmark Cache (uncheck the others) and then click the Clear Now button.

Then go to Tools | Options | Advanced | Network (tab) and in the middle menu, click the Clear Now button.

Next, go to Tools | Options | Privacy and click the Show Cookies button. Type Java in the Search field and then delete all the Java cookies. If you have a Cookie manager installed, make sure it's configured to accept cookies from java (dot) com.

Then go to the following link: http://www.java.com/en/download/manual.jsp

You want the online file which will be an .exe. See screenshot.

Hit CTRL+SHIFT+DEL, change the dropdown menu to '''Everything''', checkmark '''Cache '''(uncheck the others) and then click the '''Clear Now '''button. Then go to '''Tools '''| '''Options '''| '''Advanced '''| '''Network '''(tab) and in the middle menu, click the '''Clear Now''' button. Next, go to Tools | Options | Privacy and click the Show Cookies button. Type Java in the Search field and then delete all the Java cookies. If you have a Cookie manager installed, make sure it's configured to accept cookies from java (dot) com. Then go to the following link: http://www.java.com/en/download/manual.jsp You want the online file which will be an .exe. See screenshot.

Question owner

Okay, I did everything (thank you!), Java downloaded... i guess, it's in the download box. I'm not to sure what to do with it though.

Okay, I did everything (thank you!), Java downloaded... i guess, it's in the download box. I'm not to sure what to do with it though.
Xircal 334 solutions 3835 answers

Click the Downloads button in Firefox to open the manager, then right click the file you downloaded and choose Open Containing Folder.

Then simply run it i.e. double click it.

Click the Downloads button in Firefox to open the manager, then right click the file you downloaded and choose Open Containing Folder. Then simply run it i.e. double click it.

Question owner

It doesn't give me that option, It's there, but it isn't highlighted. The only options i can choose are "copy download" "select all" and "remove from list".

It doesn't give me that option, It's there, but it isn't highlighted. The only options i can choose are "copy download" "select all" and "remove from list".
Xircal 334 solutions 3835 answers

Presumably it shows as having been completely downloaded?

If you can't find it, just hit Windows key + F to launch Search, copy/paste the name: jre-6u24-windows-i586-iftw.exe and then click Search

When the search utility finds it. right click it and choose Open Containing Folder.

Presumably it shows as having been completely downloaded? If you can't find it, just hit Windows key + F to launch Search, copy/paste the name: '''jre-6u24-windows-i586-iftw.exe '''and then click Search When the search utility finds it. right click it and choose Open Containing Folder.

Question owner

It's not showing up, but it is in my download box as download complete.

It's not showing up, but it is in my download box as download complete.
Xircal 334 solutions 3835 answers

I think you must have Windows configured not to show file extensions. Can you hit Windows key + E to open Windows Explorer, then click Tools | Folder Options | View.

Checkmark "Show Hidden Files and Folders" and remove the checkmark from "Hide file extensions for known file types.

Then Apply/OK and run the search again please.

I think you must have Windows configured not to show file extensions. Can you hit Windows key + E to open Windows Explorer, then click '''Tools '''| '''Folder Options''' | '''View'''. Checkmark "'''Show Hidden Files and Folders'''" and remove the checkmark from "'''Hide file extensions for known file types'''. Then Apply/OK and run the search again please.

Question owner

I did that too, windows was configured to not show file extensions, but it still doesn't show up when i search for it.

I did that too, windows was configured to not show file extensions, but it still doesn't show up when i search for it.
Xircal 334 solutions 3835 answers

OK, how have you configured Firefox to handle downloads? The setting is located in Tools | Options | General.

You'll either have "Always ask me where to save files" enabled, or "Always save files to this location" which is "Downloads" by default. If it's the latter, go to C:\Documents and Settings\{Username}\My Documents\Downloads and you should find it in there.

OK, how have you configured Firefox to handle downloads? The setting is located in Tools | Options | General. You'll either have "'''Always ask me where to save files'''" enabled, or "'''Always save files to this location'''" which is "Downloads" by default. If it's the latter, go to C:\Documents and Settings\{Username}\My Documents\Downloads and you should find it in there.

Question owner

I have the latter, But I'm not sure where the "C:\Documents and Settings\{Username}\My Documents\Downloads" is, would it be easier if I just click the always ask me where to save files button?

I have the latter, But I'm not sure where the "C:\Documents and Settings\{Username}\My Documents\Downloads" is, would it be easier if I just click the '''always ask me where to save files''' button?
Xircal 334 solutions 3835 answers

Sorry, forgot you have Vista. Go to C:\Users\{Username}\Downloads

Sorry, forgot you have Vista. Go to C:\Users\{Username}\Downloads

Question owner

It's still only appearing in download box...

It's still only appearing in download box...
Xircal 334 solutions 3835 answers

Can you do the following please. In the location bar, type about:config and hit Enter.

In the filter at the top, copy/paste the following: browser.download.manager.scanWhenDone

Double click it to change it from "True" to "False"

Then close Firefox and restart it again.

Next, download the file again. You should be able to right click it and get the option "Open Containing Folder" afterwards which will take you to the file.

Can you do the following please. In the location bar, type '''about:config '''and hit Enter. In the filter at the top, copy/paste the following: '''browser.download.manager.scanWhenDone''' Double click it to change it from "True" to "'''False'''" Then close Firefox and restart it again. Next, download the file again. You should be able to right click it and get the option "Open Containing Folder" afterwards which will take you to the file.

Question owner

(I typed that in the windows start menu)It won't allow me to do that. It says "unable to open this internet shortcut. The protocol "about" does not have a registered program" When I type About:config in the search box it pulls up a system configuration shortcut and a backup status and configuration shortcut..would either of those be what I am looking for? or did I type It in the wrong place?

(I typed that in the windows start menu)It won't allow me to do that. It says ''"unable to open this internet shortcut. The protocol "'''about'''" does not have a registered program"'' When I type About:config in the search box it pulls up a system configuration shortcut and a backup status and configuration shortcut..would either of those be what I am looking for? or did I type It in the wrong place?

Modified by samwaida

Question owner

where is the Location Bar?

where is the Location Bar?