X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When sending a new email in hotmail, the "insert" line of buttons are "unclickable" so no file can be attached or emoticon, etc. Are there any fixes?

Posted

Running Windows XP pro, all software is up to date, running latest versions of firefox.----these buttons do work when using any other browser. In firefox, the buttons are visible but they wont change the pointer arrow to the finger when you mouse over them. This seems to have been doing this since the new version of hotmail has been out. The forums on hotmail have asked this same question but the customers are always directed to go back to the web browser developers.

Chosen solution

Which Firefox version do you have ?

You posted with a Firefox 3.0.13 user agent that looks corrupted

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.13; .NET CLR 2.0.50727; ffco7) Gecko/2009073022 Firefox/3.0.13

You can see the Firefox version at the top and the user agent at bottom of the "Help > About" window (Mac: Firefox > About Mozilla Firefox).

You can check the general.useragent prefs on the about:config page.
You can open the about:config page via the location bar, just like you open a website.
Filter: general.useragent
If general.useragent prefs are bold (user set) then you can right-click that pref and choose Reset.

See Web sites or add-ons incorrectly report incompatible browser and Find what version of Firefox you are using

See also http://kb.mozillazine.org/Resetting_your_useragent_string_to_its_compiled-in_default

Read this answer in context 3

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • getplusplusadobe16263
  • Garmin Communicator Plug-In 2.9.2.0
  • np-mswmp
  • NapsterLink
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Winamp Application Detector
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Provides additional functionality on Facebook. See our web site for details.
  • Google Update
  • Shockwave Flash 10.1 r82
  • iTunes Detector Plug-in
  • Delivery Network Acceleration by BitTorrent™
  • npFFApi
  • 4.0.50524.0
  • Virtual Earth 3D 4.00090316005 plugin for Mozilla
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Version 0.9.8a, copyright 1996-2008 The VideoLAN Teamhttp://www.videolan.org/
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.13; .NET CLR 2.0.50727; ffco7) Gecko/2009073022 Firefox/3.0.13

More Information

Question owner

This still happens while in safe mode.

cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97009 answers

Chosen Solution

Which Firefox version do you have ?

You posted with a Firefox 3.0.13 user agent that looks corrupted

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.13; .NET CLR 2.0.50727; ffco7) Gecko/2009073022 Firefox/3.0.13

You can see the Firefox version at the top and the user agent at bottom of the "Help > About" window (Mac: Firefox > About Mozilla Firefox).

You can check the general.useragent prefs on the about:config page.
You can open the about:config page via the location bar, just like you open a website.
Filter: general.useragent
If general.useragent prefs are bold (user set) then you can right-click that pref and choose Reset.

See Web sites or add-ons incorrectly report incompatible browser and Find what version of Firefox you are using

See also http://kb.mozillazine.org/Resetting_your_useragent_string_to_its_compiled-in_default

Question owner

i have firefox 3.6.10-- the general:useragent reset worked!! although another problem is, that my browser doesnt always display a news site I use. I cant scroll through set of picture they display for some stories.

cor-el
  • Top 10 Contributor
  • Moderator
10779 solutions 97009 answers
  • "Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"
  • "Remove the Cookies" from sites that cause problems: Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

Question owner

I figured out it was a section that I was blocking with Adblock plus. I just had to reset it and got it to work. Many thanks for the help!!

rowfars 0 solutions 1 answers

I have this problem too. I'm using a standard one year old macbook with Firefox 3.6.10. Until recently I had no problems with inserting attachments to hotmail emails. Now the attachment function is inoperable- grayed out, no hand to select. Thank you for your help in achieving a resolution to this problem.

dancer229 0 solutions 1 answers

Helpful Reply

Been searching how to fix for days...finally fixed it!! The "inset" links are controlled by Microsoft Silverlight, http://www.microsoft.com/silverlight/. I uninstalled the plugin then reinstalled it and it fixed the problem.

I am on a mac so im not sure if this would also work for windows.
Allygator 0 solutions 2 answers

Helpful Reply

I have also found that it is the Silverlight plug-in that disables the emoticon and attachments functions in hotmail when using the Firefox browser. I tried dancer's solution of uninstalling and then reinstalling Silverlight, but it didn't solve the problem. The only way I am able to use all the functions in hotmail is to disable the Silverlight plug-in whenever I use hotmail.

SmotherTeresa 0 solutions 1 answers

Having exact same problem; I simply uninstalled Silverlight, problem solved. The attachment bar now active in hotmail along with those 'orrible emoticons etc... YouTube videos still play, so no worries...

SittinNWaitin 0 solutions 1 answers

Bingo! I also uninstalled Silverlight to solve this exact problem. Did this following a long online chat with Bell support tech who concluded that the problem was 'my computer'(Acer Aspire 5738 Windows 7 less than a yr old). I can't understand why MicroSoft isn't aware of this: it's all their software - Silverlight, Windows Live/Hotmail and Internet Explorer(FF showed the symptoms when in Hotmail; IE and Safari actually fail when attempting to create a new message!)

MacHotmail 0 solutions 1 answers

I have a mac and after reading this I uninstalled Silverlight AND deleted all the Silverlight plugs in. This made all the attachment buttons "clickable". I use Safari. See below from mac help.

To remove a plug-in:

Quit Safari.

Locate the plug-in. Plug-ins are usually installed in one of these folders:

/Library/Internet Plug-Ins/

(To find this folder, open the hard disk icon, and then open the Library folder.)

~/Library/Internet Plug-Ins/

(This folder is in your home folder (represented by the tilde ~). To find it, open the hard disk icon, open your home folder, and then open the Library folder.)

Remove any plug-ins you’ve added. You may need to enter the account name and password for an administrator account on your computer.

IMPORTANT:Removing a plug-in might prevent Safari from doing certain tasks, such as playing movies.

Reopen Safari. If the problem is fixed, contact the developer of the plug-in to report the problem and to see if there is a newer version of the plug-in.

cadwellparker 0 solutions 3 answers

Thanks for al these posts. I have disabled Silverlight in 'Manage add ons' in Firefox 4 and the problem has vanished :-) Was only getting this issue in ver 4 since updating from 3.6, reverting to 3.6 also got things working again. Maybe it's ver 4 that doesn't like something in Silverlight? I had previously un/re installed silverlight, cleared cache and cookies and tried running Firefox in safe mode to no avail.

Okay, disabling silverlight will do it, I had similar problems, but this is not a solution! Mozilla should update this so that it would work. Because silverlight is needed in places and it's quite irritating to go to always enable/disable it. I'm running firefox 7, had this problem already on ff4 and 5.

Or could this be the cause? *HUOH* if i turn off the silverlight anyway hotmail shouldn't work because it needs silverlight and that's why it works for a while but soon starts laggin if i turn off silverlight. But what is THE CAUSE of this kind of annoying bug..? :/ Thanks, Matias i know i know thread is half a year old..