Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

does not open hyperlinked emails on all websites (to send an email) !!!

  • 8 replies
  • 121 have this problem
  • 199 views
  • Last reply by Annabee

more options

last week, out of a sudden, Firefox stopped allowing me to open an email when I click on CONTACT US or an actual email address on a website (any website, including my own). I don't get any error message or a warning, simply nothing happens when I click on an email hyperlink. How doI know that's Firefox issue? because I CAN open hyperlinked emails in Internet Explorer (which I keep as a back up browser), no problem. I have never had this issue with Firefox up until now, either.

As I much prefer to use Firefox (and always do), this is a very annoying problem.

Grateful for advice! thanks Anna

All Replies (8)

more options

Chosen Solution

more options

well, my 'mail to' WAS MS Outlook, but I clicked on it again, anyway. and...

IT WORKED!!!!!!!!!!!!!!!!! yeay!

''''THANK YOU!!!!''''

more options

Maybe the update to MS Outlook 2007 changed the Registry and Firefox needed to be forced to look at the Registry again to find MS Outlook 2007 all over again.

Glad you got it sorted out.

more options

I updated Outlook AFTER that problem occurred......I also have another problem - it stopped recognising my Go to Meeting program (go to the webinar), its looks like a pattern....I have re-conformed all the links in Applications, hopefully this will fix it!

thanks again!

more options

All settings were already correct. I use Outlook 2003 professional, with all service packs and updates installed, within XP Pro. The problem is of recent origin and it's very annoying. Almost enough to make me stop using Firefox. There has to be a reason/solution for this.

more options

I have a Gmail account and have followed the appropriate steps. Firefox still does not open email links. Any other thoughts?

Would be greatly appreciated.

more options

check the proxy-settings item... sometime awhile ago the default was changed from 'no proxy' to 'use system settings'... for me, this solved my problem... see: https://support.mozilla.com/en-US/kb/Changing%20the%20e-mail%20program%20used%20by%20Firefox/discuss/79

more options

I tried all the remedies once and none worked, so I tried them all again and switched off Firefox. When I clicked a hyperink in a new email message it worked!!! I have no idea how - but thanks anyway. Now I just have to get rid of that annoying Yahoo search every time I open a new window.