X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Adobe flash plugin crashes when I open Frontierville in Facebook

Posted

9 out of ten times that I open Frontierville in Facebook I get an error that says "Adobe Flash plugin has crashed". I have reinstalled the plugin numerous times. I cleared my cache. Finaly, after 2 days of this I uninstalled and reinstalled both Firefox and Adobe Flash. Still the same problem. This is getting ridiculous, what can I do?

URL of affected sites

http://

Additional System Details

Installed Plug-ins

  • -getplusplusadobe16263
  • Macromedia Shockwave for Director Netscape plug-in, version 10.1
  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape
  • NPTURNMED
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.1 r53
  • iTunes Detector Plug-in
  • GEPlugin
  • Picasa plugin
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.50524.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • Google Update
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 ( .NET CLR 3.5.30729)

More Information

Troubleshooting Information
This page contains technical information that might be useful when you're
trying to solve a problem. If you are looking for answers to common questions
about Firefox, check out our support web site.
Copy all to clipboard
Application Basics
Name
Firefox
Version
3.6.4
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adblock Plus 1.1.3 true
Amazon Wish List 1.1 true amznUWL@amazon.com
Autofill Forms 0.9.5.2 true autofillForms@blueimp.net
Gmail Manager 0.6 true {582195F5-92E7-40a0-A127-DB71295901D7}
Java Console 6.0.13 true
Java Console 6.0.15 true
Java Console 6.0.17 true
Java Quick Starter 1.0 true jqs@sun.com
Microsoft .NET Framework Assistant 1.2.1 true {20a82645-c095-46ed-80e3-08825760534b}
ReloadEvery 3.6.2 true {888d99e7-e8b5-46a3-851e-1ec45da1e644}
Zynga Toolbar 2.5.8.6 true {7b13ec3e-999a-4b70-b9cb-2617b8323822}
Java Console 6.0.20 true
Adobe DLM (powered by getPlus(R)) 1.6.2.63 true

Morbus 134 solutions 2338 answers

Hello Wildfyre.

You need to contact Adobe for support on their Flash player plugin.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Did you use the Flash uninstaller?

Flash Player uninstall: http://www.adobe.com/go/tn_14157 (this will remove the Firefox Flash plugin and the ActiveX control for IE)

Question owner

I started having the same problem playing a few of the games on my facebook the last few days, I took notice after a update came in for my firefox. So what I did was: Go to this site http://www.oldapps.com/firefox.php and download to my PC "Firefox 3.6.3" it's and older version of firefox. The newest version is just one version higher"3.6.4".

Ok once you have it downloaded and saved it to your PC, go to your add and remove programs and uninstall the Firefox version you have on your PC. I find it's good to clean my registry after I uninstall anything, I use CCleaner for that. It's free online, just Google it. After you have uninstalled and used CCleaner, go to where you saved your firefox download, and run the program. 

It's just that easy. Everything is working fine now.

Good LUCK.... BracGypsy.

)

Question owner

I have same problem.

Morbus 134 solutions 2338 answers

If you are having a problem with Adobe Flash Player, you need to contact Adobe for support. They are the ones who develop it.

Question owner

Thank you BracGypsy! Going back to the old version of Firefox fixed it! :-)

Question owner

Firefox developers, it seems to me that if the older version of Firefox running with the newest version of Flash player fixes the problem, this is not an issue Adobe can fix. You need to find the issue in 3.6.4 that causes Flash Player to work differently than in 3.6.3, and solve that issue. This is your responsibility.

Morbus 134 solutions 2338 answers

Anonymous2, while I understand your point of view, you need to understand that plugins are made for the browsers, not the other way around. You'll see that you have different Flash installers for Internet Explorer and for Firefox, for example. This is a clear indicator of how Adobe (in Flash's case) has to make different versions of Flash for different browsers. All plugins are the same, even though this example may not apply to all of them. Plugins are made to be inserted in the browsers, not the other way around. So if Flash is having some sort of problem with Firefox, you need to contact Adobe. They will make sure Firefox developers fix any eventual bugs, if they find that it's not their fault, don't worry.

Question owner

I've tried contacting Adobe and had no luck.

Thankfully some people on here are more helpful than Morbus. I followed BracGypsy's advice and it fixed my problems with Flash as well.

Why would it be Adobe's problem that a Firefox update messed up the way that Flash works inside the browser? They didn't do anything - Firefox did.

Morbus 134 solutions 2338 answers

Helpful Reply

CPAddict, know that it is not recommended to downgrade for Firefox 3.6.3, since Firefox 3.6.4 includes security fixes from previous versions. You'll probably find version 3.5.10 to be the best solution, if you want to downgrade, as it contains all the latest security fixes, but doesn't have plugin isolation.

If you want an answer for your question, please read this post.

Question owner

I'm beginning to realize I may have been quick to jump to conclusions. It doesn't make sense for the issue to lie with Firefox or with Flash, since other Zynga Facebook apps (such as Farmville, Treasure Isle, etc.), which also use Flash, work with Firefox 3.6.4. The issue most likely lies with the Frontierville App itself, which probably has some sort of conflict with the new version of Firefox, causing the plugin to crash. There is nothing now to do except wait for Zynga to realize and correct the problem.

Question owner

Anonymous2,

yes it is best to think before speaking or typing in this case. It is NOT an Adobe or Mozilla issue. The problem is with the Frontierville coding.

Zynga has surely received notification by now. Just wait a day or two and all will be right as rain again.

Question owner

I am also having the same problem with Zynga's Treasure Isle for the past 2 days. It is starting to happen with FarmVille, as well. I don't play FrontierVille, but Treasure Isle just added a whole bunch of new things to it. My husband is in IT and we followed all the directions ie, uninstalled the old Adobe Flash, installed the new, etc. He said it is not a problem with our/your computer, but with the Zynga/Firefox partnership. Hopefully, it will be corrected shortly. I miss my treasures :-(

Question owner

https://support.mozilla.com/en-US/kb/The+Adobe+Flash+plugin+has+crashed

This should fix the problem with the new version.

Question owner

I had the same problem with Facebook games. Tried to fix the Adobe flash plugin by uninstalling it and then installing it again. Did it several times, no help. Then found this site and followed the advice by BracGypsy and it totally fixed my problem. Thank you!

Question owner

Hello Everyone, BracGypsy again.

 The games are crashing again.
    I just a few minutes ago received the automatic update of firefox. It updated back to version: ( Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 (.NET CLR 3.5.30729) SO I know it's the newest update craching the games, it's NOT the games. Foxfire update is crashing. (FrontierVille) (Treasure Isle) and Farmvile. I am not sure about any of the other games Zynga has, as I haven't logged in any others yet.

All my games worked fine with version 3.6.3.

Until firefox fixes this issue with the newest UPDATE, I will be uninstalling firefox version 3. 6.4 again and reinstalling 3.6.3 again. I thought maybe I would turn off my updates, BUT I will leave my automatic update on. :) In-case there's a FIX.

Everyone who's having crashes with their games please go here: http://www.oldapps.com/firefox.php and download firefox version 3.6.3 and the crashing of your games will STOP. DO remember to clean your registry before you reinstall the 3.6.3 version of firefox. Like I said in my posting above, CCleaner does well with the registry.

Well everyone, lets go play our games now. :) and hopefully Mozilla will get whatever is crashing the games fixed soon.

I love Firefox.. Good luck Mozilla.

BracGypsy  :)

Question owner

Ok I uninstalled 3.6.4 of Firefox AGAIN, and reinstalled the older version 3.6.3 of Firefox, all my games are back working again now.

Since the crashing of games started happening with the newest update of 3.6.4 version of Firefox, then there's no doubt it's the newest update that's the problem with the games crashing.

Seems to me' you guys (Mozilla) finding out what's different with 3.6.4 update, than what 3.6.3 had, would be a solution to fix it. Sounds logical to me.

Sometimes I find little simple solutions most of the time work. But putting blame where it doesn't belong just isn't where it's at, specially since I know and others here know as plan as day the problem is the 3.6.4 update of Firefox. What I don't understand is, why fix something that isn't broken in the first place? After all' 3.6.3 version of Firefox worked great!

Good luck guys, with fixing Firefox 3.6.4 update.

BracGypsy!  :)

Question owner

Firefox 3.6.4 isolates plugin processes including Adobe Flash. This prevents crashes and hangs in Flash from taking down the main Firefox process. By default, if Flash is not responsive for 10 seconds, Firefox will terminate it and display The Adobe Flash plugin has crashed. However, some Flash-based games such as FarmVille and Mafia Wars can take more time than to load, unnecessarily triggering this hang protection.

Increase the plugin timeout

You can increase the plugin timeout to help avoid this. However, if you do so, it will take longer for Firefox to detect if the Flash process does hang or crash.

  1. In the Location bar, type about:config and press EnterReturn.
         * The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise!, to continue to the about:config page. 
  2. The about:config page should appear. In the Filter box, type dom.ipc.plugins.timeoutSecs
  3. Double click the setting and increase the number to 30 to have Firefox wait longer before shutting down Flash. 

copied from https://support.mozilla.com/en-US/kb/The+Adobe+Flash+plugin+has+crashed

I set mine to 60 instead of 30 but that's just me.

And since this worked on all 3 of my computers with the new version of firefox and flash i'll assume it works on everyone elses as well. v.v *is sad first post seemed to be ignored*

Question owner

You may also want to change the browser.sessionstore.interval to 120000 instead of 10000 but once again that's just me.

-The guy who reads memos

tallshort 0 solutions 2 answers

If this issue still occurs on the latest version of Flash Player and Firefox, please report it to http://bugs.adobe.com/jira for further investigation.