X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

After the upgrade to 3.6, my flash player crashes while I'm trying to play Farmville. I have tried updating the flash player. I have tried restarting the computer. Nothing is working.

Posted

Last night, my system was still using Firefox 3.5.8. I was playing Farmville on Facebook and everything was working fine. This morning, I log onto my computer and find that I am upgraded to Firefox 3.6. I have been trying to play Farmville all morning, and the Adobe Flash Player keeps crashing. I have tried to update the Flash Player. I have tried restarting the computer. Nothing is working.

URL of affected sites

http://facebook.com

Chosen solution

Another potential cause of this issue is that the hang timeout is set too low:

  1. Select Firefox's location bar (press CTRL+L or click it)
  2. Type about:config and press enter
  3. Click I'll be careful, I promise!
  4. in the Filter box, type dom.ipc.plugins.timeoutSecs
  5. Double click the setting and change the number.

The default number is 10, for a default wait time of 10 seconds. Some Flash games can be slow and require a higher setting. I would recommend changing this to 20 if you are having problems with this.

Also, it would be really helpful if people experiencing this problem let us know which Flash games are slow - and when they become slow. Thanks!

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • -Image Control Plugin for viewing images on Ancestry.com. Version 1.0.0.1
  • getplusplusadobe16263
  • Express View Browser Plugin
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 6.0.12.732
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.1 r53
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • iTunes Detector Plug-in
  • Picasa plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Yahoo! activeX Plug-in Bridge
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 ( .NET CLR 3.5.30729)

More Information

I don't understand what you want here; sorry.

zzxc 22 solutions 242 answers

There are several factors that can cause the latest Flash version to crash. Firefox 3.6.4 protects the rest of the browser from also crashing when Flash hangs or crashes.

  • Flash video acceleration is incompatible with your video card: Flash 10.1 includes video acceleration, which can cause problems on certain systems. Try turning it off following the steps on this page: http://kb2.adobe.com/cps/403/kb403107.html
  • Other plugins are interfering with the content on the page. Try disabling all plugins (in Tools->Add-Ons->Plugins) except Shockwave Flash, Java, and Adobe PDF. (These are the most commonly used plugins)
  • You may have spyware on your system. See Troubleshoot Firefox issues caused by malware.

Question owner

I have the same problem!!

OMg New version auto updated me. Now cant watch youtube!!!

Any way to downgrade?

Question owner

Same problem for me, farmville and other games were working perfectly fine until the new update for firefox. I have tried everything this is really irritating. please help.

zzxc 22 solutions 242 answers

Anonymous, Juan Cruz: could you try the steps above I suggested, and reply back with whether they worked? Thanks!

Question owner

None of the fixes that were suggest to me worked. I did the following:

Disabled the plug-ins Ran my malware software to ensure that there was no spyware Turned off the video acceleration.

None of this worked. I want to go back to the old Firefox as well. I'm pretty salty about the fact that I was not given a choice as to whether I wanted to switch to it or not. I typically like to wait a few months before switching to an upgraded internet browser so that bugs--like this one--are all worked out before I am inconvenienced.

Question owner

same problem! However, upon doing nothing-one minute it works, next it does not. Youtube works fine. Webkinz does not. NEVER had a problem until firefox updated to 3.6.4 and then it recommended updating adobe flash player to 10.1.

Question owner

I had already tried all those suggestions you mentioned before I posted, it always says adobe plugin (Shockwave) has crashed. I don't understand, everything was working fine before the update :(.

zzxc 22 solutions 242 answers

Helpful Reply

To anyone experiencing this problem after trying the steps I posted above, try this potential solution:

  1. Open Tools->Add-Ons->Plugins, find Shockwave Flash, and press Disable
  2. Hold down the Windows logo key and press R to bring up the Run dialog.
  3. Type %APPDATA% and press OK.
  4. Open the Adobe folder
  5. Right click on the Flash Player folder and press Rename. Type in Old Flash Player as the new name.
  6. Go back to the Application Data or AppData folder. (On Windows XP, click Up in the toolbar. On Windows 7 or Vista, click AppData in the address bar)
  7. Open the Macromedia folder and repeat step #5
  8. Go back to the add-ons window from step #1, and press Enable on Shockwave Flash
  9. Try Farmville, Youtube, and other affected sites to see if the problem is fixed.

Question owner

It's the crash protection not FLASH. I have successfully reverted to my previous version of firefox without changing a thing. Everything works again just like before. The problem is firefox 3.6.4 not flash, not my video drivers, not java, not malware, not other plugins.

Question owner

I have the same problem with the adobe flash player I have fox fire mox and everytime I get on frontierville it crashes why I have checked spyware and plugins as you suggested but it still doesnt work I have everything updated like the suggested but nothing works...What do I do now ?

Question owner

Can someone just tell me how to disable crash protection in 3.6.4?

Question owner

The second fix did not solve the problem; the player crashed almost instantly. The end result of my renaming the folder Old Flash Player was the creation of another folder that was named Flash Player. I'm done monkeying around with this. I'm going to switch back to the old version of Firefox. And if I can't do that, I'll try using another internet browser. I have spent the entire day trying to get this to work.

Question owner

I updated to 3.6.4 and also selected the Flash upgrade. Now all the menus from File thru Help all have gone nuts and drop down and flash sequentially. Cursor in boxes like this runs wild and select buttons, like above, cycle repeatedly.

How do I return to previous version?

Question owner

Yea can someone tell us how to return to the old version this is horrible 2nd fix didn't work for me either. I'm definetly thinking of just downloang chrome

Question owner

Yes, please someone tell us how to revert to the old version. If you have to send me an email off this board, it's littleangeljw@yahoo.com

Thanks!

Cheng Wang
  • Administrator
  • Moderator
36 solutions 435 answers

Firefox 3.6.4 has in addition to crash protection, a lot of security fixes. Rather than downgrading to 3.6.3, if you're sure crash protection is the problem, just turn it off.

Go to about:config in your address bar. You should see a page with lots of settings. Find dom.ipc.plugins.enabled and double click to set to false. Restart Firefox.

Morbus 134 solutions 2338 answers

To anyone having problems of this sort:

You may be having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not coming from one of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode and select Disable all add-ons. If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and theme. You can troubleshoot plugins the same way.

If you want support for one of your add-ons, you'll need to contact its author.

Question owner

My Firefox auto updated today. Now my flash keeps crashing. I just want to roll back to previous version until bugs are worked out.

Question owner

I disabled all add-ons and restarted my browser, and still have the same problem with Flash crashing.

zzxc 22 solutions 242 answers

Chosen Solution

Another potential cause of this issue is that the hang timeout is set too low:

  1. Select Firefox's location bar (press CTRL+L or click it)
  2. Type about:config and press enter
  3. Click I'll be careful, I promise!
  4. in the Filter box, type dom.ipc.plugins.timeoutSecs
  5. Double click the setting and change the number.

The default number is 10, for a default wait time of 10 seconds. Some Flash games can be slow and require a higher setting. I would recommend changing this to 20 if you are having problems with this.

Also, it would be really helpful if people experiencing this problem let us know which Flash games are slow - and when they become slow. Thanks!