Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesn't work on www.everydropwater.com website.

  • 5 replies
  • 0 have this problem
  • 24 views
  • Last reply by jonzn4SUSE

more options

I tried to add a new credit card to my subscription account on the www.everydropwater.com website. My attempts failed twice for no apparent reason. I called their customer support at 1-800-442-9991 and described my problem. They asked me which browser I was using. I told them "Firefox". They said that's the problem, their credit card update function simply does not work under Firefox!

I was appalled that they know their site doesn't work under a popular browser, yet they don't seem to care or be interested in fixing their site!

Can you folks fix this problem? (I felt like a traitor when I downloaded and used Chrome to get around it.)

I'm using 64-bit Firefox 112.0.1 under Windows 10 version 22H2 on a Dell laptop.

Thanks!!

I tried to add a new credit card to my subscription account on the www.everydropwater.com website. My attempts failed twice for no apparent reason. I called their customer support at 1-800-442-9991 and described my problem. They asked me which browser I was using. I told them "Firefox". They said that's the problem, their credit card update function simply does not work under Firefox! I was appalled that they know their site doesn't work under a popular browser, yet they don't seem to care or be interested in fixing their site! Can you folks fix this problem? (I felt like a traitor when I downloaded and used Chrome to get around it.) I'm using 64-bit Firefox 112.0.1 under Windows 10 version 22H2 on a Dell laptop. Thanks!!

Chosen solution

I'm not surprised. Mark it as resolved and good luck.

Read this answer in context 👍 0

All Replies (5)

more options

arnold1231 said

Can you folks fix this problem? (I felt like a traitor when I downloaded and used Chrome to get around it.)

LMAO

You're not a traitor, just using the tool that works at the moment. Did you try the same process with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_how-to-start-firefox-in-4troubleshoot-modesf5safe-modesf

You will have to provide more detail on what not working means. Also try to provide screenshots of the issue and block your personal data. Just take a screenshot of the issue, save the pic to your desktop, and then open it in windows paint to hide your personal info. It's hard to help with something we cannot see or have access to replicate.

more options

I would also recommend you compare products to ensure you're getting what you pay for.  ;-) https://zerowater.com/ They sale the pitcher and filters at Walmart. You can buy small one that comes with a meter test how well your current filter works.

more options

You got me fired up when it comes to water. https://www.youtube.com/results?search_query=zerowater everydropwater wants to you to just trust there ads... looks shady to me. Do your research... I digress ;-))

more options

Apparently this is -NOT- a browser issue! Sorry for the false alarm! And thanks for your advice!

For those interested, here's the rest of my story...

Our refrigerator's "replace water filter cartridge" light comes on once or twice a year. In the past we had a bad experience with a generic cartridge from Amazon, so I went to Amana's website and set up a subscription to automatically order a new cartridge twice a year using my debit card. Amana's official provider for their filters is the company called "everydropwater".

A couple months ago my bank replaced our debit cards with new ones, with different numbers. So this week I logged into my account at Amana/Everydropwater in order to add my new debit card as a payment method and delete the old card.

So far, so good... But...

I typed in the data for the new card, but after I clicked on 'Submit' it popped back to square one, ready to add a new card, still showing the old card as the only payment method on file. After "failing" in this way several times I called their Customer Support. Their agent promptly insisted it was a browser issue, and insisted (several times) that I mustn't use Firefox. I thanked her for her assistance.

Then while Chrome was downloading I posted in this forum.

But...... A few minutes later I encountered the exact same behavior using Chrome! So I called them (again) and a different agent answered. I described my problem and she said she had never heard of this being a browser issue, but insisted I needed to wait 24 to 48 hours for my new card data to "take". I told her that was silly but she insisted I needed to wait. I thanked her for her assistance.

Today, after more than 48 hours my new card data still didn't show up!

Now I realize their agents don't have a clue what's going on, and are simply giving their own personal guesses as "official" answers!!!

I refuse to deal with a company showing that much incompetence, so I canceled my subscription and will not deal with them again! (As it happens, the same cartridges are available off the shelf at Home Depot.)

Good grief!

more options

Chosen Solution

I'm not surprised. Mark it as resolved and good luck.