Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

SVG SMIL animate attributes fill="remove" not working?

  • No replies
  • 1 has this problem
  • 2 views
more options

I'm animating a SVG by dragging the mouse that changes the <path d=""> attribute. When mouseUp I'm setting the <animate values="" > to animate from that dragging point and start the animation. This works fine. But if I want to drag it for a second time it looks like the animation has been set to <animate fill="freeze"> although it has been set to "remove". In other words, it looks like the attribute fill="remove" doenst work. I can drag the object (and alter the <path d=""> ) but it doenst show after the animation has been completed for the first time. It only plays the animation.

I'm animating a SVG by dragging the mouse that changes the <path '''d=""'''> attribute. When mouseUp I'm setting the <animate '''values="" '''> to animate from that dragging point and start the animation. This works fine. But if I want to drag it for a second time it looks like the animation has been set to <animate fill="freeze"> although it has been set to "remove". In other words, it looks like the attribute fill="remove" doenst work. I can drag the object (and alter the <path '''d=""'''> ) but it doenst show after the animation has been completed for the first time. It only plays the animation.