Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Email alert on multiple accounts

  • 11 replies
  • 1 has this problem
  • 35 views
  • Last reply by Matt

more options

Hi, I have a few email accounts set up in Thunderbird (rel 91.7.0 32bit, Win10 21H1). On the work email (the first account) I receive complete notifications when receveing new email (sound and popup with sender/subject). On the personal one, I can only hear the sound and see the new mail red icon in the traybar but I can't see any preview. As far as I can tell, the notifications setting are not account-specific, and I would expect all accounts to behave the same in that respect. Does anybody have idea/suggestions to activate the popup alert also for the other account? Many thanks in advance Luca

Hi, I have a few email accounts set up in Thunderbird (rel 91.7.0 32bit, Win10 21H1). On the work email (the first account) I receive complete notifications when receveing new email (sound and popup with sender/subject). On the personal one, I can only hear the sound and see the new mail red icon in the traybar but I can't see any preview. As far as I can tell, the notifications setting are not account-specific, and I would expect all accounts to behave the same in that respect. Does anybody have idea/suggestions to activate the popup alert also for the other account? Many thanks in advance Luca

All Replies (11)

more options

is one of the accounts using an addon to connect to an exchange server perhaps?

Helpful?

more options

Hi Matt, thanks for your help. Actually the main one I think yes, it's an Office365 account provided by my university which should run on an exchange server. The one which is not working is a personal account with my former Italian internet provider (libero.it). Is it expected that the exchange one fagocitates all popups for some reason? Oh, I forgot to add that all of them are configured to use IMAP.

Modified by gwaedin

Helpful?

more options

I would be more inclined to think the OWL extension might suppress the other (unintentionally).

Could you create a new profile with just the liberto account and see if it acts correctly? That way we might get an idea where to look for what is happening. Being IMAP is willl not affect your existing profile.

Use the About:profiles in the More troubleshooting information (help menu) to manipulate and change and create profiles.

Helpful?

more options

I just created a dummy profile only with the libero account and indeed it works. Sounds you're right. I can live with that, I asked because I thought there was some option I had overlooked in the menus.

Helpful?

more options

Just a thought...you say the Office365 account is current set up as the default account - positioned at the top......but does it make any difference if in Account Settings, you set up the 'Personal' account as default and then restart Thunderbird?

You can always swap it back later if it makes no difference.

It would be useful feedback.

Helpful?

more options

Huh... I'm not sure about how to do it properly. Is it enough to drag it up on the account setting window so that it's on top of the list? I can't find any setting such as that of a "default" account in my profile.

Helpful?

more options

In 'Account Settings' In left pane - Select the personal account Click on 'Account Actions' Select 'Set as default'

Then restart Thunderbird. Image below as guide.

Helpful?

more options

Yeah, if I do that the alerts work nicely on libero. They also continue working on the Office365 one (tried that as well). Which by the way solves the problem, because I can make my personal one the default account AND still have the other one on top in the left panel, which I think was the main reason why I put the work one as default. Thanks for the very helpful suggestions!

Modified by gwaedin

Helpful?

more options

Mmm... not sure I have solved it. Apparently some messages are still received with no popup alert, only the sound. However, I realize now that they are being sent to dedicated folders by mean of a filter (applied before Junk classification). I think that since they don't land in the main Inbox folder, the alert is not triggered.

Helpful?

more options

Hi everyone:

I have the same or similar problem. It started on installing one of the the latest releases. I am on 91.9.0 (32-bit) currently.

I have seven accounts all of them generate a new mail sound but the new mail alert popup notice is inconsistent and only appears inconsistently and not always on the same account all the time. I check for new messages on all accounts once a minute.

No add-ons or Exchange accounts. Comcast and Gmail. One set of filters to change color based on account.

I don't see any new or relevant setting options to change or update the new mail alerts. I am not using Windows notifications since I want to see who the email is from and its subject before opening it.

Prior to the newest release, every account generated new mail alerts and they were all blended into one alert.

I thought I read somewhere in the release notes there was a notification change, but I can't find it now.

Any ideas what to do?

Modified by wbolivia

Helpful?

more options

wbolivia said

Hi everyone: Any ideas what to do?

Change your checking to a more reasonable time frame. 1 minute might work if the server is also on your desk and it is connected with a fibre link. Otherwise your inconsistencies are caused be the mail fetch routines running over the to of one another.

Modern mail servers using IMAP will notify you when you get new mail (GMail has the Idle command required, probably not comcast. They appear to still be somewhere in the middle of the last century. But it is worth trying.). There is no need to actually "check" mail at all between startups, although Thunderbird does default to a check every 10 minutes in case the sever slips up as the server notification cover new mail. but synchronisation changes like read state do require a syncronisation.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.