On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Saving Tabs On Exit

  • 6 replies
  • 2 have this problem
  • 89 views
  • Last reply by fabimol356

more options

Title is pretty self-explanatory- I'm wondering if there is a way to save all current tabs upon exit of firefox, opening the same tabs when opening the browser again.

I've seen the same issue posted here dating back to 2011 but the answers provided don't seem to work for me.

Any help is appreciated.

Thanks!

Title is pretty self-explanatory- I'm wondering if there is a way to save all current tabs upon exit of firefox, opening the same tabs when opening the browser again. I've seen the same issue posted here dating back to 2011 but the answers provided don't seem to work for me. Any help is appreciated. Thanks!

All Replies (6)

more options

Yes, it's hidden in Settings.

≡ -> Settings -> General -> Open previous windows and tabs

more options

TyDraniu said

Yes, it's hidden in Settings. ≡ -> Settings -> General -> Open previous windows and tabs

Hi Ty,

Thanks for the quick response.

Unfortunately, I can't see that setting or one similar.

Are there additional settings that I need to enable?

Cheers.

Modified by mecixi7903

more options

Perhaps it's a different name in your version. It's the first or 2nd checkbox in the General panel.

more options

Would it be restore previous session? If so, it's greyed out for me and un-togglable

Thanks again.

more options

OK, that's it. Go to Settings -> Privacy & Security -> and make sure that [ ] "Always use Private Browsing mode" is not selected.

Modified by TyDraniu

more options

TyDraniu said

OK, that's it. Go to Settings -> Privacy & Security -> and make sure that [ ] "Always use Private Browsing mode" is not selected.

This is the original poster's reply.

Thanks for your help Ty, this worked for me.

Have a great day!