Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No secure connection.

  • 1 reply
  • 1 has this problem
  • 11 views
  • Last reply by FredMcD

more options

Everytime I try to connect to a site for the first time during that session I get a connection error. See the images added.

Attached screenshots

All Replies (1)

more options

SSL_ERROR_RX_UNEXPECTED_APPLICATION_DATA https://support.mozilla.org/en-US/questions/1169369 In short, the problem is broken support for TLS1.3 in the corperate middleware.

A workaround is: 1. Go to about:config 2. Find setting 'security.tls.version.max' 3. Change value from '4' to '3'. ++++++++++++++++++++++++++++++++++++++++++++ ssl_error_rx_malformed_alert https://support.mozilla.org/en-US/questions/1024043 I used the malwareBytes' Anti-Malware, and it worked perfectly, it solved my Problem . . ++++++++++++++++++++++++++++++++++++++++++++ There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connection certificates and send their own.

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

Websites don't load - troubleshoot and fix error messages

http://kb.mozillazine.org/Error_loading_websites

What do the security warning codes mean

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.