Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can't open websites or login

more options

I've tried to follow all of the suggestions as to fixing why Firefox won't open websites or login - none fixed the issue.

Thanks for any suggestions Dianne

All Replies (6)

more options

You can check for issues caused by a corrupted or incomplete Visual C++ installation that is missing runtime components (Redistributable Packages) required by Firefox.

See "Visual Studio 2015, 2017 and 2019":

Helpful?

more options

Thank you - I'm installing now & will let you know if this helps!

Helpful?

more options

Unfortunately this fix didn't work. Firefox was working perfectly until a day ago?

Does it have anything to do with the upgrade? Should I uninstall and reinstall?

Thanks 1

Helpful?

more options

It is possible that your firewall or other security software blocks or restricts Firefox without informing you, possibly after detecting changes (update) to the Firefox application. Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access for Firefox and the plugin-container process and the updater process.

See:


Try to start Firefox in Safe Mode to see if that works.

  • Windows: hold down the Shift key while starting Firefox
  • Mac: hold down the Options key while starting Firefox

Helpful?

more options

I'm very frustrated - this happened on another older laptop but when I got my new one with windows 10 all was perfectly fine with firefox.

I tried all of the above suggestions and nothing works including safe mode. I'd tried doing the firewall fix, twice. Should both the private and public checks be checked on permissions?

I have to get on with my day & use another browser. But I will check for your suggestions later and try anything! Thank you

Helpful?

more options

The fix was quite easy: I refreshed Firefox and it works perfectly with the website logins etc.

Thank you for your replies and suggestions.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.