Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I've done the restart firefox to stop freezes multiple times. Still happens. Any ideas?

  • 1 reply
  • 1 has this problem
  • 10 views
  • Last reply by FredMcD

more options

I keep getting freezes, slow downs, sometimes a warning that a page is slow to respond. I'm running FF 83.0. I have the following add-ons: - AdBlock - Colorful Tabs - Hover Zoom - Scroll Zoom - Search by Image.

I'm guessing one of the add-ons is causing the problem, but don't know which one. I've done the restart firefox to stop freezes multiple times. Still happens. Any ideas?

All Replies (1)

more options

”Webpage is slowing down your browser” This is the new way the browser tells you there is a problem with the script program(s). https://support.mozilla.org/en-US/kb/warning-unresponsive-script?cache=no

https://support.mozilla.org/en-US/kb/task-manager-tabs-or-extensions-are-slowing-firefox


camelclub76 said

I'm guessing one of the add-ons is causing the problem, but . . .

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.