Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Changing the setting where delete button take you back a page

  • 4 replies
  • 1 has this problem
  • 93 views
  • Last reply by cor-el

more options

How do I change, or is there a way to stop the browser from going back a page when i press delete too many times on a box or I haven't managed to click where I thought I had?

All Replies (4)

more options

You probably mean the Backspace key, whose primary function is to delete a character left of the cursor (in left-to-right mode), the Delete key deletes right of the cursor (or at cursor in a command-line interface). This thread will help you: https://support.mozilla.org/en-US/questions/924490

more options

You can set browser.backspace_action = 2 on the about:config page to disable the backspace action.

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

more options

What is the = number to set browser.backspace_action = to to turn this ON? I love the easy one-key page-back shortcut, and it has suddenly stopped working with today's update! :-(

more options

That should be browser.backspace_action = 0

See comment 56:

  • Bug 1041377 - Disable Backspace as a shortcut for navigating back in history [87]

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)