Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

A Web Page Is Slowing Down Your Browser

  • 3 replies
  • 1 has this problem
  • 15 views
  • Last reply by FredMcD

more options

I receive the message "A web page is slowing down your browser". I have read the other Firefox users posts with the same problem but none of the solutions solve the problem. I don't have this problem with Google's Chrome nor with Microsoft's browser. The main website this problem presents itself on is my preferred news site, FoxNews.com.

Since I would prefer to continue using Firefox please find the problem and FIX your Firefox browser! Thank you.

All Replies (3)

more options

Have you checked this? ”Webpage is slowing down your browser” This is the new way the browser tells you there is a problem with the script program(s). https://support.mozilla.org/en-US/kb/warning-unresponsive-script?cache=no

https://support.mozilla.org/en-US/kb/task-manager-tabs-or-extensions-are-slowing-firefox

Helpful?

more options

Thank you, Fred. I changed it from 10 to 25. Although it reduced the number of times I get the message and the lockups are shorter, it didn't completely solve the problem. The message still appears after a couple minutes, the browser locks up for a minute or so and my CPU fan shifts to high speed.

The second links show that the foxnews.com site shows energy use often times over 100 and memory use often over 300 mb. But I knew that was the site and webpages where the problem exists.

Modified by psprgm

Helpful?

more options

Is this with all websites/pages, some, a few?

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.