Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Latest 80.0 update delays loading pages

  • 7 replies
  • 2 have this problem
  • 43 views
  • Last reply by zorto

more options

Hi,

When I updated to 80.0 when new tab is opened it won't immediately start loading pages but it delays for a moment until it starts. I didn't have that issue on version 79.0. Anyone knows how to fix this?

Chosen solution

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Read this answer in context 👍 1

All Replies (7)

more options

Actually any click on any link is delayed... very annoying. 79.0 didn't had that problem.

Helpful?

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Helpful?

more options

In Safe mode it is OK.

Helpful?

more options

Chosen Solution

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Helpful?

more options

I used this: Use recommended performance settings And it worked immediately.

Thank you very much for helping me!

Modified by zorto

Helpful?

more options

Oh God, yet more hours wasted having to 'fiddle about with the blithering computer' because somebody changed something. I do have a life. I don't have a technical brain. All I know is I downloaded an update and now everything is mucked up. I've had to resort to Edge. I can't put my life on hold to beggar about finding out how to get in to Safe mode (not knocking anyone here who is giving helpful advice, just hacked off with Mozilla). Why the heck have we been 'upgraded' to something that's far worse and then have to mess about trying to make it work?

Helpful?

more options

@Jerri I know man, same thoughts exactly. Browser should be easy to use but instead we spend a lot of time wasting it on these things when they upgrade. I am also not high school kid with bunch of free time, we have lives. Hour here, hour there... it's too much wasted.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.