Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I switch this useless searching feature off?

  • 22 replies
  • 1 has this problem
  • 90 views
  • Last reply by cor-el

more options

I don't know where to even start, but how do I turn this annoying feature off?

https://support.mozilla.org/en-US/kb/search-firefox-address-bar?as=u&utm_source=inproduct

I have gone through and clicked a never ending amount of pages and I still cannot find an answer.

I don't want a never ending drop down menu it's annoying and distracting as well as pointless, since it is easy enough to do in the background, I don't need it constantly on in the foreground. There is enough constant garbage to have to sort through, I don't need more garbage added to the visual pile of steaming crap. KISS applies.

Yes I am not happy about it..

Thanks in advance.

All Replies (20)

more options

if you search urlbar in about:config there are many options you can tweak to reduce the amount of suggestions and such

Helpful?

more options

Hello SHempsey,

This is a temporary fix (so I'm told), but I am optimistically hoping that they will give us the opportunity to permanently disable this new feature.

Would you do this please :

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :

browser.urlbar.openViewOnFocus

and set its value to false

Do the same with these preferences :

browser.urlbar.update1

browser.urlbar.update1.interventions

browser.urlbar.update1.searchTips

Then close and restart Firefox.

(if it's only the Top Sites suggestions that you want to get rid of :
setting the value of first preference to "false" will do that)

Modified by McCoy

Helpful?

more options

Thanks for the help.

How do I go back the the previous version of Mozilla..?

Helpful?

more options

SHempsey said

Thanks for the help.

My pleasure, but apparantly you're not happy with it ....

How do I go back the the previous version of Mozilla..?

Please, don't consider downgrading just yet - like I said : I am optimistically hoping that they will come to their senses and that users will have the option to disable this new address bar behavior.

Helpful?

more options

I dunno, seems easier just to switch back.

I hope they do turn this feature off, it's just so much visual mess that I just don't want, or need to look at.

If it ain't broke, don't fix it..

..just keep it super simple, a mantra that doesn't seem to apply.

Helpful?

more options

FWIW : I totally agree with you, but I still keep hoping that they will come
to their senses.

Humor me, will you, and for now just toggle those preferences and wait and see what happens .....

Helpful?

more options

I have, but it has lost all of those similar features that it had in the previous build. If that makes sense..

Helpful?

more options

My problem with this new url bar is that it makes less accessible the bookmarks' bar beneath it on a new tab opening, and I use a lot the bookmarks' bar.

I've fixed the problem setting to false browser.urlbar.openViewOnFocus browser.urlbar.update1 browser.urlbar.update1.interventions

as suggested by McCoy, thanks.

Helpful?

more options

luigi.caradonna said

I've fixed the problem setting to false
browser.urlbar.openViewOnFocus
browser.urlbar.update1
browser.urlbar.update1.interventions

as suggested by McCoy, thanks.

    I'm glad it worked for you, luigi.caradonna - have a nice weekend !

Helpful?

more options

@ SHempsey :

Would you do this please :

Type in the address bar about:config and press Enter (you know the drill by now ...)

Type in the search bar and look for the preference :

keyword.enabled and make sure its value is set to true.

If you had to change the value; then close and restart Firefox.

(keeping my fingers crossed that the value was set to "false" and that changing it to "true" does the trick ..... )

Helpful?

more options

McCoy said

@ SHempsey : Would you do this please : Type in the address bar about:config and press Enter (you know the drill by now ...) Type in the search bar and look for the preference : keyword.enabled and make sure its value is set to true. If you had to change the value; then close and restart Firefox. (keeping my fingers crossed that the value was set to "false" and that changing it to "true" does the trick ..... )

Thanks, appreciate the help very much..

..but it is set to true already..

Helpful?

more options

Bummer ...... :(

Would you please go over these articles and see if maybe there you'll find what you are looking for :

https://support.mozilla.org/en-US/kb/address-bar-autocomplete-firefox

https://support.mozilla.org/en-US/kb/search-firefox-address-bar

(keeping my fingers crossed again .... )

Helpful?

more options

Good lord, what a production...

As I said before, if it ain't broke, don't fix it.

This jumping through all these pages is just utterly ridiculous..

Not at all impressed.

Yeah I am done with this garbage.

How does one switch back to the previous version..?

Modified by SHempsey

Helpful?

more options

Don't get angry now ....

I just may have completely misconstrued your question.

Would you please explain what exactly it is that you want to do/have
Firefox do ?

Maybe someone else will immediately know what you're talking about
and offer you the perfect solution .....

In case that doesn't happen, and you absolutely want to go back to
Firefox version 74.0.1 :

https://support.mozilla.org/en-US/kb/install-older-version-of-firefox

Helpful?

more options

McCoy said

Don't get angry now .... I just may have completely misconstrued your question. Would you please explain what exactly it is that you want to do/have
Firefox do ? Maybe someone else will immediately know what you're talking about
and offer you the perfect solution ..... In case that doesn't happen, and you absolutely want to go back to
Firefox version 74.0.1 : https://support.mozilla.org/en-US/kb/install-older-version-of-firefox

Not angry, just frustrated.

Who in goods green earth though that this would be a good idea to change? Instead of arbitrary updates, maybe it would be a good idea to ask the question to the users first, if it is a good idea to change it in the first place.

Plain and simple, this was a not needed update and or change. There was noting wrong with what the search/url bar was before.

Just because one has the ability to make a change, doesn't mean that the change is a good idea.

If it ain't broke, don't fix it, plain and simple solution.

Thanks for the help, it is much appreciated.

Regards.

Helpful?

more options

For what it's worth :

I absolutely, totally agree with you  !

Helpful?

more options

As I haven't been much help to you,   I have now forwarded this
thread to a fellow contributor and asked him to jump in .....

Helpful?

more options

If you want to disable the drop-down list completely then set this pref to 0 (zero) on the about:config page.

  • browser.urlbar.maxRichResults = 0

Helpful?

more options

cor-el said

If you want to disable the drop-down list completely then set this pref to 0 (zero) on the about:config page.
  • browser.urlbar.maxRichResults = 0

Thanks for the help and info.

1 is what I was looking for.

Regards.

Helpful?

more options

Hi

Double-click the browser.backspace_action preference to display a dialog where you can enter the desired value, then click OK. Your choices are:

0 = Go "Back" in history (default) 1 = Page Up 2 or other value = ignore the keypress

Helpful?

  1. 1
  2. 2
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.