X
Tap here to go to the mobile version of the site.

Support Forum

how to enable DDE in latest Firefox versions

Posted

DDE is a Windows interprocess communication technology that is useful to automate things such as getting the url from Firefox etc. It seems that DDE is being progressively disabled since Firefox Quantum. On FF 57 I can no longer grab the url, on Firefox 70 I can no longer copy text.. Is Mozilla doing this on purpose and is there a way to re-enable DDE?

DDE is a Windows interprocess communication technology that is useful to automate things such as getting the url from Firefox etc. It seems that DDE is being progressively disabled since Firefox Quantum. On FF 57 I can no longer grab the url, on Firefox 70 I can no longer copy text.. Is Mozilla doing this on purpose and is there a way to re-enable DDE?

Chosen solution

Thanks... I apologize I am probably confusing DDE with sending messages to windows. I only had to update the message I was sending to get it working, and it turns out I was never using DDE, but Microsoft Active Accessibility, for getting urls... but my code was buggy

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

jscher2000
  • Top 10 Contributor
8838 solutions 72235 answers

I don't think DDE interfaces are coming back. Firefox supports the Windows Accessibility interface for programmatic access.

What is the Accessibility Service Indicator?

I don't think DDE interfaces are coming back. Firefox supports the Windows Accessibility interface for programmatic access. [[What is the Accessibility Service Indicator?]]
Was this helpful to you?
Quote

Chosen Solution

Thanks... I apologize I am probably confusing DDE with sending messages to windows. I only had to update the message I was sending to get it working, and it turns out I was never using DDE, but Microsoft Active Accessibility, for getting urls... but my code was buggy

Thanks... I apologize I am probably confusing DDE with sending messages to windows. I only had to update the message I was sending to get it working, and it turns out I was never using DDE, but Microsoft Active Accessibility, for getting urls... but my code was buggy
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8838 solutions 72235 answers

Thanks for the update. There's probably a better forum for that kind of programming, but I don't know where you would find it.

Thanks for the update. There's probably a better forum for that kind of programming, but I don't know where you would find it.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.