X
Tap here to go to the mobile version of the site.

Support Forum

tabs are not saved

Posted

Hello! The restore button of the previous session does not work for me, all the tabs, even if they are fixed, disappear after re-opening the browser. I guess something in the settings about: config is changed, although I checked everything regarding the tabs, everything seems to be fine, but I'm not sure. Help with solving this problem.

Hello! The restore button of the previous session does not work for me, all the tabs, even if they are fixed, disappear after re-opening the browser. I guess something in the settings about: config is changed, although I checked everything regarding the tabs, everything seems to be fine, but I'm not sure. Help with solving this problem.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

Question owner

Here I would like to restore this tick, what do you think, what could be the problem

Here I would like to restore this tick, what do you think, what could be the problem
Was this helpful to you?
Quote

Question owner

User_Anonymous said

Here I would like to restore this tick, what do you think, what could be the problem. It is simply locked.
''User_Anonymous [[#answer-1211942|said]]'' <blockquote> Here I would like to restore this tick, what do you think, what could be the problem. It is simply locked. </blockquote>
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8572 solutions 70092 answers

Helpful Reply

Is it possible you have Firefox set to use automatic private browsing mode? You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security

On the right side, scroll down to the History section. What do you have here? Either of these will trigger automatic private browsing mode:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"

In that mode, Firefox does not keep session history, so you can't restore your previous session.

Was that the issue?

Is it possible you have Firefox set to use automatic private browsing mode? You can check that here: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the left column, click Privacy & Security On the right side, scroll down to the History section. What do you have here? Either of these will trigger automatic private browsing mode: * Firefox will: Never remember history * Firefox will: Use custom settings for history + "Always use private browsing mode" In that mode, Firefox does not keep session history, so you can't restore your previous session. Was that the issue?
Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
8572 solutions 70092 answers

Helpful Reply

If that's not the issue, could you check this preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste startup and pause while the list is filtered

(3) Double-click the browser.startup.page preference to display a dialog where you can enter the desired value, change it to 3 then click OK

If the preference cannot be edited because it is Locked, then we'll have to help you track down the file or setting responsible for that.

If that's not the issue, could you check this preference: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''startup''' and pause while the list is filtered (3) Double-click the '''browser.startup.page''' preference to display a dialog where you can enter the desired value, change it to '''3''' then click OK If the preference cannot be edited because it is Locked, then we'll have to help you track down the file or setting responsible for that.
Was this helpful to you? 1
Quote

Question owner

jscher2000 said

Is it possible you have Firefox set to use automatic private browsing mode? You can check that here:
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it
In the left column, click Privacy & Security On the right side, scroll down to the History section. What do you have here? Either of these will trigger automatic private browsing mode:
  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"
In that mode, Firefox does not keep session history, so you can't restore your previous session. Was that the issue?

Thank you very much! It turned out everything was in front of my eyes, but I did not notice such a banal problem, it was really just the default private browsing mode and the story was deleted at each close. So the problem, thanks to your answer decided, thanks! The question is closed.

''jscher2000 [[#answer-1211951|said]]'' <blockquote> Is it possible you have Firefox set to use automatic private browsing mode? You can check that here: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the left column, click Privacy & Security On the right side, scroll down to the History section. What do you have here? Either of these will trigger automatic private browsing mode: * Firefox will: Never remember history * Firefox will: Use custom settings for history + "Always use private browsing mode" In that mode, Firefox does not keep session history, so you can't restore your previous session. Was that the issue? </blockquote> Thank you very much! It turned out everything was in front of my eyes, but I did not notice such a banal problem, it was really just the default private browsing mode and the story was deleted at each close. So the problem, thanks to your answer decided, thanks! The question is closed.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8572 solutions 70092 answers

Thank you for reporting back.

I know some users would like a setting to forget all history except the tabs they left open, but right now, there isn't a built-in way to do that. One option for that would be to use a session management add-on such as:

They store the open tabs independently of Firefox's history.

Thank you for reporting back. I know some users would like a setting to forget all history except the tabs they left open, but right now, there isn't a built-in way to do that. One option for that would be to use a session management add-on such as: * https://addons.mozilla.org/firefox/addon/tab-session-manager/ * https://addons.mozilla.org/firefox/addon/session-sync/ They store the open tabs independently of Firefox's history.
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.